aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/spectrwm/Makefile
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2012-08-28 10:09:38 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2012-08-28 10:09:38 +0000
commit6e327b990ff43350ae8a2cd7befbc4ffe11018a4 (patch)
treea236950a519b8b02eb3fe18cea02aa9d9dd6affa /x11-wm/spectrwm/Makefile
parent9fc4665a82660ca106f6527f68b701c67ed69639 (diff)
downloadports-6e327b990ff43350ae8a2cd7befbc4ffe11018a4.tar.gz
ports-6e327b990ff43350ae8a2cd7befbc4ffe11018a4.zip
Notes
Diffstat (limited to 'x11-wm/spectrwm/Makefile')
-rw-r--r--x11-wm/spectrwm/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/x11-wm/spectrwm/Makefile b/x11-wm/spectrwm/Makefile
index 0983215183fc..b9845136d744 100644
--- a/x11-wm/spectrwm/Makefile
+++ b/x11-wm/spectrwm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= spectrwm
-PORTVERSION= 2.0.0
+PORTVERSION= 2.0.2
CATEGORIES= x11-wm
MASTER_SITES= https://opensource.conformal.com/snapshots/${PORTNAME}/
EXTRACT_SUFX= .tgz
@@ -22,7 +22,7 @@ LIB_DEPENDS+= xcb:${PORTSDIR}/x11/libxcb \
xcb-keysyms:${PORTSDIR}/x11/xcb-util-keysyms
RUN_DEPENDS+= dmenu:${PORTSDIR}/x11/dmenu
-USE_XORG= x11 xft xrandr xt
+USE_XORG= x11 xcursor xft xrandr xt
MAN1= spectrwm.1
USE_LDCONFIG= yes
@@ -40,8 +40,8 @@ do-build:
${CC} ${CFLAGS} -I${LOCALBASE}/include \
-I${LOCALBASE}/include/freetype2 -I${WRKSRC}/freebsd \
-lutil -L${LOCALBASE}/lib -lX11 -lX11-xcb -lxcb -lxcb-icccm \
- -lxcb-keysyms -lxcb-randr -lxcb-util -lxcb-xtest -lXft \
- -lXrandr -DSWM_LIB=\"${PREFIX}/lib/libswmhack.so\" \
+ -lxcb-keysyms -lxcb-randr -lxcb-util -lxcb-xtest -lXcursor \
+ -lXft -lXrandr -DSWM_LIB=\"${PREFIX}/lib/libswmhack.so\" \
-o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c
${CC} ${CFLAGS} -I${LOCALBASE}/include -shared -fpic -DPIC \
-o ${WRKSRC}/libswmhack.so ${WRKSRC}/lib/swm_hack.c