aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/spectrwm
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-04-29 22:07:27 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-04-29 22:07:27 +0000
commit25c4307da135103ea810d65f96f2f1c21e0547b4 (patch)
tree59c19311b74653f76ed5dac83d3bf9e1e1454f20 /x11-wm/spectrwm
parentb0a48406888842dfb5b77a666e063099b1e0edc6 (diff)
downloadports-25c4307da135103ea810d65f96f2f1c21e0547b4.tar.gz
ports-25c4307da135103ea810d65f96f2f1c21e0547b4.zip
Update to 2.3.0
Changelog: https://opensource.conformal.com/fluxbb/viewtopic.php?pid=2444#p2444 Add a local patch to not look for xlock and throw and error on startup if it's not there [1] PR: ports/177754 (in response to) [1] Submitted by: Carlo Strub <cs@FreeBSD.org> [1]
Notes
Notes: svn path=/head/; revision=316849
Diffstat (limited to 'x11-wm/spectrwm')
-rw-r--r--x11-wm/spectrwm/Makefile9
-rw-r--r--x11-wm/spectrwm/distinfo4
-rw-r--r--x11-wm/spectrwm/files/patch-spectrwm.c11
3 files changed, 15 insertions, 9 deletions
diff --git a/x11-wm/spectrwm/Makefile b/x11-wm/spectrwm/Makefile
index de1e16f21343..c3ec0732e6ac 100644
--- a/x11-wm/spectrwm/Makefile
+++ b/x11-wm/spectrwm/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: scrotwm
-# Date created: June 29, 2009
-# Whom: Aragon Gouveia <aragon@phat.za.net>
-#
+# Created by: Aragon Gouveia <aragon@phat.za.net>
# $FreeBSD$
-#
PORTNAME= spectrwm
-PORTVERSION= 2.2.0
-PORTREVISION= 1
+PORTVERSION= 2.3.0
CATEGORIES= x11-wm
MASTER_SITES= https://opensource.conformal.com/snapshots/${PORTNAME}/
EXTRACT_SUFX= .tgz
diff --git a/x11-wm/spectrwm/distinfo b/x11-wm/spectrwm/distinfo
index b47129d377ec..97ef623859bb 100644
--- a/x11-wm/spectrwm/distinfo
+++ b/x11-wm/spectrwm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (spectrwm-2.2.0.tgz) = 9fc4100530005b6d97c1b2fe81e78d0bf10425ecd57f2c523db6b36e83dab103
-SIZE (spectrwm-2.2.0.tgz) = 107382
+SHA256 (spectrwm-2.3.0.tgz) = 9b8902ea167f8570accaed3e016ebc6b7c3b8177928d2e4d57f4b488ee97199f
+SIZE (spectrwm-2.3.0.tgz) = 109384
diff --git a/x11-wm/spectrwm/files/patch-spectrwm.c b/x11-wm/spectrwm/files/patch-spectrwm.c
new file mode 100644
index 000000000000..74f48047480f
--- /dev/null
+++ b/x11-wm/spectrwm/files/patch-spectrwm.c
@@ -0,0 +1,11 @@
+--- spectrwm.c.orig 2013-04-29 23:55:24.573913339 +0200
++++ spectrwm.c 2013-04-29 23:55:44.031914326 +0200
+@@ -6316,7 +6316,7 @@
+ void
+ setup_spawn(void)
+ {
+- setconfspawn("lock", "xlock", 0);
++ setconfspawn("lock", "xlock", SWM_SPAWN_OPTIONAL);
+
+ setconfspawn("term", "xterm", 0);
+ setconfspawn("spawn_term", "xterm", 0);