aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/spectrwm
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2015-07-05 13:59:38 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2015-07-05 13:59:38 +0000
commite03753a767e273ee833d4aa6564ed358bd6d9eb8 (patch)
tree47184d6379c5658529b4f3cb8771eeda3b72cc20 /x11-wm/spectrwm
parente87f560267647965a87442958036ecc9684b01f5 (diff)
downloadports-e03753a767e273ee833d4aa6564ed358bd6d9eb8.tar.gz
ports-e03753a767e273ee833d4aa6564ed358bd6d9eb8.zip
Notes
Diffstat (limited to 'x11-wm/spectrwm')
-rw-r--r--x11-wm/spectrwm/Makefile2
-rw-r--r--x11-wm/spectrwm/distinfo4
-rw-r--r--x11-wm/spectrwm/files/patch-freebsd_util.h39
-rw-r--r--x11-wm/spectrwm/files/patch-spectrwm.conf25
4 files changed, 67 insertions, 3 deletions
diff --git a/x11-wm/spectrwm/Makefile b/x11-wm/spectrwm/Makefile
index c70954e1a4ea..da1a0f6caa08 100644
--- a/x11-wm/spectrwm/Makefile
+++ b/x11-wm/spectrwm/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= spectrwm
-PORTVERSION= 2.6.1
+PORTVERSION= 2.7.2
CATEGORIES= x11-wm
MASTER_SITES= https://opensource.conformal.com/snapshots/${PORTNAME}/
EXTRACT_SUFX= .tgz
diff --git a/x11-wm/spectrwm/distinfo b/x11-wm/spectrwm/distinfo
index 89b950c57e9d..b7ecde6d5390 100644
--- a/x11-wm/spectrwm/distinfo
+++ b/x11-wm/spectrwm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (spectrwm-2.6.1.tgz) = 008ec8e9e262b7b17888592fc5248be9d2b417837f0029da4447f6eab7dffb63
-SIZE (spectrwm-2.6.1.tgz) = 124102
+SHA256 (spectrwm-2.7.2.tgz) = b56cffa01ee2c58515350c1be1940140286fd18778659c6f5ada4595319f97cb
+SIZE (spectrwm-2.7.2.tgz) = 132554
diff --git a/x11-wm/spectrwm/files/patch-freebsd_util.h b/x11-wm/spectrwm/files/patch-freebsd_util.h
new file mode 100644
index 000000000000..9962a37c06c2
--- /dev/null
+++ b/x11-wm/spectrwm/files/patch-freebsd_util.h
@@ -0,0 +1,39 @@
+From 0e4d41f065f7803d096e6c53b3956c820186c3ea Mon Sep 17 00:00:00 2001
+From: Reginald Kennedy <rk@rejii.com>
+Date: Sun, 31 May 2015 07:25:46 +0800
+Subject: [PATCH] Add SIMPLEQ->STAILQ macros for freebsd.
+
+---
+ freebsd/util.h | 18 +++++++++++++++++-
+ 1 files changed, 17 insertions(+), 1 deletions(-)
+
+diff --git a/freebsd/util.h b/freebsd/util.h
+index 4737d42..34b5c36 100644
+--- freebsd/util.h
++++ freebsd/util.h
+@@ -1,5 +1,21 @@
+ #include <libutil.h>
+
+ #ifndef TAILQ_END
+-#define TAILQ_END(head) NULL
++#define TAILQ_END(head) NULL
++#endif
++
++#ifndef SIMPLEQ_HEAD
++#define SIMPLEQ_HEAD STAILQ_HEAD
++#define SIMPLEQ_HEAD_INITIALIZER STAILQ_HEAD_INITIALIZER
++#define SIMPLEQ_ENTRY STAILQ_ENTRY
++#define SIMPLEQ_INIT STAILQ_INIT
++#define SIMPLEQ_INSERT_AFTER STAILQ_INSERT_AFTER
++#define SIMPLEQ_INSERT_HEAD STAILQ_INSERT_HEAD
++#define SIMPLEQ_INSERT_TAIL STAILQ_INSERT_TAIL
++#define SIMPLEQ_EMPTY STAILQ_EMPTY
++#define SIMPLEQ_FIRST STAILQ_FIRST
++#define SIMPLEQ_REMOVE_AFTER STAILQ_REMOVE_AFTER
++#define SIMPLEQ_REMOVE_HEAD STAILQ_REMOVE_HEAD
++#define SIMPLEQ_FOREACH STAILQ_FOREACH
++#define SIMPLEQ_END(head) NULL
+ #endif
+--
+1.7.6
+
diff --git a/x11-wm/spectrwm/files/patch-spectrwm.conf b/x11-wm/spectrwm/files/patch-spectrwm.conf
new file mode 100644
index 000000000000..c4be7da19625
--- /dev/null
+++ b/x11-wm/spectrwm/files/patch-spectrwm.conf
@@ -0,0 +1,25 @@
+From e4d823fc43527b676f631d72cc2cfd22254b15ff Mon Sep 17 00:00:00 2001
+From: Reginald Kennedy <rk@rejii.com>
+Date: Sat, 4 Jul 2015 13:24:24 +0800
+Subject: [PATCH] Fix spectrwm.conf unbind example.
+
+---
+ spectrwm.conf | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/spectrwm.conf b/spectrwm.conf
+index 35948ef..2302580 100644
+--- spectrwm.conf
++++ spectrwm.conf
+@@ -92,7 +92,7 @@
+
+ # To disable validation of the above, free the respective binding(s):
+ # bind[] = MOD+Shift+Delete # disable lock
+-# bind[] = MOD+Shift+Enter # disable term
++# bind[] = MOD+Shift+Return # disable term
+ # bind[] = MOD+p # disable menu
+
+ # Optional default programs that will only be validated if you override:
+--
+1.7.6
+