aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/tvtwm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-29 09:41:47 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-29 09:41:47 +0000
commit050ac776e483524e86cd4afbcaf4da94028a0ede (patch)
treed866e2b8befa19ad2c5697e786c65e75ac1f80f3 /x11-wm/tvtwm
parent557a6c35976f8f01dacb348a2c25edc94cf32d11 (diff)
downloadports-050ac776e483524e86cd4afbcaf4da94028a0ede.tar.gz
ports-050ac776e483524e86cd4afbcaf4da94028a0ede.zip
Notes
Diffstat (limited to 'x11-wm/tvtwm')
-rw-r--r--x11-wm/tvtwm/Makefile2
-rw-r--r--x11-wm/tvtwm/files/patch-Imakefile92
-rw-r--r--x11-wm/tvtwm/files/patch-gram.y30
-rw-r--r--x11-wm/tvtwm/files/patch-icons.c10
-rw-r--r--x11-wm/tvtwm/files/patch-lex.l82
-rw-r--r--x11-wm/tvtwm/files/patch-menus.c10
-rw-r--r--x11-wm/tvtwm/files/patch-parse.c10
-rw-r--r--x11-wm/tvtwm/files/patch-parse.h6
-rw-r--r--x11-wm/tvtwm/files/patch-twm.c14
9 files changed, 106 insertions, 150 deletions
diff --git a/x11-wm/tvtwm/Makefile b/x11-wm/tvtwm/Makefile
index 7b2abbf49d55..d09b8f853da6 100644
--- a/x11-wm/tvtwm/Makefile
+++ b/x11-wm/tvtwm/Makefile
@@ -11,6 +11,8 @@ DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Twm with a virtual desktop
+LICENSE= MIT
+
WRKSRC= ${WRKDIR}/tvtwm
USES= imake
USE_XORG= xbitmaps xpm xmu
diff --git a/x11-wm/tvtwm/files/patch-Imakefile b/x11-wm/tvtwm/files/patch-Imakefile
index a8601c670ae0..f95e0e7a51bc 100644
--- a/x11-wm/tvtwm/files/patch-Imakefile
+++ b/x11-wm/tvtwm/files/patch-Imakefile
@@ -1,59 +1,33 @@
-*** Imakefile.orig Thu Feb 2 18:25:44 1995
---- Imakefile Sun May 30 11:42:08 1999
-***************
-*** 25,31 ****
- XCOMM will define yylineno. If you get an "Undefined symbol: _yylineno"
- XCOMM when linking, adjust this to work on your system.
-
-! #if defined(i386BsdArchitecture) || defined(LinuxArchitecture)
- # ifdef LexCmd
- LEX = LexCmd -l
- # else
---- 25,31 ----
- XCOMM will define yylineno. If you get an "Undefined symbol: _yylineno"
- XCOMM when linking, adjust this to work on your system.
-
-! #if defined(FreeBSDArchitecture) || defined(LinuxArchitecture)
- # ifdef LexCmd
- LEX = LexCmd -l
- # else
-***************
-*** 100,106 ****
- SpecialObjectRule(LocPixmap.o,NullParameter,'-DBITMAPDIR="$(INCDIR)/bitmaps"')
- SpecialObjectRule(twm.o,NullParameter,$(TWM_DEFS))
-
-! #if defined(UltrixArchitecture) || defined(AlphaArchitecture)
- SpecialObjectRule(menus.o,NullParameter,-Olimit 700)
- #endif
-
---- 100,106 ----
- SpecialObjectRule(LocPixmap.o,NullParameter,'-DBITMAPDIR="$(INCDIR)/bitmaps"')
- SpecialObjectRule(twm.o,NullParameter,$(TWM_DEFS))
-
-! #if !defined(FreeBSDArchitecture) && (defined(UltrixArchitecture) || defined(AlphaArchitecture))
- SpecialObjectRule(menus.o,NullParameter,-Olimit 700)
- #endif
-
-***************
-*** 120,129 ****
- XCOMM ln $(BINDIR)/tvtwm $(BINDIR)/twm
-
- #if (ProjectX < 5)
-! InstallNonExec(system.twmrc,$(TWMDIR))
- /* InstallProgram(ssetroot,$(BINDIR)/xsetroot) */
- #else
-! InstallNonExecFile(system.twmrc,$(TWMDIR))
- /* InstallNamedProg(ssetroot,xsetroot,$(BINDIR)) */
- #endif
-
---- 120,129 ----
- XCOMM ln $(BINDIR)/tvtwm $(BINDIR)/twm
-
- #if (ProjectX < 5)
-! /* InstallNonExec(system.twmrc,$(TWMDIR))*/
- /* InstallProgram(ssetroot,$(BINDIR)/xsetroot) */
- #else
-! /* InstallNonExecFile(system.twmrc,$(TWMDIR)) */
- /* InstallNamedProg(ssetroot,xsetroot,$(BINDIR)) */
- #endif
-
+--- Imakefile.orig 1995-02-03 00:25:44 UTC
++++ Imakefile
+@@ -25,7 +25,7 @@ XCOMM the maximum level of compatibility
+ XCOMM will define yylineno. If you get an "Undefined symbol: _yylineno"
+ XCOMM when linking, adjust this to work on your system.
+
+-#if defined(i386BsdArchitecture) || defined(LinuxArchitecture)
++#if defined(FreeBSDArchitecture) || defined(LinuxArchitecture)
+ # ifdef LexCmd
+ LEX = LexCmd -l
+ # else
+@@ -100,7 +100,7 @@ SpecialObjectRule(vdt.o,NullParameter,$(
+ SpecialObjectRule(LocPixmap.o,NullParameter,'-DBITMAPDIR="$(INCDIR)/bitmaps"')
+ SpecialObjectRule(twm.o,NullParameter,$(TWM_DEFS))
+
+-#if defined(UltrixArchitecture) || defined(AlphaArchitecture)
++#if !defined(FreeBSDArchitecture) && (defined(UltrixArchitecture) || defined(AlphaArchitecture))
+ SpecialObjectRule(menus.o,NullParameter,-Olimit 700)
+ #endif
+
+@@ -120,10 +120,10 @@ XCOMM rm -f $(BINDIR)/twm
+ XCOMM ln $(BINDIR)/tvtwm $(BINDIR)/twm
+
+ #if (ProjectX < 5)
+-InstallNonExec(system.twmrc,$(TWMDIR))
++/* InstallNonExec(system.twmrc,$(TWMDIR))*/
+ /* InstallProgram(ssetroot,$(BINDIR)/xsetroot) */
+ #else
+-InstallNonExecFile(system.twmrc,$(TWMDIR))
++/* InstallNonExecFile(system.twmrc,$(TWMDIR)) */
+ /* InstallNamedProg(ssetroot,xsetroot,$(BINDIR)) */
+ #endif
+
diff --git a/x11-wm/tvtwm/files/patch-gram.y b/x11-wm/tvtwm/files/patch-gram.y
index c3d33454903c..b905f59b66de 100644
--- a/x11-wm/tvtwm/files/patch-gram.y
+++ b/x11-wm/tvtwm/files/patch-gram.y
@@ -1,19 +1,11 @@
-*** gram.y.orig Mon Dec 5 07:35:28 1994
---- gram.y Mon Dec 5 07:36:42 1994
-***************
-*** 79,85 ****
- extern int do_single_keyword(), do_string_keyword(), do_number_keyword();
- extern name_list **do_colorlist_keyword();
- extern int do_color_keyword(), do_string_savecolor();
-! extern int yylineno;
- %}
-
- %union
---- 79,85 ----
- extern int do_single_keyword(), do_string_keyword(), do_number_keyword();
- extern name_list **do_colorlist_keyword();
- extern int do_color_keyword(), do_string_savecolor();
-! int yylineno;
- %}
-
- %union
+--- gram.y.orig 1993-11-22 20:10:49 UTC
++++ gram.y
+@@ -79,7 +79,7 @@ unsigned int mods_used = (ShiftMask | Co
+ extern int do_single_keyword(), do_string_keyword(), do_number_keyword();
+ extern name_list **do_colorlist_keyword();
+ extern int do_color_keyword(), do_string_savecolor();
+-extern int yylineno;
++int yylineno;
+ %}
+
+ %union
diff --git a/x11-wm/tvtwm/files/patch-icons.c b/x11-wm/tvtwm/files/patch-icons.c
index 70215ed222b1..315dbccbdc07 100644
--- a/x11-wm/tvtwm/files/patch-icons.c
+++ b/x11-wm/tvtwm/files/patch-icons.c
@@ -1,6 +1,6 @@
---- icons.c-orig 2009-10-10 20:22:14.000000000 +0200
-+++ icons.c 2009-10-10 20:22:13.000000000 +0200
-@@ -233,10 +233,12 @@
+--- icons.c.orig 1995-02-03 00:37:34 UTC
++++ icons.c
+@@ -233,10 +233,12 @@ int *final_x, *final_y;
*final_x = ie->x + (ie->w - iconWidth (tmp_win)) / 2;
*final_y = ie->y + (ie->h - iconHeight (tmp_win)) / 2;
} else {
@@ -13,7 +13,7 @@
*final_x = def_x;
*final_y = def_y;
}
-@@ -299,6 +301,7 @@
+@@ -299,6 +301,7 @@ IconUp (tmp_win)
if (!ir) return; /* outside icon regions, leave alone */
}
@@ -21,7 +21,7 @@
defx = -100;
defy = -100;
PlaceIcon(tmp_win, defx, defy, &x, &y);
-@@ -310,6 +313,7 @@
+@@ -310,6 +313,7 @@ IconUp (tmp_win)
MoveIcon(tmp_win, x, y);
tmp_win->icon_moved = FALSE; /* since we've restored it */
}
diff --git a/x11-wm/tvtwm/files/patch-lex.l b/x11-wm/tvtwm/files/patch-lex.l
index ce4b522b7d6c..bfe8afa19e06 100644
--- a/x11-wm/tvtwm/files/patch-lex.l
+++ b/x11-wm/tvtwm/files/patch-lex.l
@@ -1,47 +1,35 @@
-*** lex.l.orig Wed Mar 10 20:57:51 1993
---- lex.l Mon Dec 5 08:06:40 1994
-***************
-*** 43,48 ****
---- 43,61 ----
-
- extern int ParseError;
-
-+ #undef YY_INPUT
-+ #define YY_INPUT(buf,result,max_size) \
-+ { \
-+ int res = (*twmInputFunc)(); \
-+ if (res == NULL) \
-+ result = YY_NULL; \
-+ else \
-+ { \
-+ buf[0] = res; \
-+ result = 1; \
-+ } \
-+ }
-+
- %}
-
- string \"([^"]|\\.)*\"
-***************
-*** 98,107 ****
- #endif
-
- #undef unput
-! #undef input
- #undef output
- #undef feof
- #define unput(c) twmUnput(c)
-! #define input() (*twmInputFunc)()
- #define output(c) TwmOutput(c)
- #define feof() (1)
---- 111,120 ----
- #endif
-
- #undef unput
-! /*#undef input*/
- #undef output
- #undef feof
- #define unput(c) twmUnput(c)
-! /*#define input() (*twmInputFunc)()*/
- #define output(c) TwmOutput(c)
- #define feof() (1)
+--- lex.l.orig 1993-03-10 20:57:51 UTC
++++ lex.l
+@@ -43,6 +43,19 @@ extern char *ProgramName;
+
+ extern int ParseError;
+
++#undef YY_INPUT
++#define YY_INPUT(buf,result,max_size) \
++ { \
++ int res = (*twmInputFunc)(); \
++ if (res == NULL) \
++ result = YY_NULL; \
++ else \
++ { \
++ buf[0] = res; \
++ result = 1; \
++ } \
++ }
++
+ %}
+
+ string \"([^"]|\\.)*\"
+@@ -98,10 +111,10 @@ yywrap() { return(1);}
+ #endif
+
+ #undef unput
+-#undef input
++/*#undef input*/
+ #undef output
+ #undef feof
+ #define unput(c) twmUnput(c)
+-#define input() (*twmInputFunc)()
++/*#define input() (*twmInputFunc)()*/
+ #define output(c) TwmOutput(c)
+ #define feof() (1)
diff --git a/x11-wm/tvtwm/files/patch-menus.c b/x11-wm/tvtwm/files/patch-menus.c
index ade9218aeda3..75b46d6699e5 100644
--- a/x11-wm/tvtwm/files/patch-menus.c
+++ b/x11-wm/tvtwm/files/patch-menus.c
@@ -1,6 +1,6 @@
---- menus.c-orig 2009-10-10 20:22:14.000000000 +0200
-+++ menus.c 2009-10-10 20:22:13.000000000 +0200
-@@ -2674,14 +2674,20 @@
+--- menus.c.orig 1995-02-09 20:09:18 UTC
++++ menus.c
+@@ -2674,14 +2674,20 @@ ExecuteFunction(func, action, sub, w, tm
if (DeferExecution(context, func, action, Scr->SelectCursor))
return TRUE;
@@ -27,7 +27,7 @@
}
break;
-@@ -3091,6 +3097,50 @@
+@@ -3091,6 +3097,50 @@ ExecuteFunction(func, action, sub, w, tm
RelativeMove(tmp_win, action);
break;
@@ -78,7 +78,7 @@
case F_QUIT:
Done();
break;
-@@ -3188,6 +3238,7 @@
+@@ -3188,6 +3238,7 @@ int func;
case F_DESTROY:
case F_DELETE:
case F_DELETEORDESTROY:
diff --git a/x11-wm/tvtwm/files/patch-parse.c b/x11-wm/tvtwm/files/patch-parse.c
index 1f4331c04dbc..d53b45388359 100644
--- a/x11-wm/tvtwm/files/patch-parse.c
+++ b/x11-wm/tvtwm/files/patch-parse.c
@@ -1,6 +1,6 @@
---- parse.c.orig 2009-10-10 20:22:13.000000000 +0200
-+++ parse.c 2009-10-10 20:22:13.000000000 +0200
-@@ -646,6 +646,7 @@
+--- parse.c.orig 1995-02-03 00:17:00 UTC
++++ parse.c
+@@ -646,6 +646,7 @@ static TwmKeyword keytable[] = {
{ "f.deltastop", FKEYWORD, F_DELTASTOP },
{ "f.destroy", FKEYWORD, F_DESTROY },
{ "f.downiconmgr", FKEYWORD, F_DOWNICONMGR },
@@ -8,7 +8,7 @@
{ "f.exec", FSKEYWORD, F_EXEC },
{ "f.file", FSKEYWORD, F_FILE },
{ "f.focus", FKEYWORD, F_FOCUS },
-@@ -1609,6 +1610,8 @@
+@@ -1609,6 +1610,8 @@ do_squeeze_entry (list, name, type, just
}
}
@@ -17,7 +17,7 @@
static FILE *start_m4(fraw)
FILE *fraw;
{
-@@ -1627,7 +1630,6 @@
+@@ -1627,7 +1630,6 @@ FILE *fraw;
if (fres == 0) {
extern Display *dpy;
extern char *display_name;
diff --git a/x11-wm/tvtwm/files/patch-parse.h b/x11-wm/tvtwm/files/patch-parse.h
index a17641708f2d..c29d39e6af1f 100644
--- a/x11-wm/tvtwm/files/patch-parse.h
+++ b/x11-wm/tvtwm/files/patch-parse.h
@@ -1,6 +1,6 @@
---- parse.h-orig 2009-10-10 20:22:14.000000000 +0200
-+++ parse.h 2009-10-10 20:22:13.000000000 +0200
-@@ -102,6 +102,7 @@
+--- parse.h.orig 1993-12-01 21:01:13 UTC
++++ parse.h
+@@ -102,6 +102,7 @@ extern void TwmOutput();
#define F_CONSTRAINEDMOVE 55
#define F_OPAQUEMOVE 56
#define F_DELETEORDESTROY 57
diff --git a/x11-wm/tvtwm/files/patch-twm.c b/x11-wm/tvtwm/files/patch-twm.c
index 3ee4f71f5fa0..309bbf907b7c 100644
--- a/x11-wm/tvtwm/files/patch-twm.c
+++ b/x11-wm/tvtwm/files/patch-twm.c
@@ -1,6 +1,6 @@
---- twm.c-orig 2009-10-10 20:22:14.000000000 +0200
-+++ twm.c 2009-10-10 20:31:33.000000000 +0200
-@@ -185,6 +185,9 @@
+--- twm.c.orig 1995-02-03 00:14:17 UTC
++++ twm.c
+@@ -185,6 +185,9 @@ static int RedirectError; /* TRUE ==> an
static int CatchRedirectError(); /* for settting RedirectError */
static int TwmErrorHandler(); /* for everything else */
static void SetRootProperties(); /* leave note on root window */
@@ -10,7 +10,7 @@
char Info[INFO_LINES][INFO_SIZE]; /* info strings to print */
int InfoLines;
char *InitFile = NULL;
-@@ -248,6 +251,14 @@
+@@ -248,6 +251,14 @@ main(argc, argv, environ)
int i, j, sync = FALSE;
unsigned long valuemask; /* mask for create windows */
XSetWindowAttributes attributes; /* attributes for create windows */
@@ -25,7 +25,7 @@
int numManaged, firstscrn, lastscrn, scrnum;
extern ColormapWindow *CreateColormapWindow();
SIGNAL_T QueueRestartTwm();
-@@ -631,6 +640,67 @@
+@@ -629,6 +640,67 @@ main(argc, argv, environ)
Scr->iconmgr.twm_win->isicon = TRUE;
/*
@@ -93,7 +93,7 @@
* weed out icon windows
*/
for (i = 0; i < nchildren; i++) {
-@@ -786,6 +856,7 @@
+@@ -784,6 +856,7 @@ QueueRestartTwm()
{
XClientMessageEvent ev;
@@ -101,7 +101,7 @@
ev.type = ClientMessage;
ev.window = Scr->Root;
ev.message_type = _XA_TWM_RESTART;
-@@ -1248,3 +1319,125 @@
+@@ -1246,3 +1319,125 @@ InternUsefulAtoms ()
_XA_TWM_MACHINE = XInternAtom (dpy, "_TWM_MACHINE", False);
}