aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/windowmaker/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-10-10 10:20:07 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-10-10 10:20:07 +0000
commit21479ebd6a358cf1e20de10ad13186a4afa45d0d (patch)
treed14f61a024319409cf6bcdff03bc3f4433114302 /x11-wm/windowmaker/Makefile
parent966d1a37dd6144574ad12fb30dabb9d59b98fadc (diff)
downloadports-21479ebd6a358cf1e20de10ad13186a4afa45d0d.tar.gz
ports-21479ebd6a358cf1e20de10ad13186a4afa45d0d.zip
Notes
Diffstat (limited to 'x11-wm/windowmaker/Makefile')
-rw-r--r--x11-wm/windowmaker/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index e72829e85596..d4cc683665f5 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= windowmaker
-PORTVERSION= 0.65.1
-PORTREVISION= 1
+PORTVERSION= 0.70.0
CATEGORIES= x11-wm windowmaker
MASTER_SITES= ${MASTER_SITE_WINDOWMAKER}
MASTER_SITE_SUBDIR= source/release
@@ -19,7 +18,6 @@ BUILD_DEPENDS= msgfmt-new:${PORTSDIR}/devel/gettext-devel
LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
- PropList.2:${PORTSDIR}/devel/libPropList \
intl.1:${PORTSDIR}/devel/gettext \
Hermes.1:${PORTSDIR}/graphics/Hermes
RUN_DEPENDS= ${X11BASE}/share/WindowMaker/Themes/Checker.themed/style:${PORTSDIR}/graphics/wmicons
@@ -29,8 +27,8 @@ USE_PERL5= yes
USE_X_PREFIX= yes
USE_XPM= yes
WANT_GNOME= yes
-USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= X11BASE=${X11BASE} \
LIBS="-L${LOCALBASE}/lib -lintl" \
CPPFLAGS="-I${LOCALBASE}/include" \
@@ -44,10 +42,11 @@ CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-appspath="${PREFIX}/GNUstep/Apps" \
--enable-hermes \
--disable-debug
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MANLANG= "" sk
MAN1= geticonset.1x getstyle.1x seticons.1x setstyle.1x wdwrite.1x \
- wmaker.1x wmsetbg.1x wsetfont.1x wxcopy.1x wxpaste.1x
+ wcopy.1x wmaker.1x wmsetbg.1x wsetfont.1x wxcopy.1x wxpaste.1x
.include <bsd.port.pre.mk>
@@ -72,6 +71,8 @@ post-patch:
post-install:
@${MKDIR} ${PREFIX}/share/WindowMaker/Sounds
+# XXX
+ @${INSTALL_MAN} ${PREFIX}/man/man1/wcopy.1x ${PREFIX}/man/sk/man1
update-LINGUAS: extract
cd ${WRKSRC}/po && \