aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/windowmaker/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2014-09-04 22:48:56 +0000
committerHiroki Sato <hrs@FreeBSD.org>2014-09-04 22:48:56 +0000
commitfad8bb1f2386d219bbee0062b0785d533b8532be (patch)
tree379eb4e7cefebc01795ad290663e44e786617928 /x11-wm/windowmaker/Makefile
parentff4574084bccb550db6090070943c830b7ce430f (diff)
downloadports-fad8bb1f2386d219bbee0062b0785d533b8532be.tar.gz
ports-fad8bb1f2386d219bbee0062b0785d533b8532be.zip
Notes
Diffstat (limited to 'x11-wm/windowmaker/Makefile')
-rw-r--r--x11-wm/windowmaker/Makefile25
1 files changed, 9 insertions, 16 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index b9bd2a0178b9..205d0d1632ec 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= windowmaker
-PORTVERSION= 0.95.5
-PORTREVISION= 4
+PORTVERSION= 0.95.6
CATEGORIES= x11-wm windowmaker
MASTER_SITES= http://windowmaker.org/pub/%SUBDIR%/
MASTER_SITE_SUBDIR= source/release
@@ -18,14 +17,15 @@ LIB_DEPENDS= libgif.so:${PORTSDIR}/graphics/giflib \
libpng15.so:${PORTSDIR}/graphics/png \
libjbig.so:${PORTSDIR}/graphics/jbigkit \
libtiff.so:${PORTSDIR}/graphics/tiff \
- libwraster.so:${PORTSDIR}/x11-wm/libwraster
-RUN_DEPENDS= libwraster>=${PORTVERSION}:${PORTSDIR}/x11-wm/libwraster \
- ${LOCALBASE}/share/WindowMaker/Themes/LeetWM.themed/style:${PORTSDIR}/graphics/wmicons
+ libwebp.so:${PORTSDIR}/graphics/webp \
+ libMagickWand-6.Q16.so:${PORTSDIR}/graphics/ImageMagick \
+ libwraster.so.5:${PORTSDIR}/x11-wm/libwraster
+RUN_DEPENDS= ${LOCALBASE}/share/WindowMaker/Themes/LeetWM.themed/style:${PORTSDIR}/graphics/wmicons
-USES= libtool pathfix perl5 pkgconfig shebangfix
-SHEBANG_FILES= util/wkdemenu.pl
+USES= libtool shebangfix pathfix perl5 pkgconfig
USE_LDCONFIG= yes
USE_XORG= xft xinerama xmu xpm
+SHEBANG_FILES= util/wkdemenu.pl
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_sys_inotify_h=no
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
@@ -38,24 +38,17 @@ CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-x
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
PORTDOCS= AUTHORS BUGFORM BUGS ChangeLog FAQ FAQ.I18N INSTALL \
INSTALL-WMAKER NEWS README README.definable-cursor TODO
LINGUAS= be bg bs ca cs da de el es et fi fr gl hr hu hy it \
ja ko ms nl no pl pt ro ru sk sv tr zh_CN zh_TW
-INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= DOCS NLS XRANDR
+OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_ENV= LINGUAS="${LINGUAS}"
NLS_CONFIGURE_ENABLE= locale
-XRANDR_USE= XORG=xrandr
-XRANDR_CONFIGURE_ENABLE= xrandr
-
-post-patch:
- @${REINPLACE_CMD} 's,PREFIX,"${PREFIX}",' \
- ${WRKSRC}/WINGs/wapplication.c ${WRKSRC}/WPrefs.app/Menu.c \
- ${WRKSRC}/WPrefs.app/Paths.c ${WRKSRC}/util/wmgenmenu.c
post-install:
@${MKDIR} \