aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/windowmaker/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-07-24 09:00:50 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-07-24 09:00:50 +0000
commit55afef8b54df5d1da615054cbbcb964f39c1e8f7 (patch)
tree21325c0343e323e307a98135d5442b19dbf0ae56 /x11-wm/windowmaker/Makefile
parent1e34811bc22d08793b629cedc02727d2e74477ec (diff)
downloadports-55afef8b54df5d1da615054cbbcb964f39c1e8f7.tar.gz
ports-55afef8b54df5d1da615054cbbcb964f39c1e8f7.zip
Notes
Diffstat (limited to 'x11-wm/windowmaker/Makefile')
-rw-r--r--x11-wm/windowmaker/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index eaa1080e7669..a9d3c34eafd9 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= windowmaker
-PORTVERSION= 0.65.0
-PORTREVISION= 2
+PORTVERSION= 0.65.1
CATEGORIES= x11-wm windowmaker
MASTER_SITES= ${MASTER_SITE_WINDOWMAKER}
MASTER_SITE_SUBDIR= beta/srcs
@@ -15,6 +14,7 @@ DISTNAME= WindowMaker-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
+BUILD_DEPENDS= msgfmt-new:${PORTSDIR}/devel/gettext-devel
LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
@@ -31,9 +31,11 @@ WANT_GNOME= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= X11BASE=${X11BASE} \
- LIBS="-L${LOCALBASE}/lib" \
+ LIBS="-L${LOCALBASE}/lib -lintl" \
CPPFLAGS="-I${LOCALBASE}/include" \
- LINGUAS="${LINGUAS}"
+ LINGUAS="${LINGUAS}" \
+ MSGFMT=${LOCALBASE}/bin/msgfmt-new \
+ XGETTEXT=${LOCALBASE}/bin/xgettext-new
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-nlsdir=${PREFIX}/share/locale \
--with-libs-from="-L${LOCALBASE}/lib" \
@@ -42,6 +44,7 @@ CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--enable-hermes \
--disable-debug
+MANLANG= "" sk
MAN1= geticonset.1x getstyle.1x seticons.1x setstyle.1x wdwrite.1x \
wmaker.1x wmsetbg.1x wsetfont.1x wxcopy.1x wxpaste.1x
@@ -56,7 +59,6 @@ CONFIGURE_ARGS+= --enable-gnome
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde
.else
-.SILENT:
pre-extract:
@${ECHO} "You can add hooks for KDE by defining WITH_KDE"
.endif