aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/windowmaker
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-08 02:09:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-08 02:09:40 +0000
commit074d4bc21e8e4c3ed850764d6f12220b45da2454 (patch)
tree36b624c3a4c57c18eb1b5c01c6b17f3bbc8746ba /x11-wm/windowmaker
parentf45e58359bfd35af847c14948f91c6a8d303233e (diff)
downloadports-074d4bc21e8e4c3ed850764d6f12220b45da2454.tar.gz
ports-074d4bc21e8e4c3ed850764d6f12220b45da2454.zip
Notes
Diffstat (limited to 'x11-wm/windowmaker')
-rw-r--r--x11-wm/windowmaker/Makefile33
-rw-r--r--x11-wm/windowmaker/distinfo4
-rw-r--r--x11-wm/windowmaker/files/patch-Makefile.in11
-rw-r--r--x11-wm/windowmaker/files/patch-WINGs__Examples__Makefile.in20
-rw-r--r--x11-wm/windowmaker/files/patch-WINGs__Extras__Makefile.in23
-rw-r--r--x11-wm/windowmaker/files/patch-WINGs__Makefile.in32
-rw-r--r--x11-wm/windowmaker/files/patch-WINGs__Tests__Makefile.in41
-rw-r--r--x11-wm/windowmaker/files/patch-WPrefs.app__Makefile.in18
-rw-r--r--x11-wm/windowmaker/files/patch-doc__Makefile.in10
-rw-r--r--x11-wm/windowmaker/files/patch-src__Makefile.in27
-rw-r--r--x11-wm/windowmaker/files/patch-util__Makefile.in47
-rw-r--r--x11-wm/windowmaker/pkg-plist39
12 files changed, 264 insertions, 41 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 0844f421cf18..d46826b9ae0e 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME?= windowmaker
-PORTVERSION= 0.95.3
+PORTVERSION= 0.95.4
PORTREVISION?= 0
CATEGORIES= x11-wm windowmaker
MASTER_SITES= http://windowmaker.org/pub/%SUBDIR%/
@@ -12,26 +12,25 @@ DISTNAME= WindowMaker-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT?= GNUstep-compliant NeXTstep window manager clone
+LICENSE?= GPLv2
+
LIB_DEPENDS= gif:${PORTSDIR}/graphics/giflib \
png15:${PORTSDIR}/graphics/png \
jbig:${PORTSDIR}/graphics/jbigkit \
tiff:${PORTSDIR}/graphics/tiff
.if !defined(LWR_SLAVE)
-RUN_DEPENDS= ${LOCALBASE}/share/WindowMaker/Themes/LeetWM.themed/style:${PORTSDIR}/graphics/wmicons
+LIB_DEPENDS+= wraster:${PORTSDIR}/x11-wm/libwraster
+RUN_DEPENDS+= ${LOCALBASE}/share/WindowMaker/Themes/LeetWM.themed/style:${PORTSDIR}/graphics/wmicons
USE_PERL5= yes
OPTIONS_DEFINE= NLS XRANDR
.endif
-MAKE_JOBS_SAFE= yes
-
-USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack
+USE_GCC= any
USE_XORG= xft xinerama xmu xpm
-USE_PKGCONFIG= yes
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+USE_GNOME= gnomehack
+USE_PKGCONFIG= build
+USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-nlsdir=${PREFIX}/share/locale \
--with-libs-from="-L${LOCALBASE}/lib" \
@@ -41,6 +40,10 @@ CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--enable-xinerama --enable-usermenu \
--with-x
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
@@ -51,7 +54,7 @@ CONFIGURE_ENV+= ac_cv_c_inline_asm=no
.endif
.if ${OSVERSION} < 800000
-BROKEN= does not compile on FreeBSD 7.X
+CPPFLAGS+= -DHAVE_SYS_SELECT_H
.endif
.if ${PORT_OPTIONS:MNLS}
@@ -69,13 +72,11 @@ USE_XORG+= xrandr
CONFIGURE_ARGS+= --enable-xrandr
.endif
-CONFLICTS= libwraster-0.*
-
MANLANG= "" cs sk ru
MAN1_EN= geticonset.1x getstyle.1x seticons.1x setstyle.1x wdwrite.1x \
wmaker.1x wmsetbg.1x wxcopy.1x wxpaste.1x get-wings-flags.1 \
- get-wraster-flags.1 get-wutil-flags.1 wdread.1 WindowMaker.1x \
- wmagnify.1x wmgenmenu.1 wmmenugen.1 WPrefs.1x
+ get-wutil-flags.1 wdread.1 WindowMaker.1x wmagnify.1x \
+ wmgenmenu.1 wmmenugen.1 WPrefs.1x
MAN8_EN= upgrade-windowmaker-defaults.8
@@ -111,7 +112,7 @@ post-patch:
post-install:
@${MKDIR} ${PREFIX}/GNUstep/Applications/WPrefs.app/xpm
@${MKDIR} ${PREFIX}/share/WindowMaker/Sounds
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
diff --git a/x11-wm/windowmaker/distinfo b/x11-wm/windowmaker/distinfo
index c916158836cc..20c61534cd6b 100644
--- a/x11-wm/windowmaker/distinfo
+++ b/x11-wm/windowmaker/distinfo
@@ -1,2 +1,2 @@
-SHA256 (WindowMaker-0.95.3.tar.gz) = b5eb88eccbf9a196a617594717797aa38f5c38d13d2ee40e914e153d09c9975a
-SIZE (WindowMaker-0.95.3.tar.gz) = 2780245
+SHA256 (WindowMaker-0.95.4.tar.gz) = 2bea97f00570f05ff115d147457c16abefe496a4fc882a027152ce592d768e45
+SIZE (WindowMaker-0.95.4.tar.gz) = 2789390
diff --git a/x11-wm/windowmaker/files/patch-Makefile.in b/x11-wm/windowmaker/files/patch-Makefile.in
new file mode 100644
index 000000000000..479bd4d6e253
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig
++++ Makefile.in
+@@ -271,7 +271,7 @@
+ BUILT_SOURCES = config-paths.h
+ DISTCLEANFILES = config-paths.h
+ ACLOCAL_AMFLAGS = -I m4
+-SUBDIRS = wrlib WINGs src util po WindowMaker wmlib WPrefs.app doc test
++SUBDIRS = WINGs src util po WindowMaker wmlib WPrefs.app doc test
+ EXTRA_DIST = TODO BUGS BUGFORM FAQ FAQ.I18N INSTALL \
+ INSTALL-WMAKER README.definable-cursor \
+ The-perfect-Window-Maker-patch.txt \
diff --git a/x11-wm/windowmaker/files/patch-WINGs__Examples__Makefile.in b/x11-wm/windowmaker/files/patch-WINGs__Examples__Makefile.in
new file mode 100644
index 000000000000..00af3b229b20
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-WINGs__Examples__Makefile.in
@@ -0,0 +1,20 @@
+--- WINGs/Examples/Makefile.in.orig
++++ WINGs/Examples/Makefile.in
+@@ -254,7 +254,7 @@
+ wprefs_bindir = @wprefs_bindir@
+ wprefs_datadir = @wprefs_datadir@
+ AUTOMAKE_OPTIONS =
+-LDADD = $(top_builddir)/WINGs/libWINGs.la $(top_builddir)/wrlib/libwraster.la \
++LDADD = $(top_builddir)/WINGs/libWINGs.la -lwraster \
+ $(top_builddir)/WINGs/libWUtil.la \
+ @XFTLIBS@ @INTLIBS@
+
+@@ -265,7 +265,7 @@
+ connect_LDADD = $(top_builddir)/WINGs/libWUtil.la @LIBRARY_SEARCH_PATH@ @INTLIBS@
+ server_DEPENDENCIES = $(top_builddir)/WINGs/libWUtil.la
+ server_LDADD = $(top_builddir)/WINGs/libWUtil.la @LIBRARY_SEARCH_PATH@ @INTLIBS@
+-AM_CPPFLAGS = -I$(top_srcdir)/WINGs -I$(top_srcdir)/wrlib -I$(top_srcdir)/src \
++AM_CPPFLAGS = -I$(top_srcdir)/WINGs -I$(top_srcdir)/src \
+ -DRESOURCE_PATH=\"$(datadir)/WINGs\" @HEADER_SEARCH_PATH@
+
+ all: all-am
diff --git a/x11-wm/windowmaker/files/patch-WINGs__Extras__Makefile.in b/x11-wm/windowmaker/files/patch-WINGs__Extras__Makefile.in
new file mode 100644
index 000000000000..58ca9f05b904
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-WINGs__Extras__Makefile.in
@@ -0,0 +1,23 @@
+--- WINGs/Extras/Makefile.in.orig
++++ WINGs/Extras/Makefile.in
+@@ -86,7 +86,6 @@
+ test_SOURCES = test.c
+ test_OBJECTS = test.$(OBJEXT)
+ am__DEPENDENCIES_1 = $(top_builddir)/WINGs/libWINGs.la \
+- $(top_builddir)/wrlib/libwraster.la \
+ $(top_builddir)/WINGs/libWUtil.la
+ test_DEPENDENCIES = wtableview.o wtabledelegates.o \
+ $(am__DEPENDENCIES_1)
+@@ -288,10 +287,10 @@
+ wtableview.h \
+ wtabledelegates.h
+
+-AM_CPPFLAGS = -I$(top_srcdir)/wrlib -I$(top_srcdir)/WINGs \
++AM_CPPFLAGS = -I$(top_srcdir)/WINGs \
+ -DRESOURCE_PATH=\"$(datadir)/WINGs\" @HEADER_SEARCH_PATH@
+
+-LDADD = $(top_builddir)/WINGs/libWINGs.la $(top_builddir)/wrlib/libwraster.la \
++LDADD = $(top_builddir)/WINGs/libWINGs.la -lwraster \
+ $(top_builddir)/WINGs/libWUtil.la \
+ @XFTLIBS@ @INTLIBS@
+
diff --git a/x11-wm/windowmaker/files/patch-WINGs__Makefile.in b/x11-wm/windowmaker/files/patch-WINGs__Makefile.in
new file mode 100644
index 000000000000..e3b91c0d1246
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-WINGs__Makefile.in
@@ -0,0 +1,32 @@
+--- WINGs/Makefile.in.orig
++++ WINGs/Makefile.in
+@@ -76,8 +76,7 @@
+ am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" \
+ "$(DESTDIR)$(pkgconfigdir)"
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+-libWINGs_la_DEPENDENCIES = libWUtil.la \
+- $(top_builddir)/wrlib/libwraster.la
++libWINGs_la_DEPENDENCIES = libWUtil.la
+ am_libWINGs_la_OBJECTS = configuration.lo dragcommon.lo \
+ dragdestination.lo dragsource.lo selection.lo wappresource.lo \
+ wballoon.lo wbox.lo wbrowser.lo wbutton.lo wcolor.lo \
+@@ -335,8 +334,8 @@
+ libWUtil_la_LDFLAGS = -version-info @WUTIL_VERSION@
+ bin_SCRIPTS = get-wings-flags get-wutil-flags
+ lib_LTLIBRARIES = libWUtil.la libWINGs.la
+-LDADD = libWUtil.la libWINGs.la $(top_builddir)/wrlib/libwraster.la @INTLIBS@
+-libWINGs_la_LIBADD = libWUtil.la $(top_builddir)/wrlib/libwraster.la @XLIBS@ @XFTLIBS@ @FCLIBS@ @LIBM@
++LDADD = libWUtil.la libWINGs.la -lwraster @INTLIBS@
++libWINGs_la_LIBADD = libWUtil.la -lwraster @XLIBS@ @XFTLIBS@ @FCLIBS@ @LIBM@
+ libWUtil_la_LIBADD = @LIBBSD@
+ EXTRA_DIST = BUGS make-rgb Examples Extras Tests get-wings-flags.in get-wutil-flags.in
+
+@@ -408,7 +407,7 @@
+
+ AM_CFLAGS =
+ AM_CPPFLAGS = -DLOCALEDIR=\"$(NLSDIR)\" -DRESOURCE_PATH=\"$(datadir)/WINGs\" \
+- -I$(top_srcdir)/WINGs/WINGs -I$(top_srcdir)/wrlib -I$(top_srcdir)/src \
++ -I$(top_srcdir)/WINGs/WINGs -I$(top_srcdir)/src \
+ @XFTFLAGS@ @HEADER_SEARCH_PATH@
+
+ pkgconfigdir = $(libdir)/pkgconfig
diff --git a/x11-wm/windowmaker/files/patch-WINGs__Tests__Makefile.in b/x11-wm/windowmaker/files/patch-WINGs__Tests__Makefile.in
new file mode 100644
index 000000000000..75a1f6362222
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-WINGs__Tests__Makefile.in
@@ -0,0 +1,41 @@
+--- WINGs/Tests/Makefile.in.orig
++++ WINGs/Tests/Makefile.in
+@@ -56,7 +56,6 @@
+ testmywidget_OBJECTS = $(am_testmywidget_OBJECTS)
+ testmywidget_LDADD = $(LDADD)
+ testmywidget_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.la \
+- $(top_builddir)/wrlib/libwraster.la \
+ $(top_builddir)/WINGs/libWUtil.la
+ AM_V_lt = $(am__v_lt_$(V))
+ am__v_lt_ = $(am__v_lt_$(AM_DEFAULT_VERBOSITY))
+@@ -65,13 +64,11 @@
+ wmfile_OBJECTS = wmfile.$(OBJEXT)
+ wmfile_LDADD = $(LDADD)
+ wmfile_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.la \
+- $(top_builddir)/wrlib/libwraster.la \
+ $(top_builddir)/WINGs/libWUtil.la
+ wmquery_SOURCES = wmquery.c
+ wmquery_OBJECTS = wmquery.$(OBJEXT)
+ wmquery_LDADD = $(LDADD)
+ wmquery_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.la \
+- $(top_builddir)/wrlib/libwraster.la \
+ $(top_builddir)/WINGs/libWUtil.la
+ wtest_SOURCES = wtest.c
+ wtest_OBJECTS = wtest.$(OBJEXT)
+@@ -262,14 +259,14 @@
+ wprefs_bindir = @wprefs_bindir@
+ wprefs_datadir = @wprefs_datadir@
+ AUTOMAKE_OPTIONS =
+-LDADD = $(top_builddir)/WINGs/libWINGs.la $(top_builddir)/wrlib/libwraster.la \
++LDADD = $(top_builddir)/WINGs/libWINGs.la -lwraster \
+ $(top_builddir)/WINGs/libWUtil.la \
+ @XFTLIBS@ @INTLIBS@
+
+ testmywidget_SOURCES = testmywidget.c mywidget.c mywidget.h
+ wtest_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.la
+ EXTRA_DIST = logo.xpm upbtn.xpm wm.html wm.png
+-AM_CPPFLAGS = -I$(top_srcdir)/WINGs -I$(top_srcdir)/wrlib -I$(top_srcdir)/src \
++AM_CPPFLAGS = -I$(top_srcdir)/WINGs -I$(top_srcdir)/src \
+ -DRESOURCE_PATH=\"$(datadir)/WINGs\" @XFTFLAGS@ @HEADER_SEARCH_PATH@
+
+ all: all-am
diff --git a/x11-wm/windowmaker/files/patch-WPrefs.app__Makefile.in b/x11-wm/windowmaker/files/patch-WPrefs.app__Makefile.in
new file mode 100644
index 000000000000..2aefc1c2ecc0
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-WPrefs.app__Makefile.in
@@ -0,0 +1,18 @@
+--- WPrefs.app/Makefile.in.orig
++++ WPrefs.app/Makefile.in
+@@ -347,13 +347,13 @@
+
+ AM_CFLAGS =
+ AM_CPPFLAGS = -DLOCALEDIR=\"$(NLSDIR)\" -DRESOURCE_PATH=\"$(wpdatadir)\" -DWMAKER_RESOURCE_PATH=\"$(pkgdatadir)\" \
+- -I$(top_srcdir)/wrlib -I$(top_srcdir)/WINGs @HEADER_SEARCH_PATH@
++ -I$(top_srcdir)/WINGs @HEADER_SEARCH_PATH@
+
+ WPrefs_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.la
+ WPrefs_LDADD = \
+ $(top_builddir)/WINGs/libWINGs.la\
+ $(top_builddir)/WINGs/libWUtil.la\
+- $(top_builddir)/wrlib/libwraster.la \
++ -lwraster \
+ @XLFLAGS@ @XLIBS@ \
+ @FCLIBS@ \
+ @INTLIBS@
diff --git a/x11-wm/windowmaker/files/patch-doc__Makefile.in b/x11-wm/windowmaker/files/patch-doc__Makefile.in
new file mode 100644
index 000000000000..b33664598232
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-doc__Makefile.in
@@ -0,0 +1,10 @@
+--- doc/Makefile.in.orig
++++ doc/Makefile.in
+@@ -282,7 +282,6 @@
+ geticonset.1x \
+ getstyle.1x \
+ get-wings-flags.1 \
+- get-wraster-flags.1 \
+ get-wutil-flags.1 \
+ seticons.1x \
+ setstyle.1x \
diff --git a/x11-wm/windowmaker/files/patch-src__Makefile.in b/x11-wm/windowmaker/files/patch-src__Makefile.in
new file mode 100644
index 000000000000..7209bc1ae45b
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-src__Makefile.in
@@ -0,0 +1,27 @@
+--- src/Makefile.in.orig
++++ src/Makefile.in
+@@ -72,8 +72,7 @@
+ wmspec.$(OBJEXT) workspace.$(OBJEXT)
+ wmaker_OBJECTS = $(am_wmaker_OBJECTS)
+ wmaker_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.la \
+- $(top_builddir)/WINGs/libWUtil.la \
+- $(top_builddir)/wrlib/libwraster.la
++ $(top_builddir)/WINGs/libWUtil.la
+ AM_V_lt = $(am__v_lt_$(V))
+ am__v_lt_ = $(am__v_lt_$(AM_DEFAULT_VERBOSITY))
+ am__v_lt_0 = --silent
+@@ -365,13 +364,12 @@
+ AM_CFLAGS =
+ AM_CPPFLAGS = \
+ $(DFLAGS) -DLOCALEDIR=\"$(NLSDIR)\" \
+- -I$(top_srcdir)/wrlib \
+ -I$(top_srcdir)/WINGs @HEADER_SEARCH_PATH@
+
+ wmaker_LDADD = \
+ $(top_builddir)/WINGs/libWINGs.la\
+ $(top_builddir)/WINGs/libWUtil.la\
+- $(top_builddir)/wrlib/libwraster.la\
++ -lwraster \
+ @XLFLAGS@ \
+ @LIBXRANDR@ \
+ @LIBXINERAMA@ \
diff --git a/x11-wm/windowmaker/files/patch-util__Makefile.in b/x11-wm/windowmaker/files/patch-util__Makefile.in
new file mode 100644
index 000000000000..18d98467d7a1
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-util__Makefile.in
@@ -0,0 +1,47 @@
+--- util/Makefile.in.orig
++++ util/Makefile.in
+@@ -91,8 +91,7 @@
+ wmagnify_SOURCES = wmagnify.c
+ wmagnify_OBJECTS = wmagnify.$(OBJEXT)
+ wmagnify_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.la \
+- $(top_builddir)/WINGs/libWUtil.la \
+- $(top_builddir)/wrlib/libwraster.la
++ $(top_builddir)/WINGs/libWUtil.la
+ am_wmgenmenu_OBJECTS = wmgenmenu.$(OBJEXT)
+ wmgenmenu_OBJECTS = $(am_wmgenmenu_OBJECTS)
+ wmgenmenu_DEPENDENCIES = $(top_builddir)/WINGs/libWUtil.la
+@@ -104,8 +103,7 @@
+ wmsetbg_SOURCES = wmsetbg.c
+ wmsetbg_OBJECTS = wmsetbg.$(OBJEXT)
+ wmsetbg_DEPENDENCIES = $(top_builddir)/WINGs/libWINGs.la \
+- $(top_builddir)/WINGs/libWUtil.la \
+- $(top_builddir)/wrlib/libwraster.la
++ $(top_builddir)/WINGs/libWUtil.la
+ wxcopy_SOURCES = wxcopy.c
+ wxcopy_OBJECTS = wxcopy.$(OBJEXT)
+ wxcopy_DEPENDENCIES =
+@@ -369,7 +367,7 @@
+ bin_SCRIPTS = wmaker.inst wm-oldmenu2new wkdemenu.pl
+ EXTRA_DIST = wmaker.inst.in bughint wm-oldmenu2new directjpeg.c wkdemenu.pl
+ AM_CPPFLAGS = -DLOCALEDIR=\"$(NLSDIR)\" \
+- $(DFLAGS) -I$(top_srcdir)/WINGs -I$(top_srcdir)/wrlib \
++ $(DFLAGS) -I$(top_srcdir)/WINGs \
+ @HEADER_SEARCH_PATH@ \
+ -DETCDIR=\"sysconfdir\" -DDATADIR=\"pkgdatadir\"
+
+@@ -392,13 +390,13 @@
+ wmagnify_LDADD = \
+ $(top_builddir)/WINGs/libWINGs.la \
+ $(top_builddir)/WINGs/libWUtil.la \
+- $(top_builddir)/wrlib/libwraster.la \
++ -lwraster \
+ @XLFLAGS@ @XLIBS@ @INTLIBS@
+
+ wmsetbg_LDADD = \
+ $(top_builddir)/WINGs/libWINGs.la \
+ $(top_builddir)/WINGs/libWUtil.la \
+- $(top_builddir)/wrlib/libwraster.la \
++ -lwraster \
+ @XLFLAGS@ @LIBXINERAMA@ @XLIBS@ @INTLIBS@
+
+ wmgenmenu_LDADD = \
diff --git a/x11-wm/windowmaker/pkg-plist b/x11-wm/windowmaker/pkg-plist
index 9dd51a7d2604..bb8000d35308 100644
--- a/x11-wm/windowmaker/pkg-plist
+++ b/x11-wm/windowmaker/pkg-plist
@@ -74,7 +74,6 @@ GNUstep/Applications/WPrefs.app/tiff/workspacename.tiff
GNUstep/Applications/WPrefs.app/tiff/xis.tiff
bin/convertfonts
bin/get-wings-flags
-bin/get-wraster-flags
bin/get-wutil-flags
bin/geticonset
bin/getstyle
@@ -100,26 +99,20 @@ etc/WindowMaker/WindowMaker
include/WINGs/WINGs.h
include/WINGs/WINGsP.h
include/WINGs/WUtil.h
-include/wraster.h
include/WMaker.h
lib/libWINGs.a
lib/libWINGs.la
lib/libWINGs.so
lib/libWINGs.so.2
+lib/libWMaker.a
+lib/libWMaker.la
+lib/libWMaker.so
+lib/libWMaker.so.1
lib/libWUtil.a
lib/libWUtil.la
lib/libWUtil.so
lib/libWUtil.so.2
-lib/libwraster.a
-lib/libwraster.la
-lib/libwraster.so
-lib/libwraster.so.4
-lib/libWMaker.so.1
-lib/libWMaker.so
-lib/libWMaker.la
-lib/libWMaker.a
libdata/pkgconfig/WINGs.pc
-libdata/pkgconfig/wrlib.pc
share/WINGs/Images.tiff
share/WINGs/Images.xpm
share/WINGs/defaultIcon.tiff
@@ -349,19 +342,19 @@ share/WindowMaker/wmmacros
%%NLS%%share/locale/zh_CN/LC_MESSAGES/WindowMaker.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/WPrefs.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/WindowMaker.mo
-@dirrm GNUstep/Applications/WPrefs.app/tiff
+@dirrmtry share/locale/hy/LC_MESSAGES
+@dirrmtry share/locale/hy
+@dirrm share/WindowMaker/Styles
+@dirrm share/WindowMaker/Sounds
+@dirrm share/WindowMaker/IconSets
+@dirrm share/WindowMaker/Backgrounds
+@dirrm share/WINGs
+@dirrmtry man/sk/man1
+@dirrmtry man/sk
+@dirrm include/WINGs
+@dirrm etc/WindowMaker
@dirrm GNUstep/Applications/WPrefs.app/xpm
+@dirrm GNUstep/Applications/WPrefs.app/tiff
@dirrm GNUstep/Applications/WPrefs.app
@dirrm GNUstep/Applications
@dirrm GNUstep
-@dirrm etc/WindowMaker
-@dirrm include/WINGs
-@dirrm man/sk/man1
-@dirrm man/sk
-@dirrmtry share/locale/hy/LC_MESSAGES
-@dirrmtry share/locale/hy
-@dirrm share/WINGs
-@dirrm share/WindowMaker/Backgrounds
-@dirrm share/WindowMaker/IconSets
-@dirrm share/WindowMaker/Sounds
-@dirrm share/WindowMaker/Styles