aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/wmakerconf/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-10 01:57:34 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-10 01:57:34 +0000
commit48bd23fd97cb80e932c96f011b8a78aff424360d (patch)
tree3a468fd4309b55a2aa013bcaceb69268953dc480 /x11-wm/wmakerconf/Makefile
parente4e8a4e1537ea21b78a22fd32729f3622b29351d (diff)
downloadports-48bd23fd97cb80e932c96f011b8a78aff424360d.tar.gz
ports-48bd23fd97cb80e932c96f011b8a78aff424360d.zip
Notes
Diffstat (limited to 'x11-wm/wmakerconf/Makefile')
-rw-r--r--x11-wm/wmakerconf/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-wm/wmakerconf/Makefile b/x11-wm/wmakerconf/Makefile
index 5a9ed514e2b6..b79f93b8ece4 100644
--- a/x11-wm/wmakerconf/Makefile
+++ b/x11-wm/wmakerconf/Makefile
@@ -14,25 +14,26 @@ COMMENT= Configuration tool for Window Maker
LICENSE= GPLv2
-LIB_DEPENDS= wraster.4:${PORTSDIR}/x11-wm/windowmaker
+LIB_DEPENDS= libwraster.so:${PORTSDIR}/x11-wm/windowmaker
RUN_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GNOME= gtk20
-USES= gettext pkgconfig perl5 gmake
+USES= gettext pkgconfig perl5 gmake shebangfix
+SHEBANG_FILES= scripts/getfile.pl.in scripts/upgrade.pl.in
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wmakerdataprefix="${LOCALBASE}/share" \
--with-wmakeretcprefix="${LOCALBASE}/share"
-MAN1= mkpreview.1 wmakerconf.1
-
-NO_STAGE= yes
post-extract:
@${FIND} ${WRKSRC} -name "*.gmo" -delete
post-patch:
@${REINPLACE_CMD} -e 's|lynx wget|lynx fetch|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$(prefix)/share/locale|${STAGEDIR}${PREFIX}/share/locale|g' \
+ ${WRKSRC}/data/po/Makefile.am ${WRKSRC}/data/po/Makefile.in \
+ ${WRKSRC}/po/Makefile.in.in
@${REINPLACE_CMD} -e '/chmod 0/d' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -E '/\/usr\/share/d; \
s|/usr/local|${LOCALBASE}|g ; \