aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/wmanager
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2008-05-24 16:15:52 +0000
committerPeter Pentchev <roam@FreeBSD.org>2008-05-24 16:15:52 +0000
commitf2cd05db50e72a85678b4963d948067b3e0a337d (patch)
tree92de0a01131adfbf302e793d93fbec905d4520c7 /x11-wm/wmanager
parent8581757f83eeb9c8af9e04f0e7df94510264ee70 (diff)
downloadports-f2cd05db50e72a85678b4963d948067b3e0a337d.tar.gz
ports-f2cd05db50e72a85678b4963d948067b3e0a337d.zip
Notes
Diffstat (limited to 'x11-wm/wmanager')
-rw-r--r--x11-wm/wmanager/Makefile10
-rw-r--r--x11-wm/wmanager/files/patch-aa41
-rw-r--r--x11-wm/wmanager/files/patch-ab29
-rw-r--r--x11-wm/wmanager/files/patch-inc::WManager.H16
-rw-r--r--x11-wm/wmanager/files/pkg-message.in5
-rw-r--r--x11-wm/wmanager/pkg-message5
6 files changed, 85 insertions, 21 deletions
diff --git a/x11-wm/wmanager/Makefile b/x11-wm/wmanager/Makefile
index 33ddd5c2a759..9daaced0c7c0 100644
--- a/x11-wm/wmanager/Makefile
+++ b/x11-wm/wmanager/Makefile
@@ -26,6 +26,14 @@ MAKE_ENV= CXX="${CXX}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+OPTIONS= ADDONS "Install the helper scripts and manpages" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ADDONS)
+RUN_DEPENDS+= wmanager-loop:${PORTSDIR}/x11-wm/wmanager-addons
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmanager ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@@ -38,4 +46,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/.xinitrc ${EXAMPLESDIR}/xinitrc_sample
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/wmanager/files/patch-aa b/x11-wm/wmanager/files/patch-aa
index 982b0eddc1c0..81056832f586 100644
--- a/x11-wm/wmanager/files/patch-aa
+++ b/x11-wm/wmanager/files/patch-aa
@@ -1,11 +1,15 @@
$FreeBSD$
---- Makefile.orig Mon Nov 15 00:29:24 1999
-+++ Makefile Sat Oct 26 06:02:46 2002
-@@ -29,17 +29,21 @@
+diff -urN -urN -x .svn ../vendor/wmanager/Makefile ./Makefile
+--- ../vendor/wmanager/Makefile 2007-12-11 12:42:04.000000000 +0200
++++ ./Makefile 2008-05-21 18:21:47.000000000 +0300
+@@ -28,39 +28,39 @@
+ # make settings
SHELL = /bin/sh
MAKEFLAGS = --print-directory
++PREFIX ?= /usr/local
++LOCALBASE ?= /usr/local
+# base settings
+bindir = $(PREFIX)/bin
@@ -18,8 +22,13 @@ $FreeBSD$
-CXX = g++
-CXXFLAGS = -I$(incdir) -O2 -Wall -pedantic #-DDEBUG=1 -g3
-
-+CXX ?= g++
-+CXXFLAGS+= -I$(fltkinc) -I$(incdir) $(PTHREAD_CFLAGS) #-DDEBUG=1 -g3
++CXX ?= g++
++CXXFLAGS_WARN ?= -Wall -W
++CXXFLAGS_OPT ?= -O2 -fno-strict-aliasing -pipe
++#CXXFLAGS_DBG ?= -g -DDEBUG
++CXXFLAGS_DBG ?=
++CXXFLAGS ?= ${CXXFLAGS_WARN} ${CXXFLAGS_DBG} ${CXXFLAGS_OPT}
++CXXFLAGS += -I${fltkinc} -I${incdir} ${PTHREAD_CFLAGS}
# linker settings
-LD = g++
@@ -27,12 +36,17 @@ $FreeBSD$
-LDDIRS = -L/usr/X11R6/lib -L/usr/lib -L/usr/local/lib
-
+LD = $(CXX)
-+LDFLAGS = -lGL -lfltk -lXext -lX11 -lm $(PTHREAD_LIBS)
++LDFLAGS ?= -lGL -lfltk -lXext -lX11 -lm ${PTHREAD_LIBS}
+LDDIRS = -L$(x11lib)
# install settings
- INSTALL = /usr/bin/install
-@@ -50,17 +54,6 @@
+-INSTALL = /usr/bin/install
+-INSTALL_FLAGS = --strip
++INSTALL ?= install
++STRIP ?= -s
+
+
+ # documentation tool
DOCTOOL = perceps
DOCTOOL_FLAGS = -a -b -f -h -m -r
@@ -50,7 +64,7 @@ $FreeBSD$
# documentational files for developer
docdir = ./doc
templates = $(docdir)/templates
-@@ -82,8 +75,7 @@
+@@ -82,8 +82,7 @@
# project version
VERSION = 0.1.1
@@ -60,3 +74,12 @@ $FreeBSD$
wmanager: $(OBJ)
$(LD) -o $@ $^ $(LDDIRS) $(LDFLAGS)
+@@ -92,7 +91,7 @@
+ $(LD) -o wmanager $^ $(LDDIRS) $(LDFLAGS) -static
+
+ install: wmanager
+- $(INSTALL) $< $(bindir)/$<
++ $(INSTALL) $(STRIP) $< ${DESTDIR}$(bindir)/$<
+
+ clean:
+ @rm -f $(OBJ) wmanager
diff --git a/x11-wm/wmanager/files/patch-ab b/x11-wm/wmanager/files/patch-ab
index d33d88b1aa75..1866ad3a1155 100644
--- a/x11-wm/wmanager/files/patch-ab
+++ b/x11-wm/wmanager/files/patch-ab
@@ -1,8 +1,11 @@
---- src/WManager.cc.orig Mon Nov 15 00:28:36 1999
-+++ src/WManager.cc Sun Nov 2 02:45:05 2003
-@@ -25,7 +25,10 @@
+diff -urN -urN -x .svn ../vendor/wmanager/src/WManager.cc ./src/WManager.cc
+--- ../vendor/wmanager/src/WManager.cc 2007-12-11 12:42:04.000000000 +0200
++++ ./src/WManager.cc 2007-12-17 16:09:16.000000000 +0200
+@@ -24,8 +24,12 @@
+ // SYSTEM INCLUDES /////////////////////////////////
#include <string> // standard string class
#include <fstream> // file streams
++#include <cstdlib> // 'exit'
#include <cstring> // only for 'strtok'
+#include <iostream>
#include <pwd.h> // for home directory
@@ -11,7 +14,7 @@
// PROJECT INCLUDES ////////////////////////////////
-@@ -36,6 +39,7 @@
+@@ -36,6 +40,7 @@
// LOCAL INCLUDES //////////////////////////////////
#include <FL/fl_message.H> // message window
@@ -19,3 +22,21 @@
// constructor
WManager::WManager()
+@@ -302,7 +307,7 @@
+ } else {
+ fl_alert("Error near %s while parsing configuration file %s!"
+ "Try to read on...",
+- name->c_str(), _ConfigurationFilename);
++ name->c_str(), _ConfigurationFilename->c_str());
+ } // end if
+ } // end if
+ }
+@@ -310,7 +315,7 @@
+
+ // cut rest from the beginning of str
+ char*
+-WManager::_CutString(char* str, char* rest)
++WManager::_CutString(const char* str, const char* rest)
+ {
+ int i = 0;
+ int n = 0;
diff --git a/x11-wm/wmanager/files/patch-inc::WManager.H b/x11-wm/wmanager/files/patch-inc::WManager.H
index a2e5df36c386..0588a68b898b 100644
--- a/x11-wm/wmanager/files/patch-inc::WManager.H
+++ b/x11-wm/wmanager/files/patch-inc::WManager.H
@@ -1,6 +1,7 @@
---- inc/WManager.H.orig Mon Nov 15 00:28:36 1999
-+++ inc/WManager.H Sun Nov 2 02:38:20 2003
-@@ -80,10 +80,10 @@
+diff -urN -urN -x .svn ../vendor/wmanager/inc/WManager.H ./inc/WManager.H
+--- ../vendor/wmanager/inc/WManager.H 2007-12-11 12:42:04.000000000 +0200
++++ ./inc/WManager.H 2007-12-17 16:00:13.000000000 +0200
+@@ -80,17 +80,17 @@
private:
Interface* _Interface;
@@ -13,3 +14,12 @@
void
_TokenizeAndAddToBrowser(char* entry);
+
+ char*
+- _CutString(char* str,
+- char* sub);
++ _CutString(const char* str,
++ const char* sub);
+ };
+
+ #endif // WManager_H
diff --git a/x11-wm/wmanager/files/pkg-message.in b/x11-wm/wmanager/files/pkg-message.in
index 53ee339c45f4..427e446625ae 100644
--- a/x11-wm/wmanager/files/pkg-message.in
+++ b/x11-wm/wmanager/files/pkg-message.in
@@ -1,3 +1,4 @@
-Docs have been installed in /usr/X11R6/share/wmanager/.
+Documentation has been installed in /usr/local/share/doc/wmanager/ and
+example files in /usr/local/share/examples/wmanager/
You are advised to have a look at the sample .wmanagerrc
-and .xinitrc's available there.
+and .xinitrc files available there.
diff --git a/x11-wm/wmanager/pkg-message b/x11-wm/wmanager/pkg-message
index 53ee339c45f4..427e446625ae 100644
--- a/x11-wm/wmanager/pkg-message
+++ b/x11-wm/wmanager/pkg-message
@@ -1,3 +1,4 @@
-Docs have been installed in /usr/X11R6/share/wmanager/.
+Documentation has been installed in /usr/local/share/doc/wmanager/ and
+example files in /usr/local/share/examples/wmanager/
You are advised to have a look at the sample .wmanagerrc
-and .xinitrc's available there.
+and .xinitrc files available there.