aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/wmfs/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-14 10:35:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-14 10:35:10 +0000
commit14b6ba7a44edea24098bea3a011951d179bd5be0 (patch)
tree6e6d669d0e6462335c051b349171fd5cbdd0cb3b /x11-wm/wmfs/Makefile
parent614a36a6043c67f3ea100a49ad18f05828463dda (diff)
WMFS, as known as Window Manager From Scratch, is a very very
lightweight window manager for X. The goal of this project is to make a very basic, lightweight and dynamic WM. The result is for now a little WM usable for daily use. WWW: http://wmfs.sangor.net/ PR: ports/129507 Submitted by: Dennis Herrmann <adox at mcx2.org>
Notes
Notes: svn path=/head/; revision=224221
Diffstat (limited to 'x11-wm/wmfs/Makefile')
-rw-r--r--x11-wm/wmfs/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-wm/wmfs/Makefile b/x11-wm/wmfs/Makefile
new file mode 100644
index 000000000000..d00c149bb9ab
--- /dev/null
+++ b/x11-wm/wmfs/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: wmfs
+# Date created: 08 December 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmfs
+DISTVERSION= 0.1rc3
+CATEGORIES= x11-wm
+MASTER_SITES=http://wmfs.sangor.net/ \
+ http://mirror.mcx2.org/
+
+MAINTAINER= adox@mcx2.org
+COMMENT= A floating and tiling Window Manager From Scratch
+
+BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc \
+ xmlto:${PORTSDIR}/textproc/xmlto
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2 \
+ confuse.0:${PORTSDIR}/devel/libconfuse
+
+USE_GNOME= pkgconfig
+USE_CMAKE= yes
+USE_XORG= x11 xft xpm
+
+MAN1= ${PORTNAME}.1
+MANCOMPRESSED= yes
+
+PLIST_FILES= bin/wmfs \
+ etc/xdg/wmfs/wmfsrc \
+ %%DOCSDIR%%/TODO \
+ %%DOCSDIR%%/README \
+ %%DOCSDIR%%/CHANGELOG \
+ %%DOCSDIR%%/wmfsrc
+PLIST_DIRS= %%DOCSDIR%% etc/xdg/wmfs etc/xdg
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|share/$${PROJECT_NAME})|${DOCSDIR})|g' \
+ -e 's|$${PREFIX}/share/man|/$${PREFIX}/man|g' \
+ -e 's|$${SYSCONFDIR}/xdg|${PREFIX}/etc/xdg|g' ${WRKSRC}/CMakeLists.txt
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/wmfs ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TODO ${DOCSDIR}/TODO
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
+ ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${DOCSDIR}/CHANGELOG
+ ${INSTALL_DATA} ${WRKSRC}/wmfsrc ${DOCSDIR}/wmfsrc
+.endif
+
+ @${CAT} ${PKGMESSAGE} | ${SED} "s|PREFIX|${PREFIX}|g" \
+ ${PKGDIR}/pkg-message
+
+.include <bsd.port.post.mk>