aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/xfce4-panel
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-03-03 16:08:46 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-03-03 16:08:46 +0000
commit6a2157983a8ba9def323d452faf150a447002eb2 (patch)
tree7377d9a6e6e281212ae4e0231a8d0819ee25e317 /x11-wm/xfce4-panel
parenta6005117606a1fc60787de3e56f9f29f85943614 (diff)
downloadports-6a2157983a8ba9def323d452faf150a447002eb2.tar.gz
ports-6a2157983a8ba9def323d452faf150a447002eb2.zip
Notes
Diffstat (limited to 'x11-wm/xfce4-panel')
-rw-r--r--x11-wm/xfce4-panel/Makefile2
-rw-r--r--x11-wm/xfce4-panel/files/patch-plugins__actions__actions.c38
2 files changed, 39 insertions, 1 deletions
diff --git a/x11-wm/xfce4-panel/Makefile b/x11-wm/xfce4-panel/Makefile
index 042abbb3ff73..4ed634b3c2a2 100644
--- a/x11-wm/xfce4-panel/Makefile
+++ b/x11-wm/xfce4-panel/Makefile
@@ -4,7 +4,7 @@
PORTNAME= xfce4-panel
PORTVERSION= 4.10.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-wm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DIST_SUBDIR= xfce4
diff --git a/x11-wm/xfce4-panel/files/patch-plugins__actions__actions.c b/x11-wm/xfce4-panel/files/patch-plugins__actions__actions.c
new file mode 100644
index 000000000000..4fb7c1721538
--- /dev/null
+++ b/x11-wm/xfce4-panel/files/patch-plugins__actions__actions.c
@@ -0,0 +1,38 @@
+--- ./plugins/actions/actions.c.orig 2012-04-28 20:31:35.000000000 +0000
++++ ./plugins/actions/actions.c 2013-02-18 19:39:14.000000000 +0000
+@@ -705,7 +705,7 @@
+
+ if (timeout->time_left == 0)
+ {
+- /* unattended shutdown, so don't allow apps to cancel shutdown */
++ /* unattended shutdown, don't save the session to avoid blocking the logout */
+ timeout->unattended = TRUE;
+
+ gtk_dialog_response (GTK_DIALOG (timeout->dialog),
+@@ -928,22 +928,22 @@
+ {
+ case ACTION_TYPE_LOGOUT:
+ succeed = actions_plugin_action_dbus_xfsm ("Logout", FALSE,
+- unattended, &error);
++ !unattended, &error);
+ break;
+
+ case ACTION_TYPE_LOGOUT_DIALOG:
+ succeed = actions_plugin_action_dbus_xfsm ("Logout", TRUE,
+- unattended, &error);
++ !unattended, &error);
+ break;
+
+ case ACTION_TYPE_RESTART:
+ succeed = actions_plugin_action_dbus_xfsm ("Restart", FALSE,
+- unattended, &error);
++ !unattended, &error);
+ break;
+
+ case ACTION_TYPE_SHUTDOWN:
+ succeed = actions_plugin_action_dbus_xfsm ("Shutdown", FALSE,
+- unattended, &error);
++ !unattended, &error);
+ break;
+
+ case ACTION_TYPE_HIBERNATE: