aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/xfce4-session/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-30 16:49:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-30 16:49:12 +0000
commit4b68fc723bc6478544954fa1a7554ca5c269f611 (patch)
tree752bd2703b89f85a96b337b223e14ab4bb621705 /x11-wm/xfce4-session/Makefile
parent66521294b08078847ba4c56a6423c20cf34d68f8 (diff)
downloadports-4b68fc723bc6478544954fa1a7554ca5c269f611.tar.gz
ports-4b68fc723bc6478544954fa1a7554ca5c269f611.zip
Notes
Diffstat (limited to 'x11-wm/xfce4-session/Makefile')
-rw-r--r--x11-wm/xfce4-session/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/x11-wm/xfce4-session/Makefile b/x11-wm/xfce4-session/Makefile
index 7189d41b931a..78d3f46dce40 100644
--- a/x11-wm/xfce4-session/Makefile
+++ b/x11-wm/xfce4-session/Makefile
@@ -35,14 +35,13 @@ USE_XFCE= configenv libmenu libutil panel xfconf
USE_XORG= x11 sm ice
CONFIGURE_ARGS+=--enable-legacy-sm \
- --disable-libgnome-keyring \
- --with-xsession-prefix=${LOCALBASE}
+ --disable-libgnome-keyring \
+ --with-xsession-prefix=${LOCALBASE}
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-OPTIONS= NLS "Enable Native Language Support" on \
- GNUPG "Add support of GNU Privacy Guard" off
+OPTIONS_DEFINE= NLS GNUPG
.include <bsd.port.options.mk>
@@ -50,7 +49,7 @@ MAN1= xfce4-session.1 xfce4-session-logout.1
PLIST_SUB= VERSION="4.6"
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
@@ -59,7 +58,7 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITH_GNUPG)
+.if ${PORT_OPTIONS:MGNUPG}
RUN_DEPENDS+= gpg-agent:${PORTSDIR}/security/gnupg
.endif