aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/xfce4-session/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-09-19 23:46:33 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2019-09-19 23:46:33 +0000
commite69e6941cc0f1dab5aefa920fb26c0f26941f258 (patch)
treee3316902afbb4318b0439dc574f0496749ecfdc3 /x11-wm/xfce4-session/Makefile
parent1e85daf0f563c93a39304c113d346f778baccbd8 (diff)
downloadports-e69e6941cc0f1dab5aefa920fb26c0f26941f258.tar.gz
ports-e69e6941cc0f1dab5aefa920fb26c0f26941f258.zip
Notes
Diffstat (limited to 'x11-wm/xfce4-session/Makefile')
-rw-r--r--x11-wm/xfce4-session/Makefile25
1 files changed, 8 insertions, 17 deletions
diff --git a/x11-wm/xfce4-session/Makefile b/x11-wm/xfce4-session/Makefile
index 89b3bd019343..79f4bdc355cc 100644
--- a/x11-wm/xfce4-session/Makefile
+++ b/x11-wm/xfce4-session/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xfce4-session
-PORTVERSION= 4.12.1
-PORTREVISION= 6
+PORTVERSION= 4.14.0
CATEGORIES= x11-wm xfce
MASTER_SITES= XFCE
DIST_SUBDIR= xfce4
@@ -16,18 +15,13 @@ LICENSE= GPLv2
BUILD_DEPENDS= iceauth:x11/iceauth
RUN_DEPENDS= iceauth:x11/iceauth \
console-kit-daemon:sysutils/consolekit2
-LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
- libdbus-1.so:devel/dbus \
- libupower-glib.so:sysutils/upower \
- libpolkit-gobject-1.so:sysutils/polkit \
- libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
+LIB_DEPENDS= libupower-glib.so:sysutils/upower \
+ libpolkit-gobject-1.so:sysutils/polkit
USES= gettext-tools gmake gnome libtool pathfix pkgconfig \
- tar:bzip2 xfce
-USE_GNOME= cairo gtk20 glib20 intlhack intltool libwnck
-USE_LDCONFIG= yes
-USE_XFCE= libmenu
+ tar:bzip2 xfce xorg
+USE_GNOME= cairo gtk30 glib20 intltool libwnck3
+USE_XFCE= libexo xfconf
USE_XORG= ice sm x11
GNU_CONFIGURE= yes
@@ -35,17 +29,14 @@ INSTALLS_ICONS= yes
CONFIGURE_ARGS= --enable-legacy-sm \
--with-xsession-prefix=${PREFIX}
SUB_FILES= pkg-message
-PLIST_SUB= VERSION="4.6"
INSTALL_TARGET= install-strip
+PORTSCOUT= limitw:1,even
+
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext-runtime
-post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${WRKSRC}/scripts/xflock4
-
.include <bsd.port.mk>