aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2010-01-09 10:51:27 +0000
committerRenato Botelho <garga@FreeBSD.org>2010-01-09 10:51:27 +0000
commit1c66bb748d966ce8ba35eae93563339de59d6ba4 (patch)
tree561501a2f63cc429bfd3159405fcdee99f764937 /x11-wm
parent2a62fe05be8d42b2e027e08016e25a674e186853 (diff)
downloadports-1c66bb748d966ce8ba35eae93563339de59d6ba4.tar.gz
ports-1c66bb748d966ce8ba35eae93563339de59d6ba4.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/awesome/Makefile3
-rw-r--r--x11-wm/awesome/files/patch-lib__awful__rules.lua.in43
-rw-r--r--x11-wm/awesome/files/patch-lib__awful__tag.lua.in7
3 files changed, 33 insertions, 20 deletions
diff --git a/x11-wm/awesome/Makefile b/x11-wm/awesome/Makefile
index f46d119d73c8..8a3959639edc 100644
--- a/x11-wm/awesome/Makefile
+++ b/x11-wm/awesome/Makefile
@@ -7,11 +7,12 @@
PORTNAME= awesome
PORTVERSION= 3.4.3
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://awesome.naquadah.org/download/ \
http://redundancy.redundancy.org/mirror/
-MAINTAINER= ntarmos@cs.uoi.gr
+MAINTAINER= garga@FreeBSD.org
COMMENT= A highly configurable, next generation framework window manager
BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
diff --git a/x11-wm/awesome/files/patch-lib__awful__rules.lua.in b/x11-wm/awesome/files/patch-lib__awful__rules.lua.in
index 937f0ea47578..e0feba5c9e94 100644
--- a/x11-wm/awesome/files/patch-lib__awful__rules.lua.in
+++ b/x11-wm/awesome/files/patch-lib__awful__rules.lua.in
@@ -1,23 +1,30 @@
--- lib/awful/rules.lua.in
+++ lib/awful/rules.lua.in
-@@ -89,7 +89,9 @@ end
-
- --- Apply rules to a client.
- -- @param c The client.
--function apply(c)
-+-- @param startup Executed at startup ? (optional, default is false)
-+function apply(c, startup)
-+ startup = startup or false
- local props = {}
- local callbacks = {}
- for _, entry in ipairs(rules) do
-@@ -129,6 +131,9 @@ function apply(c)
- callback(c)
+@@ -112,7 +112,7 @@ function apply(c)
+ if property == "floating" then
+ aclient.floating.set(c, value)
+ elseif property == "tag" then
+- aclient.movetotag(value, c)
++ c:tags({ value })
+ elseif property == "switchtotag" and value and props.tag then
+ atag.viewonly(props.tag)
+ elseif property == "height" or property == "width" or
+@@ -127,6 +127,11 @@ function apply(c)
+ end
end
-+ -- Apply tags.
-+ atag.withcurrent(c, startup)
++ -- If untagged, stick the client on the current one.
++ if #c:tags() == 0 then
++ atag.withcurrent(c, startup)
++ end
+
- -- Do this at last so we do not erase things done by the focus
- -- signal.
- if props.focus then
+ -- Apply all callbacks from matched rules.
+ for i, callback in pairs(callbacks) do
+ callback(c)
+@@ -140,5 +145,6 @@ function apply(c)
+ end
+
+ client.add_signal("manage", apply)
++client.remove_signal("manage", atag.withcurrent)
+
+ -- vim: filetype=lua:expandtab:shiftwidth=4:tabstop=8:softtabstop=4:encoding=utf-8:textwidth=80
diff --git a/x11-wm/awesome/files/patch-lib__awful__tag.lua.in b/x11-wm/awesome/files/patch-lib__awful__tag.lua.in
index 1b170f1097c9..595bac2474ab 100644
--- a/x11-wm/awesome/files/patch-lib__awful__tag.lua.in
+++ b/x11-wm/awesome/files/patch-lib__awful__tag.lua.in
@@ -1,6 +1,6 @@
--- lib/awful/tag.lua.in
+++ lib/awful/tag.lua.in
-@@ -374,7 +374,6 @@ capi.client.add_signal("manage", function(c, startup)
+@@ -374,10 +374,11 @@ capi.client.add_signal("manage", function(c, startup)
c.screen = capi.mouse.screen
end
end
@@ -8,3 +8,8 @@
c:add_signal("property::screen", withcurrent)
end)
++capi.client.add_signal("manage", withcurrent)
++
+ for s = 1, capi.screen.count() do
+ capi.screen[s]:add_signal("tag::history::update", history.update)
+ end