aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-07-24 13:28:15 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-07-24 13:28:15 +0000
commitd5ce16831784148812800292e7ba7dd3dba9871f (patch)
tree76383a1622b4336bedad934f721365a15b57a9bc /x11-wm
parentebfef2946b2e05db537b73be318d314f78e01e6e (diff)
downloadports-d5ce16831784148812800292e7ba7dd3dba9871f.tar.gz
ports-d5ce16831784148812800292e7ba7dd3dba9871f.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/dwm/Makefile4
-rw-r--r--x11-wm/dwm/distinfo6
-rw-r--r--x11-wm/dwm/files/patch-config.mk16
3 files changed, 14 insertions, 12 deletions
diff --git a/x11-wm/dwm/Makefile b/x11-wm/dwm/Makefile
index e04772876789..16cfa443afe0 100644
--- a/x11-wm/dwm/Makefile
+++ b/x11-wm/dwm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dwm
-PORTVERSION= 5.5
+PORTVERSION= 5.6
CATEGORIES= x11-wm
MASTER_SITES= http://code.suckless.org/dl/${PORTNAME}/ \
http://schot.a-eskwadraat.nl/files/
@@ -25,7 +25,7 @@ PORTDOCS= LICENSE README
pre-everything::
@${ECHO_MSG} "You can build dwm with your own config.h using the DWM_CONF knob:"
@${ECHO_MSG} "make DWM_CONF=/path/to/dwm/config.h install clean"
- @${ECHO_MSG} "Note: Pre-5.5 config.h-files no longer work."
+ @${ECHO_MSG} "Note: Pre-5.6 config.h-files no longer work."
post-extract:
.if defined(DWM_CONF)
diff --git a/x11-wm/dwm/distinfo b/x11-wm/dwm/distinfo
index 14a2c3d3c1b1..9aaddeaf00c2 100644
--- a/x11-wm/dwm/distinfo
+++ b/x11-wm/dwm/distinfo
@@ -1,3 +1,3 @@
-MD5 (dwm-5.5.tar.gz) = 352d952e839ab0e2df0b0959a250b098
-SHA256 (dwm-5.5.tar.gz) = ee56b43f3a12c292ae4df2902412ae5a16b345813b9220732e3c48669371b8c8
-SIZE (dwm-5.5.tar.gz) = 17959
+MD5 (dwm-5.6.tar.gz) = 9fcea56d7ead12c445d65482e6d4c3bb
+SHA256 (dwm-5.6.tar.gz) = 5519123de8709703f3783a91f21c06f9f832b07626637851f2806774efbe2be9
+SIZE (dwm-5.6.tar.gz) = 19294
diff --git a/x11-wm/dwm/files/patch-config.mk b/x11-wm/dwm/files/patch-config.mk
index 94e96bfb82f1..44e4846a5bc0 100644
--- a/x11-wm/dwm/files/patch-config.mk
+++ b/x11-wm/dwm/files/patch-config.mk
@@ -1,5 +1,5 @@
---- config.mk.orig 2008-07-29 20:18:32.000000000 +0200
-+++ config.mk 2008-08-06 00:31:19.000000000 +0200
+--- config.mk.orig 2009-07-14 20:07:55.000000000 +0200
++++ config.mk 2009-07-20 13:29:40.000000000 +0200
@@ -4,11 +4,11 @@
# Customize below to fit your system
@@ -14,18 +14,20 @@
+X11INC = $(LOCALBASE)/include
+X11LIB = $(LOCALBASE)/lib
- # Xinerama, comment if you don't want it
+ # Xinerama, un-comment if you want it
XINERAMALIBS = -L${X11LIB} -lXinerama
-@@ -19,13 +19,13 @@
+@@ -19,15 +19,15 @@
LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${XINERAMALIBS}
# flags
-CPPFLAGS = -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
++CPPFLAGS+= -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
+ #CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
++CFLAGS+= -std=c99 ${INCS} ${CPPFLAGS}
+ #LDFLAGS = -g ${LIBS}
-LDFLAGS = -s ${LIBS}
-+CPPFLAGS+= -std=c99 -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
-+CFLAGS+= ${INCS} ${CPPFLAGS}
-+LDFLAGS+= ${LIBS}
++LDFLAGS+= ${LIBS}
# Solaris
#CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"