aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-05-31 05:03:49 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-05-31 05:03:49 +0000
commit004146be14dfce3e750e735148d73b416ae1516e (patch)
treedb9d7e7f92b991e942b44bb1fb4d009f84bb4fef /x11-wm
parent0e3d8ef98dc55dac5d115247e06ac64df90f1e78 (diff)
downloadports-004146be14dfce3e750e735148d73b416ae1516e.tar.gz
ports-004146be14dfce3e750e735148d73b416ae1516e.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/icewm/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/x11-wm/icewm/Makefile b/x11-wm/icewm/Makefile
index fb2f998da783..6a64e5d4ad2c 100644
--- a/x11-wm/icewm/Makefile
+++ b/x11-wm/icewm/Makefile
@@ -30,9 +30,18 @@ CONFIGURE_ARGS= --enable-shaped-decorations \
--with-docdir=${PREFIX}/share/doc \
--with-mkfontdir=${NONEXISTENT}
+OPTIONS= GNOME "Enable GNOME desktop support" off \
+ IMLIB "Build with Imlib support" off \
+ ESOUND "Enable EsounD daemon support" off \
+ XFT "Enable Xft support for fonts" on \
+ XINERAMA "Enable Xinerama support" on \
+ X86_ASM "Use optimized x86 assembly code" on \
+ BEASTIE "Use Beastie'fied startup button" off \
+ NLS "Enable National Language Support" on
+
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgnomedesktop}!=""
+.if ${HAVE_GNOME:Mgnomedesktop}!="" || defined(WITH_GNOME)
USE_GNOME+= gnomedesktop
CONFIGURE_ARGS+= --enable-menus-gnome2
INSTALL_TARGET= install install-gnome
@@ -42,7 +51,7 @@ PKGNAMESUFFIX= -gnome
PLIST_SUB+= GNOMEDESKTOP="@comment "
.endif
-.if ${HAVE_GNOME:Mimlib}!=""
+.if ${HAVE_GNOME:Mimlib}!="" || defined(WITH_IMLIB)
USE_GNOME+= imlib
CONFIGURE_ARGS+= --with-imlib
.else
@@ -50,7 +59,7 @@ USE_XPM= yes
CONFIGURE_ARGS+= --without-imlib
.endif
-.if ${HAVE_GNOME:Mesound}!=""
+.if ${HAVE_GNOME:Mesound}!="" || defined(WITH_ESOUND)
USE_GNOME+= esound
CONFIGURE_ARGS+= --with-icesound=esound
.else
@@ -72,7 +81,7 @@ CONFIGURE_ARGS+= --disable-xinerama
CONFIGURE_ARGS+= --disable-x86-asm
.endif
-.if defined(WITH_BEASTIE_STARTUP_PIXMAP)
+.if defined(WITH_BEASTIE)
STARTUP_PIXMAP= bsd-daemon.xpm
.else
STARTUP_PIXMAP= icewm-logo.xpm