aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-06-12 23:08:03 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-06-12 23:08:03 +0000
commit1d061142a241611f9ec99daf55c7d9e255098fe9 (patch)
tree72018f8a6dd06a03188828f9cd9f990b56772bac /x11-wm
parentb7ba7d441a696f81be991415500ceefef7e24fd7 (diff)
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/beryl-plugins/Makefile18
-rw-r--r--x11-wm/beryl-plugins/pkg-plist6
2 files changed, 18 insertions, 6 deletions
diff --git a/x11-wm/beryl-plugins/Makefile b/x11-wm/beryl-plugins/Makefile
index fdfc9e713a16..49a0a640bff3 100644
--- a/x11-wm/beryl-plugins/Makefile
+++ b/x11-wm/beryl-plugins/Makefile
@@ -18,8 +18,7 @@ COMMENT= Plugins for Beryl Composite/Window Manager
# XXX - Might depends on graphics/libsvg-cairo instead.
LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/beryl.pc:${PORTSDIR}/x11-wm/beryl-core \
- ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:${PORTSDIR}/devel/dbus
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/beryl.pc:${PORTSDIR}/x11-wm/beryl-core
RUN_DEPENDS= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
@@ -35,4 +34,17 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-.include <bsd.port.mk>
+OPTIONS= DBUS "Enable dbus support" On
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DBUS)
+CONFIGURE_ARGS= --enable-dbus
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:${PORTSDIR}/devel/dbus
+PLIST_SUB= DBUS=""
+.else
+CONFIGURE_ARGS= --disable-dbus
+PLIST_SUB= DBUS="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-wm/beryl-plugins/pkg-plist b/x11-wm/beryl-plugins/pkg-plist
index b4f28a41e62c..6ab3ca96f8dd 100644
--- a/x11-wm/beryl-plugins/pkg-plist
+++ b/x11-wm/beryl-plugins/pkg-plist
@@ -97,9 +97,9 @@ lib/beryl/libimgjpeg.a
lib/beryl/libannotate.so
lib/beryl/libannotate.la
lib/beryl/libannotate.a
-lib/beryl/libdbus.so
-lib/beryl/libdbus.la
-lib/beryl/libdbus.a
+%%DBUS%%lib/beryl/libdbus.so
+%%DBUS%%lib/beryl/libdbus.la
+%%DBUS%%lib/beryl/libdbus.a
share/locale/es/LC_MESSAGES/beryl-plugins.mo
share/locale/fr/LC_MESSAGES/beryl-plugins.mo
share/locale/nl/LC_MESSAGES/beryl-plugins.mo