aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-03 21:15:33 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-03 21:15:33 +0000
commit318c594deb5841c8397750d8a5f8ceca33662043 (patch)
treeeba90a4e6b2202c1d72166b19fdcfea6b50d0ef4 /x11-wm
parentbd3610a0684128fff2ca39a5f3a2590bbb80fe4c (diff)
downloadports-318c594deb5841c8397750d8a5f8ceca33662043.tar.gz
ports-318c594deb5841c8397750d8a5f8ceca33662043.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/wmcp/Makefile8
-rw-r--r--x11-wm/wmcp/files/patch-wmcp.c73
2 files changed, 74 insertions, 7 deletions
diff --git a/x11-wm/wmcp/Makefile b/x11-wm/wmcp/Makefile
index 014bfe3310ac..d7bb81ab24c2 100644
--- a/x11-wm/wmcp/Makefile
+++ b/x11-wm/wmcp/Makefile
@@ -20,10 +20,4 @@ ALL_TARGET= clean wmcp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmcp ${PREFIX}/bin
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/wmcp/files/patch-wmcp.c b/x11-wm/wmcp/files/patch-wmcp.c
new file mode 100644
index 000000000000..ce31d26e151a
--- /dev/null
+++ b/x11-wm/wmcp/files/patch-wmcp.c
@@ -0,0 +1,73 @@
+--- wmcp.c.orig Sat Jan 3 17:14:42 2004
++++ wmcp.c Sat Jan 3 17:15:43 2004
+@@ -806,38 +806,38 @@
+ void show_usage()
+ {
+
+-fprintf(stderr,"
+-
+-%s
+-This software is GPL -- do as you wish with it.
+-
+-Origional Author:
+- Ben Cohen <buddog@aztec.asu.edu>
+-
+-Contributors:
+- Thomas Nemeth <tnemeth@multimania.com>
+- Craig Maloney <craig@ic.net>
+- Gert Beumer <Gert@scintilla.utwente.nl>
+-
+-
+-
+-usage: wmcp [-g geometry] [-d dpy] [-n workspaces] [-a alt key] [-v]
+- [-c] [-w i/n/w] [-s y/n] [-x #] [-y #] [-h]
+-
+-
+--g geometry: ie: 64x64+10+10
+--d dpy: Display. ie: 127.0.0.1:0.0
+--n workspaces: How many buttons to start with.
+--a alt key: integer 1-4 defining ModXMask (default 1 Mod1Mask).
+--w i/n/w: Window State: Iconic, Normal, Withdrawn (default Withdrawn)
+--s y/n: Shaped window: yes or no (default y)
+--c Sends CTRL + ALT + Key (default only sends ALT + key)
+--v Verbose. 0=off, 1=on (default 0)
+--x Number of buttons on the x-direction (1,2,3, or 4)
+--y Number of buttons in the y-direction (1,2,3, or 4)
+--h Help. This screen.
+-
+-
++fprintf(stderr,"\n\
++\n\
++%s\n\
++This software is GPL -- do as you wish with it.\n\
++\n\
++Origional Author:\n\
++ Ben Cohen <buddog@aztec.asu.edu>\n\
++\n\
++Contributors:\n\
++ Thomas Nemeth <tnemeth@multimania.com>\n\
++ Craig Maloney <craig@ic.net>\n\
++ Gert Beumer <Gert@scintilla.utwente.nl>\n\
++\n\
++\n\
++\n\
++usage: wmcp [-g geometry] [-d dpy] [-n workspaces] [-a alt key] [-v]\n\
++ [-c] [-w i/n/w] [-s y/n] [-x #] [-y #] [-h]\n\
++\n\
++\n\
++-g geometry: ie: 64x64+10+10\n\
++-d dpy: Display. ie: 127.0.0.1:0.0\n\
++-n workspaces: How many buttons to start with.\n\
++-a alt key: integer 1-4 defining ModXMask (default 1 Mod1Mask).\n\
++-w i/n/w: Window State: Iconic, Normal, Withdrawn (default Withdrawn)\n\
++-s y/n: Shaped window: yes or no (default y)\n\
++-c Sends CTRL + ALT + Key (default only sends ALT + key)\n\
++-v Verbose. 0=off, 1=on (default 0)\n\
++-x Number of buttons on the x-direction (1,2,3, or 4)\n\
++-y Number of buttons in the y-direction (1,2,3, or 4)\n\
++-h Help. This screen.\n\
++\n\
++\n\
+ ",VERSION);
+
+ exit(-1);