aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-25 22:27:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-25 22:27:51 +0000
commit7d63a886d38dd102eff05296d79ddebcdc3c4624 (patch)
tree92f8cc1066dcba409aef1fa1f9d4665ff52672e8 /x11-wm
parent1da7b5e1a9eb9aa6d5bc87f34cd6f7daf22b47f2 (diff)
downloadports-7d63a886d38dd102eff05296d79ddebcdc3c4624.tar.gz
ports-7d63a886d38dd102eff05296d79ddebcdc3c4624.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/windowmaker/Makefile38
-rw-r--r--x11-wm/windowmaker/files/patch-ah11
-rw-r--r--x11-wm/windowmaker/files/patch-src::switchpanel.c12
-rw-r--r--x11-wm/windowmaker/files/patch-src::wmspec.c12
-rw-r--r--x11-wm/windowmaker/files/patch-src::workspace.c27
-rw-r--r--x11-wm/windowmaker/pkg-descr13
-rw-r--r--x11-wm/windowmaker/pkg-plist12
7 files changed, 83 insertions, 42 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 3be4ef897499..4622ad81c5e9 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -7,6 +7,7 @@
PORTNAME= windowmaker
PORTVERSION= 0.90.0
+PORTREVISION= 1
CATEGORIES= x11-wm windowmaker
MASTER_SITES= ${MASTER_SITE_WINDOWMAKER}
MASTER_SITE_SUBDIR= source/release
@@ -22,51 +23,46 @@ LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
RUN_DEPENDS= ${X11BASE}/share/WindowMaker/Themes/LeetWM.themed/style:${PORTSDIR}/graphics/wmicons
USE_BZIP2= yes
-USE_GETTEXT= yes
-USE_PERL5= yes
USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnometarget pkgconfig
USE_XPM= yes
+USE_PERL5= yes
+USE_GETTEXT= yes
USE_REINPLACE= yes
-WANT_GNOME= yes
-INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
-CONFIGURE_ENV= X11BASE=${X11BASE} \
- LIBS="-L${LOCALBASE}/lib -lintl" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
LINGUAS="${LINGUAS}"
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-nlsdir=${PREFIX}/share/locale \
--with-libs-from="-L${LOCALBASE}/lib" \
--with-incs-from="-I${LOCALBASE}/include" \
--with-appspath="${PREFIX}/GNUstep/Apps" \
+ --enable-vdesktop \
+ --enable-xinerama \
--disable-debug
-
-OPTIONS= XKB_STATUS "XKB STATUS" off \
- KDE "Add hooks for KDE" off
-
-.include <bsd.port.pre.mk>
+INSTALLS_SHLIB= yes
MANLANG= "" sk
MAN1= geticonset.1x getstyle.1x seticons.1x setstyle.1x wdwrite.1x \
wmaker.1x wmsetbg.1x wxcopy.1x wxpaste.1x
+OPTIONS= XKB_STATUS "XKB STATUS" off
+
+.include <bsd.port.pre.mk>
+
LINGUAS!= ${CAT} ${FILESDIR}/LINGUAS
.if defined(WITH_XKB_STATUS)
CONFIGURE_ARGS+= --enable-modelock
.endif
-.if defined(HAVE_GNOME)
-CONFIGURE_ARGS+= --enable-gnome
-.endif
-
-.if defined(WITH_KDE)
-CONFIGURE_ARGS+= --enable-kde
-.endif
-
post-patch:
+ @${REINPLACE_CMD} -e "s|TW\.Big5|TW|g" ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/WPrefs.app/Paths.c
@${REINPLACE_CMD} -e "s|%%PERL%%|${PERL}|g" ${WRKSRC}/util/wm-oldmenu2new
+ @${REINPLACE_CMD} -e "s|-version-info 3:|-version-info 5:|g" ${WRKSRC}/wrlib/Makefile.in
+ @${REINPLACE_CMD} -e "s|Trebuchet MS,Luxi Sans|sans|g" ${WRKSRC}/WindowMaker/Defaults/WMGLOBAL
@${REINPLACE_CMD} -e "s|/usr/local/GNUstep|${PREFIX}/GNUstep|g" \
${WRKSRC}/WindowMaker/*menu*
diff --git a/x11-wm/windowmaker/files/patch-ah b/x11-wm/windowmaker/files/patch-ah
deleted file mode 100644
index 98271d305b53..000000000000
--- a/x11-wm/windowmaker/files/patch-ah
+++ /dev/null
@@ -1,11 +0,0 @@
---- WINGs/usleep.c.orig Wed Oct 21 14:43:55 1998
-+++ WINGs/usleep.c Mon Oct 26 19:27:37 1998
-@@ -11,6 +11,8 @@
- # include <sys/types.h>
- #endif
-
-+#include <unistd.h>
-+#include <string.h>
-
- #if defined(HAVE_SELECT)
-
diff --git a/x11-wm/windowmaker/files/patch-src::switchpanel.c b/x11-wm/windowmaker/files/patch-src::switchpanel.c
new file mode 100644
index 000000000000..72b712956bc6
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-src::switchpanel.c
@@ -0,0 +1,12 @@
+--- src/switchpanel.c.orig Sat Oct 23 10:56:59 2004
++++ src/switchpanel.c Sun Oct 24 02:56:19 2004
+@@ -198,8 +198,8 @@
+ static void addIconForWindow(WSwitchPanel *panel, WWindow *wwin, int iconWidth)
+ {
+ WMLabel *label= WMCreateLabel(panel->hbox);
+- WMAddBoxSubviewAtEnd(panel->hbox, WMWidgetView(label), False, True, iconWidth + ICON_EXTRASPACE, 0, 0);
+ RImage *image = NULL;
++ WMAddBoxSubviewAtEnd(panel->hbox, WMWidgetView(label), False, True, iconWidth + ICON_EXTRASPACE, 0, 0);
+
+ if (!WFLAGP(wwin, always_user_icon) && wwin->net_icon_image)
+ image = RRetainImage(wwin->net_icon_image);
diff --git a/x11-wm/windowmaker/files/patch-src::wmspec.c b/x11-wm/windowmaker/files/patch-src::wmspec.c
new file mode 100644
index 000000000000..b13b4ade0c49
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-src::wmspec.c
@@ -0,0 +1,12 @@
+--- src/wmspec.c.orig Sat Oct 23 12:18:47 2004
++++ src/wmspec.c Sun Oct 24 02:57:37 2004
+@@ -392,8 +392,8 @@
+ RImage *new_rimage;
+
+ do {
+- len = data[pos+0]*data[pos+1];
+ unsigned int tmp = pref_sq-len;
++ len = data[pos+0]*data[pos+1];
+ if (tmp < best_tmp && tmp > 0) {
+ best_tmp = tmp;
+ best_pos = pos;
diff --git a/x11-wm/windowmaker/files/patch-src::workspace.c b/x11-wm/windowmaker/files/patch-src::workspace.c
new file mode 100644
index 000000000000..888e4db5f3a8
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-src::workspace.c
@@ -0,0 +1,27 @@
+--- src/workspace.c.orig Fri Oct 15 06:14:43 2004
++++ src/workspace.c Sun Oct 24 22:32:02 2004
+@@ -738,16 +738,20 @@
+ vdMouseMoveDesktop(XEvent *event, WMPoint direction)
+ {
+ static int lock = False;
+- if (lock) return;
+- lock = True;
+
+ Bool done = False;
+ Bool moved = True;
+- WScreen *scr = wScreenForRootWindow(event->xcrossing.root);
+- WMPoint old_pos = wmkpoint(event->xcrossing.x_root, event->xcrossing.y_root);
++ WScreen *scr;
++ WMPoint old_pos;
+ WMPoint step;
+ int x, y;
+ int resisted = 0;
++
++ if (lock) return;
++ lock = True;
++
++ scr = wScreenForRootWindow(event->xcrossing.root);
++ old_pos = wmkpoint(event->xcrossing.x_root, event->xcrossing.y_root);
+
+ if (XGrabPointer(dpy, event->xcrossing.window, False,
+ PointerMotionMask, GrabModeAsync, GrabModeAsync,
diff --git a/x11-wm/windowmaker/pkg-descr b/x11-wm/windowmaker/pkg-descr
index 427e76c67527..8a25943c79eb 100644
--- a/x11-wm/windowmaker/pkg-descr
+++ b/x11-wm/windowmaker/pkg-descr
@@ -1,6 +1,9 @@
-Window Maker is a new Windowmanager for X written by Alfredo Kojima. It follows
-in the tradition of Afterstep, attempting to emulate the most fantastic of
-UI's posessed by the NeXT STEP(tm) operating system. Window Maker is an
-official part of the GNU Project.
+Window Maker is an X11 window manager designed to give additional
+integration support to the GNUstep Desktop Environment. In every
+way possible, it reproduces the elegant look and feel of the
+NeXTSTEP[tm] GUI. It is fast, feature rich, easy to configure, and
+easy to use. In addition, Window Maker works with GNOME and KDE,
+making it one of the most useful and universal window managers
+available.
-WWW: http://www.windowmaker.org/
+WWW: http://www.windowmaker.org/
diff --git a/x11-wm/windowmaker/pkg-plist b/x11-wm/windowmaker/pkg-plist
index ce61ebf4aaef..0c571525bad6 100644
--- a/x11-wm/windowmaker/pkg-plist
+++ b/x11-wm/windowmaker/pkg-plist
@@ -103,10 +103,10 @@ lib/libWMaker.a
lib/libWUtil.a
lib/libwraster.a
lib/libwraster.so
-lib/libwraster.so.3
-lib/pkgconfig/wrlib.pc
-lib/pkgconfig/WINGs.pc
-lib/pkgconfig/wmlib.pc
+lib/libwraster.so.5
+libdata/pkgconfig/WINGs.pc
+libdata/pkgconfig/wmlib.pc
+libdata/pkgconfig/wrlib.pc
share/WINGs/Images.tiff
share/WINGs/Images.xpm
share/WINGs/defaultIcon.tiff
@@ -277,8 +277,8 @@ share/locale/bg/LC_MESSAGES/WPrefs.mo
share/locale/bg/LC_MESSAGES/WindowMaker.mo
share/locale/bs/LC_MESSAGES/WindowMaker.mo
share/locale/ca/LC_MESSAGES/WINGs.mo
-share/locale/ca/LC_MESSAGES/WindowMaker.mo
share/locale/ca/LC_MESSAGES/WPrefs.mo
+share/locale/ca/LC_MESSAGES/WindowMaker.mo
share/locale/cs/LC_MESSAGES/WINGs.mo
share/locale/cs/LC_MESSAGES/WPrefs.mo
share/locale/cs/LC_MESSAGES/WindowMaker.mo
@@ -323,6 +323,8 @@ share/locale/sv/LC_MESSAGES/WindowMaker.mo
share/locale/tr/LC_MESSAGES/WindowMaker.mo
share/locale/zh_CN/LC_MESSAGES/WPrefs.mo
share/locale/zh_CN/LC_MESSAGES/WindowMaker.mo
+share/locale/zh_TW/LC_MESSAGES/WPrefs.mo
+share/locale/zh_TW/LC_MESSAGES/WindowMaker.mo
@exec mkdir -p %D/GNUstep/Apps/WPrefs.app/xpm
@exec mkdir -p %D/share/WindowMaker/Sounds
@dirrm share/WindowMaker/Styles