aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-07-17 15:42:29 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-07-17 15:42:29 +0000
commit27d93e1c01a72496200b1f2dad22e65f190c4436 (patch)
tree88eda08967fac075c3d016c0f25e1f54adb12370 /x11-wm
parent5f0485b069d5844397d434faf3f71e661b166515 (diff)
downloadports-27d93e1c01a72496200b1f2dad22e65f190c4436.tar.gz
ports-27d93e1c01a72496200b1f2dad22e65f190c4436.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/obmenu/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/x11-wm/obmenu/Makefile b/x11-wm/obmenu/Makefile
index 87ea1e453e8b..8449a2231b47 100644
--- a/x11-wm/obmenu/Makefile
+++ b/x11-wm/obmenu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= obmenu
PORTVERSION= 1.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= x11-wm
MASTER_SITES= SF
@@ -12,10 +12,12 @@ COMMENT= Menu manager for Openbox supporting both static and pipe menus
LICENSE= GPLv2
-USES= python
+USES= python shebangfix
USE_GNOME= pygtk2
USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= obMenu
+SHEBANG_FILES= obmenu obxml.py pipes/obm-xdg
+NO_ARCH= yes
PORTDOCS= README
OPTIONS_DEFINE= DOCS
@@ -25,6 +27,16 @@ SUB_FILES= pkg-message
DESKTOP_ENTRIES="Obmenu" "Menu manager for Openbox" ${PORTNAME} \
"${PORTNAME}" "Settings;" ""
+post-patch:
+ @${REINPLACE_CMD} -e '/itm.nodeName.lower()/s|execute|command|; \
+ /self.dom.createElement("execute")/s|execute|command|; \
+ /xml.dom.minidom.Element("execute")/s|execute|command|; \
+ /i.nodeName == "execute"/s|execute|command|' \
+ ${WRKSRC}/obxml.py
+ @${REINPLACE_CMD} -e '/import/{p;s|.*|import signal|;}; \
+ /os.kill/s|12)|signal.SIGUSR2)|' \
+ ${WRKSRC}/obmenu
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}