aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-11-06 23:57:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-11-06 23:57:30 +0000
commit3888e194dcf271c6e406d5dd5a32a4dac87a11dc (patch)
treef29a05d5cccf96fb13e3bf96398d8d9ec7b9b04c /x11-wm
parentf1751568f5cb2a02c3f880a51114dbe1803859a5 (diff)
downloadports-3888e194dcf271c6e406d5dd5a32a4dac87a11dc.tar.gz
ports-3888e194dcf271c6e406d5dd5a32a4dac87a11dc.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/amaterus/Makefile10
-rw-r--r--x11-wm/amaterus/files/patch-src-wmclient.h45
2 files changed, 47 insertions, 8 deletions
diff --git a/x11-wm/amaterus/Makefile b/x11-wm/amaterus/Makefile
index cd8955d315c7..544b1aa5c000 100644
--- a/x11-wm/amaterus/Makefile
+++ b/x11-wm/amaterus/Makefile
@@ -16,16 +16,10 @@ COMMENT= A GTK+ window manager
LIB_DEPENDS= xml.5:${PORTSDIR}/textproc/libxml
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GNOME= gtk12
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/amaterus/files/patch-src-wmclient.h b/x11-wm/amaterus/files/patch-src-wmclient.h
new file mode 100644
index 000000000000..e59cc2c20dc8
--- /dev/null
+++ b/x11-wm/amaterus/files/patch-src-wmclient.h
@@ -0,0 +1,45 @@
+--- src/wmclient.h.orig 2000-10-30 21:25:19.000000000 +0100
++++ src/wmclient.h 2007-10-09 15:57:28.000000000 +0200
+@@ -20,24 +20,24 @@ extern "C" {
+ #define WM_CLIENT_CLASS(klass) GTK_CHECK_CLASS_CAST (klass, wm_client_get_type (), WmClientClass)
+ #define IS_WM_CLIENT(obj) GTK_CHECK_TYPE (obj, wm_client_get_type ())
+
+-#define WM_CLIENT_X(obj) ((gint16)(((WmClient *)obj)->x))
+-#define WM_CLIENT_Y(obj) ((gint16)(((WmClient *)obj)->y))
+-#define WM_CLIENT_X_PREV(obj) ((guint16)((WmClient *)obj)->priviousX)
+-#define WM_CLIENT_Y_PREV(obj) ((guint16)((WmClient *)obj)->priviousY)
+-#define WM_CLIENT_WIDTH(obj) ((guint16)((WmClient *)obj)->width)
+-#define WM_CLIENT_HEIGHT(obj) ((guint16)((WmClient *)obj)->height)
+-#define WM_CLIENT_W_PREV(obj) ((guint16)((WmClient *)obj)->priviousWidth)
+-#define WM_CLIENT_H_PREV(obj) ((guint16)((WmClient *)obj)->priviousHeight)
+-#define WM_CLIENT_SIZE_FLAG(obj) ((guint16)((WmClient *)obj)->size_flags)
+-#define WM_CLIENT_W_INC(obj) ((gint16)((WmClient *)obj)->width_inc)
+-#define WM_CLIENT_H_INC(obj) ((gint16)((WmClient *)obj)->height_inc)
+-#define WM_CLIENT_W_BASE(obj) ((gint16)((WmClient *)obj)->base_width)
+-#define WM_CLIENT_H_BASE(obj) ((gint16)((WmClient *)obj)->base_height)
+-#define WM_CLIENT_W_MIN(obj) ((gint16)((WmClient *)obj)->min_width)
+-#define WM_CLIENT_H_MIN(obj) ((gint16)((WmClient *)obj)->min_height)
+-#define WM_CLIENT_W_MAX(obj) ((gint16)((WmClient *)obj)->max_width)
+-#define WM_CLIENT_H_MAX(obj) ((gint16)((WmClient *)obj)->max_height)
+-#define WM_CLIENT_STATE(obj) ((gint16)((WmClient *)obj)->state)
++#define WM_CLIENT_X(obj) ((((WmClient *)obj)->x))
++#define WM_CLIENT_Y(obj) ((((WmClient *)obj)->y))
++#define WM_CLIENT_X_PREV(obj) (((WmClient *)obj)->priviousX)
++#define WM_CLIENT_Y_PREV(obj) (((WmClient *)obj)->priviousY)
++#define WM_CLIENT_WIDTH(obj) (((WmClient *)obj)->width)
++#define WM_CLIENT_HEIGHT(obj) (((WmClient *)obj)->height)
++#define WM_CLIENT_W_PREV(obj) (((WmClient *)obj)->priviousWidth)
++#define WM_CLIENT_H_PREV(obj) (((WmClient *)obj)->priviousHeight)
++#define WM_CLIENT_SIZE_FLAG(obj) (((WmClient *)obj)->size_flags)
++#define WM_CLIENT_W_INC(obj) (((WmClient *)obj)->width_inc)
++#define WM_CLIENT_H_INC(obj) (((WmClient *)obj)->height_inc)
++#define WM_CLIENT_W_BASE(obj) (((WmClient *)obj)->base_width)
++#define WM_CLIENT_H_BASE(obj) (((WmClient *)obj)->base_height)
++#define WM_CLIENT_W_MIN(obj) (((WmClient *)obj)->min_width)
++#define WM_CLIENT_H_MIN(obj) (((WmClient *)obj)->min_height)
++#define WM_CLIENT_W_MAX(obj) (((WmClient *)obj)->max_width)
++#define WM_CLIENT_H_MAX(obj) (((WmClient *)obj)->max_height)
++#define WM_CLIENT_STATE(obj) (((WmClient *)obj)->state)
+ #define WM_CLIENT_BORDER_WIDTH(obj) ((guint16)((WmClient *)obj)->border_width)
+ #define WM_CLIENT_BORDER_FRAME(obj) ((gchar *)((WmClient *)obj)->border_frame)
+ #define WM_CLIENT_GROUP(obj) (((WmClient *)obj)->group)