aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-05 00:03:38 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-05 00:03:38 +0000
commit604116319397d8837379d628a953297d6e20f678 (patch)
tree4c812b5cfa9abc839ea8f55bf58fbe2d2ad8ae2d /x11-wm
parent2e071148542cd98a0a4ce116b408147b7e8e5fa8 (diff)
downloadports-604116319397d8837379d628a953297d6e20f678.tar.gz
ports-604116319397d8837379d628a953297d6e20f678.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/awesome2/Makefile9
-rw-r--r--x11-wm/sapphire/Makefile7
2 files changed, 12 insertions, 4 deletions
diff --git a/x11-wm/awesome2/Makefile b/x11-wm/awesome2/Makefile
index 34715be8f135..eaf498ecc826 100644
--- a/x11-wm/awesome2/Makefile
+++ b/x11-wm/awesome2/Makefile
@@ -34,7 +34,12 @@ MAN5= awesome2rc.5
PORTDOCS= AUTHORS LICENSE README STYLE UPGRADE
PORTEXAMPLES= awesomerc
+OPTIONS_DEFINE= DOCS EXAMPLES
+
NO_STAGE= yes
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's, "$$(DESTDIR)$$(docdir)";,;,g' \
-e 's,\([[:space:]]\)install-docDATA ,\1,g' \
@@ -58,14 +63,14 @@ post-configure:
${WRKSRC}/Makefile
post-install:
-. if !defined(NOPORTDOCS)
+. if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
@${MKDIR} ${DOCSDIR}
. for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
. endfor
. endif
-. if !defined(NOPORTEXAMPLES)
+. if ${PORT_OPTIONS:MEXAMPLES}
@${ECHO_MSG} "installing example config file to ${EXAMPLESDIR}"
@${MKDIR} ${EXAMPLESDIR}
. for example in ${PORTEXAMPLES}
diff --git a/x11-wm/sapphire/Makefile b/x11-wm/sapphire/Makefile
index 532e3eb834fd..d4683e43e50e 100644
--- a/x11-wm/sapphire/Makefile
+++ b/x11-wm/sapphire/Makefile
@@ -17,8 +17,11 @@ USES= gmake
REINPLACE_ARGS= -i '' -e
CC= ${CXX}
+OPTIONS_DEFINE= DOCS
+
NO_STAGE= yes
-post-extract:
+
+.include <bsd.port.options.mk>
post-patch:
${REINPLACE_CMD} "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/data.inst
@@ -36,7 +39,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/data/menu/default ${PREFIX}/share/sapphire/menu/default.orig
@${MKDIR} ${PREFIX}/share/sapphire/themes
${INSTALL_DATA} ${WRKSRC}/data/themes/*.theme ${PREFIX}/share/sapphire/themes
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
.endif