aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-17 20:08:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-17 20:08:20 +0000
commit7bf3009384c6929144921bdb25a128cfcf986eea (patch)
tree18e6b0539c7706d0ec567d05216b93dd845a314d /x11-wm
parentc3ef8ffdf610102e173283a564bcb83b08167bb9 (diff)
downloadports-7bf3009384c6929144921bdb25a128cfcf986eea.tar.gz
ports-7bf3009384c6929144921bdb25a128cfcf986eea.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/orion/Makefile32
-rw-r--r--x11-wm/orion/distinfo2
-rw-r--r--x11-wm/orion/pkg-descr15
-rw-r--r--x11-wm/orion/pkg-plist23
4 files changed, 72 insertions, 0 deletions
diff --git a/x11-wm/orion/Makefile b/x11-wm/orion/Makefile
new file mode 100644
index 000000000000..71b3e8230226
--- /dev/null
+++ b/x11-wm/orion/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: orion
+# Date created: 14 July 2004
+# Whom: bkhl@elektrubadur.se
+#
+# $FreeBSD$
+#
+
+PORTNAME= orion
+PORTVERSION= 0.2
+CATEGORIES= x11-wm scheme
+MASTER_SITES= ftp://ftp.scsh.net/pub/scsh/packages/orion-wm/
+
+MAINTAINER= bkhl@elektrubadur.se
+COMMENT= An X11 window manager written in Scheme
+
+RUN_DEPENDS= ${LOCALBASE}/lib/scsh/0.6/module-system:${PORTSDIR}/devel/sunterlib \
+ ${LOCALBASE}/lib/scsh/0.6/scx:${PORTSDIR}/x11-toolkits/scx
+
+USE_X_PREFIX= yes
+NO_BUILD= yes
+
+do-install:
+ (cd ${WRKSRC}; ./install.scm --prefix=${PREFIX})
+
+post-install:
+ ${RM} -rf ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/user.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/orion/distinfo b/x11-wm/orion/distinfo
new file mode 100644
index 000000000000..15a45da5bc7c
--- /dev/null
+++ b/x11-wm/orion/distinfo
@@ -0,0 +1,2 @@
+MD5 (orion-0.2.tar.gz) = 4a328f7509cb4756d61ecc55bf6f0c94
+SIZE (orion-0.2.tar.gz) = 40281
diff --git a/x11-wm/orion/pkg-descr b/x11-wm/orion/pkg-descr
new file mode 100644
index 000000000000..18630dd75f0b
--- /dev/null
+++ b/x11-wm/orion/pkg-descr
@@ -0,0 +1,15 @@
+Orion is a window manager for the X11 windowing system. Orion is
+written in Scheme and accesses Xlib via the scx library for
+scsh. Orion is in fact a family of window managers that can be
+nested. This enables great flexibility and efficient handling of X11
+applications. Orion currently comes with four child window managers:
+
+ * a conventional moving window manager
+ * a window manager for stacking windows in a frame
+ * a window manager for splitting windows horizontally and vertically
+ * a work space manager
+
+Orion also supports saving the window manager layout and programmatic
+configuration.
+
+WWW: http://www.scsh.net/resources/graphics.html
diff --git a/x11-wm/orion/pkg-plist b/x11-wm/orion/pkg-plist
new file mode 100644
index 000000000000..1118c1af4375
--- /dev/null
+++ b/x11-wm/orion/pkg-plist
@@ -0,0 +1,23 @@
+bin/orion
+share/orion-0.2/scheme/button.scm
+share/orion-0.2/scheme/config.scm
+share/orion-0.2/scheme/drag-window.scm
+share/orion-0.2/scheme/file-name-completion.scm
+share/orion-0.2/scheme/key-grab.scm
+share/orion-0.2/scheme/main.scm
+share/orion-0.2/scheme/manager.scm
+share/orion-0.2/scheme/motif.scm
+share/orion-0.2/scheme/move-wm-icon.scm
+share/orion-0.2/scheme/move-wm-resizer.scm
+share/orion-0.2/scheme/move-wm.scm
+share/orion-0.2/scheme/packages.scm
+share/orion-0.2/scheme/prompt.scm
+share/orion-0.2/scheme/root-manager.scm
+share/orion-0.2/scheme/split-wm.scm
+share/orion-0.2/scheme/switch-wm.scm
+share/orion-0.2/scheme/titlebar.scm
+share/orion-0.2/scheme/utils.scm
+%%PORTDOCS%%%%DOCSDIR%%/user.html
+@dirrm share/orion-0.2/scheme
+@dirrm share/orion-0.2
+%%PORTDOCS%%@dirrm %%DOCSDIR%%