aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-07-28 00:48:48 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-07-28 00:48:48 +0000
commitbfb3d70bbfcf89ba06069301ebe0bb52edf18471 (patch)
tree4f3ab1d5ab8e4dc4b6129c8130657b7a75692b02 /x11-wm
parent23358c0c2dc1d768f0289018e894c28ca66ac5ad (diff)
downloadports-bfb3d70bbfcf89ba06069301ebe0bb52edf18471.tar.gz
ports-bfb3d70bbfcf89ba06069301ebe0bb52edf18471.zip
x11-wm/wayfire: add new port
Wayfire is a wayland compositor based on wlroots. It aims to create a customizable, extendable and lightweight environment without sacrificing its appearance. https://wayfire.org/
Notes
Notes: svn path=/head/; revision=507480
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/wayfire/Makefile45
-rw-r--r--x11-wm/wayfire/distinfo9
-rw-r--r--x11-wm/wayfire/pkg-descr5
-rw-r--r--x11-wm/wayfire/pkg-plist63
5 files changed, 123 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 31723931edf8..1d16fe2a0548 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -128,6 +128,7 @@
SUBDIR += twm
SUBDIR += vtwm
SUBDIR += w9wm
+ SUBDIR += wayfire
SUBDIR += weewm
SUBDIR += windowlab
SUBDIR += windowmaker
diff --git a/x11-wm/wayfire/Makefile b/x11-wm/wayfire/Makefile
new file mode 100644
index 000000000000..1ed10c61d1f5
--- /dev/null
+++ b/x11-wm/wayfire/Makefile
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+PORTNAME= wayfire
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2
+CATEGORIES= x11-wm
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= c51e3eda7fa0.patch:-p1 # drop unused
+PATCHFILES+= c4d4c941e773.patch:-p1 # support SUID
+PATCHFILES+= 45535347c922.patch:-p1 # wlroots 0.7
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= 3D wayland compositor
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
+ ${LOCALBASE}/include/xf86drmMode.h:graphics/libdrm \
+ wayland-protocols>=1.12:graphics/wayland-protocols \
+ glm>=0.9.8:math/glm
+LIB_DEPENDS= libinotify.so:devel/libinotify \
+ libwf-config.so:devel/wf-config \
+ libpng.so:graphics/png \
+ libwayland-server.so:graphics/wayland \
+ libwlroots.so:x11-toolkits/wlroots \
+ libinput.so:x11/libinput \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c++11-lib gl jpeg meson pkgconfig
+USE_GITHUB= yes
+USE_GL= egl glesv2
+USE_GNOME= cairo
+USE_XORG= pixman
+GH_ACCOUNT= WayfireWM
+
+OPTIONS_DEFINE= SUID
+OPTIONS_DEFAULT=SUID
+
+SUID_DESC= setuid bit on "${PORTNAME}" binary (required for DRM session)
+SUID_PLIST_SUB= MAYBE_SUID="@(,,4755) "
+SUID_PLIST_SUB_OFF= MAYBE_SUID=""
+
+.include <bsd.port.mk>
diff --git a/x11-wm/wayfire/distinfo b/x11-wm/wayfire/distinfo
new file mode 100644
index 000000000000..1b05ca609caa
--- /dev/null
+++ b/x11-wm/wayfire/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1547849902
+SHA256 (WayfireWM-wayfire-v0.2_GH0.tar.gz) = 94fe93bb2b86048fd1c7601f97b167767e19618bb6b6226e21c22fbd052540bf
+SIZE (WayfireWM-wayfire-v0.2_GH0.tar.gz) = 212795
+SHA256 (c51e3eda7fa0.patch) = 43187242154b6ed4053a02183d7c87826ff58e442fa28e1327494b9bc905f50d
+SIZE (c51e3eda7fa0.patch) = 1327
+SHA256 (c4d4c941e773.patch) = b08e348c90669a88b5bf5dbf106bc02573b4cb0c34187bf85f18fb5f98c0f56c
+SIZE (c4d4c941e773.patch) = 1418
+SHA256 (45535347c922.patch) = 4641571558a2178e432097e510eadc677019a63c5541cd863dfe3b105d255bf5
+SIZE (45535347c922.patch) = 933
diff --git a/x11-wm/wayfire/pkg-descr b/x11-wm/wayfire/pkg-descr
new file mode 100644
index 000000000000..132816395771
--- /dev/null
+++ b/x11-wm/wayfire/pkg-descr
@@ -0,0 +1,5 @@
+Wayfire is a wayland compositor based on wlroots. It aims to create a
+customizable, extendable and lightweight environment without
+sacrificing its appearance.
+
+WWW: https://wayfire.org/
diff --git a/x11-wm/wayfire/pkg-plist b/x11-wm/wayfire/pkg-plist
new file mode 100644
index 000000000000..94942594eeb7
--- /dev/null
+++ b/x11-wm/wayfire/pkg-plist
@@ -0,0 +1,63 @@
+%%MAYBE_SUID%%bin/wayfire
+include/wayfire/bindings.hpp
+include/wayfire/compositor-surface.hpp
+include/wayfire/compositor-view.hpp
+include/wayfire/core.hpp
+include/wayfire/debug.hpp
+include/wayfire/decorator.hpp
+include/wayfire/geometry.hpp
+include/wayfire/img.hpp
+include/wayfire/input-device.hpp
+include/wayfire/nonstd/noncopyable.hpp
+include/wayfire/nonstd/observer_ptr.h
+include/wayfire/nonstd/reverse.hpp
+include/wayfire/nonstd/safe-list.hpp
+include/wayfire/object.hpp
+include/wayfire/opengl.hpp
+include/wayfire/output-layout.hpp
+include/wayfire/output.hpp
+include/wayfire/plugin.hpp
+include/wayfire/render-manager.hpp
+include/wayfire/signal-definitions.hpp
+include/wayfire/surface.hpp
+include/wayfire/util.hpp
+include/wayfire/view-transform.hpp
+include/wayfire/view.hpp
+include/wayfire/workspace-manager.hpp
+include/wayfire/workspace-stream.hpp
+lib/wayfire/libalpha.so
+lib/wayfire/libanimate.so
+lib/wayfire/libautostart.so
+lib/wayfire/libblur.so
+lib/wayfire/libcommand.so
+lib/wayfire/libcube.so
+lib/wayfire/libdecoration.so
+lib/wayfire/libexpo.so
+lib/wayfire/libfast-switcher.so
+lib/wayfire/libfisheye.so
+lib/wayfire/libgrid.so
+lib/wayfire/libidle.so
+lib/wayfire/libinvert.so
+lib/wayfire/libmatcher.so
+lib/wayfire/libmove.so
+lib/wayfire/liboswitch.so
+lib/wayfire/libplace.so
+lib/wayfire/libresize.so
+lib/wayfire/libswitcher.so
+lib/wayfire/libvswitch.so
+lib/wayfire/libwindow-rules.so
+lib/wayfire/libwobbly.so
+lib/wayfire/libwrot.so
+lib/wayfire/libzoom.so
+libdata/pkgconfig/wayfire.pc
+%%DATADIR%%/cube/shaders_2.0/frag.glsl
+%%DATADIR%%/cube/shaders_2.0/frag_cubemap.glsl
+%%DATADIR%%/cube/shaders_2.0/vertex.glsl
+%%DATADIR%%/cube/shaders_2.0/vertex_cubemap.glsl
+%%DATADIR%%/cube/shaders_3.2/frag.glsl
+%%DATADIR%%/cube/shaders_3.2/geom.glsl
+%%DATADIR%%/cube/shaders_3.2/tcs.glsl
+%%DATADIR%%/cube/shaders_3.2/tes.glsl
+%%DATADIR%%/cube/shaders_3.2/vertex.glsl
+%%DATADIR%%/shaders/frag.glsl
+%%DATADIR%%/shaders/vertex.glsl