aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-03-12 21:44:29 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-03-12 21:44:29 +0000
commitcfeea34f058b7c3fb8ba30a097f072b7b0d12f36 (patch)
tree1e0eba5e40f2e2f7b3840567981bdbc49c6f8968 /x11-wm
parent553818ac4350dd19d04cd1c90daeabcd65646a56 (diff)
downloadports-cfeea34f058b7c3fb8ba30a097f072b7b0d12f36.tar.gz
ports-cfeea34f058b7c3fb8ba30a097f072b7b0d12f36.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xfce4-desktop/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/x11-wm/xfce4-desktop/Makefile b/x11-wm/xfce4-desktop/Makefile
index f600ae4f37db..a6ebb2656bba 100644
--- a/x11-wm/xfce4-desktop/Makefile
+++ b/x11-wm/xfce4-desktop/Makefile
@@ -30,6 +30,7 @@ USE_GETTEXT= yes
USE_GNOME= gtk20
USE_X_PREFIX= yes
USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
@@ -38,4 +39,7 @@ CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
MAN1= xfdesktop.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|G_INLINE_FUNC||g' ${WRKSRC}/src/xfce-desktop.c
+
.include <bsd.port.mk>