aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2010-07-02 00:15:55 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2010-07-02 00:15:55 +0000
commitb3be99986ec96ffda30c2e7550d3d5ffdbf2b968 (patch)
tree0c1a6a39351a83333ba18ae3f453f897ea73bbe6 /x11-wm
parent90e1b7737678e01acce155be8c2ec1a5879839b3 (diff)
downloadports-b3be99986ec96ffda30c2e7550d3d5ffdbf2b968.tar.gz
ports-b3be99986ec96ffda30c2e7550d3d5ffdbf2b968.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/scrotwm/Makefile22
-rw-r--r--x11-wm/scrotwm/distinfo6
-rw-r--r--x11-wm/scrotwm/files/clock_format.patch79
-rw-r--r--x11-wm/spectrwm/Makefile22
-rw-r--r--x11-wm/spectrwm/distinfo6
-rw-r--r--x11-wm/spectrwm/files/clock_format.patch79
6 files changed, 14 insertions, 200 deletions
diff --git a/x11-wm/scrotwm/Makefile b/x11-wm/scrotwm/Makefile
index 9c1dd174a1e7..d727c95bb3ea 100644
--- a/x11-wm/scrotwm/Makefile
+++ b/x11-wm/scrotwm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scrotwm
-PORTVERSION= 0.9.22
+PORTVERSION= 0.9.24
CATEGORIES= x11-wm
MASTER_SITES= http://scrotwm.org/snapshot/ \
http://www.peereboom.us/scrotwm/snapshot/
@@ -15,9 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= aragon@phat.za.net
COMMENT= A small, dynamic tiling window manager for X11
-OPTIONS= DMENU "Depend on x11/dmenu" On \
- DMENU_BOTTOM "dmenu at screen bottom (instead of top)" Off \
- CLOCKFORMAT "Configurable strftime(3) clock format" Off
+OPTIONS= DMENU "Depend on x11/dmenu" Off \
+ DMENU_BOTTOM "dmenu at screen bottom (instead of top)" Off
.include <bsd.port.pre.mk>
@@ -26,6 +25,7 @@ USE_XLIB= yes
MAN1= scrotwm.1
PLIST_FILES= bin/scrotwm bin/startscrotwm lib/libswmhack.so etc/scrotwm.conf
+USE_LDCONFIG=yes
.if defined(WITH_DMENU)
RUN_DEPENDS+= dmenu:${PORTSDIR}/x11/dmenu
@@ -33,9 +33,6 @@ RUN_DEPENDS+= dmenu:${PORTSDIR}/x11/dmenu
.if defined(WITH_DMENU_BOTTOM)
EXTRA_PATCHES+= ${FILESDIR}/spawn_menu_atbottom.patch
.endif
-.if defined(WITH_CLOCKFORMAT)
-EXTRA_PATCHES+= ${FILESDIR}/clock_format.patch
-.endif
do-build:
${CC} ${CFLAGS} -I${X11BASE}/include \
@@ -54,15 +51,4 @@ do-install:
post-patch:
@${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' ${WRKSRC}/scrotwm.*
-post-install:
-.if defined(WITH_CLOCKFORMAT)
- @${ECHO_MSG}
- @${ECHO_MSG} "CLOCK FORMAT"
- @${ECHO_MSG}
- @${ECHO_MSG} "To set the clock's format, add a clock_format directive"
- @${ECHO_MSG} "to your configuration file and set it to a format string"
- @${ECHO_MSG} "following strftime(3) convention."
- @${ECHO_MSG}
-.endif
-
.include <bsd.port.post.mk>
diff --git a/x11-wm/scrotwm/distinfo b/x11-wm/scrotwm/distinfo
index 8f033459fa0a..6729d9e7e07c 100644
--- a/x11-wm/scrotwm/distinfo
+++ b/x11-wm/scrotwm/distinfo
@@ -1,3 +1,3 @@
-MD5 (scrotwm-0.9.22.tgz) = bc66c66d300b3176c119bfdae43b6a42
-SHA256 (scrotwm-0.9.22.tgz) = a3952d6a27f0c08dac05cb28226d70e611a8051cdc2735f04e7d64f122fb2943
-SIZE (scrotwm-0.9.22.tgz) = 54396
+MD5 (scrotwm-0.9.24.tgz) = e7e0022b3166774351db3a29bf5f0909
+SHA256 (scrotwm-0.9.24.tgz) = f592619f6053a47e28eace059647fed7ec4ac9848b00163637e6eb58a4bac6af
+SIZE (scrotwm-0.9.24.tgz) = 54940
diff --git a/x11-wm/scrotwm/files/clock_format.patch b/x11-wm/scrotwm/files/clock_format.patch
deleted file mode 100644
index 6c74bf70cd59..000000000000
--- a/x11-wm/scrotwm/files/clock_format.patch
+++ /dev/null
@@ -1,79 +0,0 @@
---- scrotwm.c.orig 2009-10-24 16:21:19.000000000 +0200
-+++ scrotwm.c 2009-10-24 16:58:55.000000000 +0200
-@@ -193,6 +193,7 @@
- int bar_height = 0;
- int stack_enabled = 1;
- int clock_enabled = 1;
-+char *clock_format = NULL;
- int title_name_enabled = 0;
- int title_class_enabled = 0;
- pid_t bar_pid;
-@@ -839,7 +840,7 @@
- else {
- time(&tmt);
- localtime_r(&tmt, &tm);
-- strftime(s, sizeof s, "%a %b %d %R %Z %Y ", &tm);
-+ strftime(s, sizeof s, clock_format, &tm);
- }
-
- for (i = 0; i < ScreenCount(display); i++) {
-@@ -851,7 +852,7 @@
- if (stack_enabled)
- stack = r->ws->cur_layout->name;
-
-- snprintf(loc, sizeof loc, "%d:%d %s %s %s %s",
-+ snprintf(loc, sizeof loc, "%d:%d %s %s %s %s",
- x++, r->ws->idx + 1, stack, s, bar_ext,
- bar_vertext);
- bar_print(r, loc);
-@@ -3293,10 +3294,11 @@
- #define SWM_CONF_FILE "scrotwm.conf"
-
- enum { SWM_S_BAR_DELAY, SWM_S_BAR_ENABLED, SWM_S_STACK_ENABLED,
-- SWM_S_CLOCK_ENABLED, SWM_S_CYCLE_EMPTY, SWM_S_CYCLE_VISIBLE,
-- SWM_S_SS_ENABLED, SWM_S_TERM_WIDTH, SWM_S_TITLE_CLASS_ENABLED,
-- SWM_S_TITLE_NAME_ENABLED, SWM_S_BAR_FONT, SWM_S_BAR_ACTION,
-- SWM_S_SPAWN_TERM, SWM_S_SS_APP, SWM_S_DIALOG_RATIO };
-+ SWM_S_CLOCK_ENABLED, SWM_S_CLOCK_FORMAT, SWM_S_CYCLE_EMPTY,
-+ SWM_S_CYCLE_VISIBLE, SWM_S_SS_ENABLED, SWM_S_TERM_WIDTH,
-+ SWM_S_TITLE_CLASS_ENABLED, SWM_S_TITLE_NAME_ENABLED,
-+ SWM_S_BAR_FONT, SWM_S_BAR_ACTION, SWM_S_SPAWN_TERM,
-+ SWM_S_SS_APP, SWM_S_DIALOG_RATIO };
-
- int
- setconfvalue(char *selector, char *value, int flags)
-@@ -3314,6 +3316,12 @@
- case SWM_S_CLOCK_ENABLED:
- clock_enabled = atoi(value);
- break;
-+ case SWM_S_CLOCK_FORMAT:
-+ if (clock_format != NULL)
-+ free(clock_format);
-+ if ((clock_format = strdup(value)) == NULL)
-+ err(1, "setconfvalue: clock_format");
-+ break;
- case SWM_S_CYCLE_EMPTY:
- cycle_empty = atoi(value);
- break;
-@@ -3407,6 +3415,7 @@
- { "bind", setconfbinding, 0 },
- { "stack_enabled", setconfvalue, SWM_S_STACK_ENABLED },
- { "clock_enabled", setconfvalue, SWM_S_CLOCK_ENABLED },
-+ { "clock_format", setconfvalue, SWM_S_CLOCK_FORMAT },
- { "color_focus", setconfcolor, SWM_S_COLOR_FOCUS },
- { "color_unfocus", setconfcolor, SWM_S_COLOR_UNFOCUS },
- { "cycle_empty", setconfvalue, SWM_S_CYCLE_EMPTY },
-@@ -4468,6 +4477,13 @@
- if (cfile)
- conf_load(cfile);
-
-+ if (clock_format == NULL) {
-+ if ((clock_format = strdup("%a %b %d %R %Z %Y"))
-+ == NULL) {
-+ errx(1, "strdup");
-+ }
-+ }
-+
- /* setup all bars */
- for (i = 0; i < ScreenCount(display); i++)
- TAILQ_FOREACH(r, &screens[i].rl, entry) {
diff --git a/x11-wm/spectrwm/Makefile b/x11-wm/spectrwm/Makefile
index 9c1dd174a1e7..d727c95bb3ea 100644
--- a/x11-wm/spectrwm/Makefile
+++ b/x11-wm/spectrwm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scrotwm
-PORTVERSION= 0.9.22
+PORTVERSION= 0.9.24
CATEGORIES= x11-wm
MASTER_SITES= http://scrotwm.org/snapshot/ \
http://www.peereboom.us/scrotwm/snapshot/
@@ -15,9 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= aragon@phat.za.net
COMMENT= A small, dynamic tiling window manager for X11
-OPTIONS= DMENU "Depend on x11/dmenu" On \
- DMENU_BOTTOM "dmenu at screen bottom (instead of top)" Off \
- CLOCKFORMAT "Configurable strftime(3) clock format" Off
+OPTIONS= DMENU "Depend on x11/dmenu" Off \
+ DMENU_BOTTOM "dmenu at screen bottom (instead of top)" Off
.include <bsd.port.pre.mk>
@@ -26,6 +25,7 @@ USE_XLIB= yes
MAN1= scrotwm.1
PLIST_FILES= bin/scrotwm bin/startscrotwm lib/libswmhack.so etc/scrotwm.conf
+USE_LDCONFIG=yes
.if defined(WITH_DMENU)
RUN_DEPENDS+= dmenu:${PORTSDIR}/x11/dmenu
@@ -33,9 +33,6 @@ RUN_DEPENDS+= dmenu:${PORTSDIR}/x11/dmenu
.if defined(WITH_DMENU_BOTTOM)
EXTRA_PATCHES+= ${FILESDIR}/spawn_menu_atbottom.patch
.endif
-.if defined(WITH_CLOCKFORMAT)
-EXTRA_PATCHES+= ${FILESDIR}/clock_format.patch
-.endif
do-build:
${CC} ${CFLAGS} -I${X11BASE}/include \
@@ -54,15 +51,4 @@ do-install:
post-patch:
@${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' ${WRKSRC}/scrotwm.*
-post-install:
-.if defined(WITH_CLOCKFORMAT)
- @${ECHO_MSG}
- @${ECHO_MSG} "CLOCK FORMAT"
- @${ECHO_MSG}
- @${ECHO_MSG} "To set the clock's format, add a clock_format directive"
- @${ECHO_MSG} "to your configuration file and set it to a format string"
- @${ECHO_MSG} "following strftime(3) convention."
- @${ECHO_MSG}
-.endif
-
.include <bsd.port.post.mk>
diff --git a/x11-wm/spectrwm/distinfo b/x11-wm/spectrwm/distinfo
index 8f033459fa0a..6729d9e7e07c 100644
--- a/x11-wm/spectrwm/distinfo
+++ b/x11-wm/spectrwm/distinfo
@@ -1,3 +1,3 @@
-MD5 (scrotwm-0.9.22.tgz) = bc66c66d300b3176c119bfdae43b6a42
-SHA256 (scrotwm-0.9.22.tgz) = a3952d6a27f0c08dac05cb28226d70e611a8051cdc2735f04e7d64f122fb2943
-SIZE (scrotwm-0.9.22.tgz) = 54396
+MD5 (scrotwm-0.9.24.tgz) = e7e0022b3166774351db3a29bf5f0909
+SHA256 (scrotwm-0.9.24.tgz) = f592619f6053a47e28eace059647fed7ec4ac9848b00163637e6eb58a4bac6af
+SIZE (scrotwm-0.9.24.tgz) = 54940
diff --git a/x11-wm/spectrwm/files/clock_format.patch b/x11-wm/spectrwm/files/clock_format.patch
deleted file mode 100644
index 6c74bf70cd59..000000000000
--- a/x11-wm/spectrwm/files/clock_format.patch
+++ /dev/null
@@ -1,79 +0,0 @@
---- scrotwm.c.orig 2009-10-24 16:21:19.000000000 +0200
-+++ scrotwm.c 2009-10-24 16:58:55.000000000 +0200
-@@ -193,6 +193,7 @@
- int bar_height = 0;
- int stack_enabled = 1;
- int clock_enabled = 1;
-+char *clock_format = NULL;
- int title_name_enabled = 0;
- int title_class_enabled = 0;
- pid_t bar_pid;
-@@ -839,7 +840,7 @@
- else {
- time(&tmt);
- localtime_r(&tmt, &tm);
-- strftime(s, sizeof s, "%a %b %d %R %Z %Y ", &tm);
-+ strftime(s, sizeof s, clock_format, &tm);
- }
-
- for (i = 0; i < ScreenCount(display); i++) {
-@@ -851,7 +852,7 @@
- if (stack_enabled)
- stack = r->ws->cur_layout->name;
-
-- snprintf(loc, sizeof loc, "%d:%d %s %s %s %s",
-+ snprintf(loc, sizeof loc, "%d:%d %s %s %s %s",
- x++, r->ws->idx + 1, stack, s, bar_ext,
- bar_vertext);
- bar_print(r, loc);
-@@ -3293,10 +3294,11 @@
- #define SWM_CONF_FILE "scrotwm.conf"
-
- enum { SWM_S_BAR_DELAY, SWM_S_BAR_ENABLED, SWM_S_STACK_ENABLED,
-- SWM_S_CLOCK_ENABLED, SWM_S_CYCLE_EMPTY, SWM_S_CYCLE_VISIBLE,
-- SWM_S_SS_ENABLED, SWM_S_TERM_WIDTH, SWM_S_TITLE_CLASS_ENABLED,
-- SWM_S_TITLE_NAME_ENABLED, SWM_S_BAR_FONT, SWM_S_BAR_ACTION,
-- SWM_S_SPAWN_TERM, SWM_S_SS_APP, SWM_S_DIALOG_RATIO };
-+ SWM_S_CLOCK_ENABLED, SWM_S_CLOCK_FORMAT, SWM_S_CYCLE_EMPTY,
-+ SWM_S_CYCLE_VISIBLE, SWM_S_SS_ENABLED, SWM_S_TERM_WIDTH,
-+ SWM_S_TITLE_CLASS_ENABLED, SWM_S_TITLE_NAME_ENABLED,
-+ SWM_S_BAR_FONT, SWM_S_BAR_ACTION, SWM_S_SPAWN_TERM,
-+ SWM_S_SS_APP, SWM_S_DIALOG_RATIO };
-
- int
- setconfvalue(char *selector, char *value, int flags)
-@@ -3314,6 +3316,12 @@
- case SWM_S_CLOCK_ENABLED:
- clock_enabled = atoi(value);
- break;
-+ case SWM_S_CLOCK_FORMAT:
-+ if (clock_format != NULL)
-+ free(clock_format);
-+ if ((clock_format = strdup(value)) == NULL)
-+ err(1, "setconfvalue: clock_format");
-+ break;
- case SWM_S_CYCLE_EMPTY:
- cycle_empty = atoi(value);
- break;
-@@ -3407,6 +3415,7 @@
- { "bind", setconfbinding, 0 },
- { "stack_enabled", setconfvalue, SWM_S_STACK_ENABLED },
- { "clock_enabled", setconfvalue, SWM_S_CLOCK_ENABLED },
-+ { "clock_format", setconfvalue, SWM_S_CLOCK_FORMAT },
- { "color_focus", setconfcolor, SWM_S_COLOR_FOCUS },
- { "color_unfocus", setconfcolor, SWM_S_COLOR_UNFOCUS },
- { "cycle_empty", setconfvalue, SWM_S_CYCLE_EMPTY },
-@@ -4468,6 +4477,13 @@
- if (cfile)
- conf_load(cfile);
-
-+ if (clock_format == NULL) {
-+ if ((clock_format = strdup("%a %b %d %R %Z %Y"))
-+ == NULL) {
-+ errx(1, "strdup");
-+ }
-+ }
-+
- /* setup all bars */
- for (i = 0; i < ScreenCount(display); i++)
- TAILQ_FOREACH(r, &screens[i].rl, entry) {