aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2009-12-14 21:42:25 +0000
committerDoug Barton <dougb@FreeBSD.org>2009-12-14 21:42:25 +0000
commit89da9581ebcd311dfd3a9e0a3d6fc16f50fc3b9b (patch)
tree34f7eacb39fe43d151de6b8cb1ddfdd53250026b /x11-wm
parent4094bfea1019780223ef0b22b26f5b711e4e709c (diff)
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/windowmaker/Makefile2
-rw-r--r--x11-wm/windowmaker/files/patch-src_actions.c35
2 files changed, 36 insertions, 1 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 9de674691acc..bb77ee5fb0c8 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -7,7 +7,7 @@
PORTNAME= windowmaker
PORTVERSION= 0.92.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-wm windowmaker
MASTER_SITES= ${MASTER_SITE_WINDOWMAKER} \
http://dougbarton.us/Downloads/
diff --git a/x11-wm/windowmaker/files/patch-src_actions.c b/x11-wm/windowmaker/files/patch-src_actions.c
new file mode 100644
index 000000000000..e3d03c234792
--- /dev/null
+++ b/x11-wm/windowmaker/files/patch-src_actions.c
@@ -0,0 +1,35 @@
+--- src/actions.c.orig
++++ src/actions.c
+@@ -78,6 +78,16 @@
+ #define SHADE_STEPS shadePars[(int)wPreferences.shade_speed].steps
+ #define SHADE_DELAY shadePars[(int)wPreferences.shade_speed].delay
+
++static int
++compareTimes(Time t1, Time t2)
++{
++ Time diff;
++
++ if (t1 == t2)
++ return 0;
++ diff = t1 - t2;
++ return (diff < 60000) ? 1 : -1;
++}
+
+ /*
+ *----------------------------------------------------------------------
+@@ -99,11 +109,11 @@
+
+ WWindow *old_focused;
+ WWindow *focused=scr->focused_window;
+- int timestamp=LastTimestamp;
++ Time timestamp=LastTimestamp;
+ WApplication *oapp=NULL, *napp=NULL;
+ int wasfocused;
+
+- if (scr->flags.ignore_focus_events || LastFocusChange > timestamp)
++ if (scr->flags.ignore_focus_events || compareTimes(LastFocusChange, timestamp) > 0)
+ return;
+
+ if (!old_scr)
+
+