aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-06-16 20:42:13 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-06-16 20:42:13 +0000
commita40d2eedb30d0fd1a1249b627823eb6597408abc (patch)
tree8be5b0e4f91c1b5c0e39b4f1bd7d6d307dcc809d /x11-wm
parent59e93da178e006bccbf5c834a51a074b1ec0497a (diff)
downloadports-a40d2eedb30d0fd1a1249b627823eb6597408abc.tar.gz
ports-a40d2eedb30d0fd1a1249b627823eb6597408abc.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/i3/Makefile3
-rw-r--r--x11-wm/i3/distinfo4
-rw-r--r--x11-wm/i3/files/patch-memory-leak110
-rw-r--r--x11-wm/i3/pkg-plist2
4 files changed, 5 insertions, 114 deletions
diff --git a/x11-wm/i3/Makefile b/x11-wm/i3/Makefile
index b65768f589f5..6dc538cd1cbe 100644
--- a/x11-wm/i3/Makefile
+++ b/x11-wm/i3/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= i3
-DISTVERSION= 4.7.2
-PORTREVISION= 2
+DISTVERSION= 4.8
CATEGORIES= x11-wm
MASTER_SITES= http://i3wm.org/downloads/
diff --git a/x11-wm/i3/distinfo b/x11-wm/i3/distinfo
index 1dfd2ec78ef1..17388ed94709 100644
--- a/x11-wm/i3/distinfo
+++ b/x11-wm/i3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (i3-4.7.2.tar.bz2) = 6fe4565e364a5017eb6a89ce104d6bb21afcdb4bb0b3bee9526781fa64b1f393
-SIZE (i3-4.7.2.tar.bz2) = 897398
+SHA256 (i3-4.8.tar.bz2) = 502c34290f239780bb40352191f0500e8f35d2446eddb573c67c27873d6a1b6b
+SIZE (i3-4.8.tar.bz2) = 939690
diff --git a/x11-wm/i3/files/patch-memory-leak b/x11-wm/i3/files/patch-memory-leak
deleted file mode 100644
index d7ea1a297f4d..000000000000
--- a/x11-wm/i3/files/patch-memory-leak
+++ /dev/null
@@ -1,110 +0,0 @@
---- i3bar/src/xcb.c
-+++ /i3bar/src/xcb.c
-@@ -1395,8 +1395,8 @@ void realloc_sl_buffer(void) {
-
- mask |= XCB_GC_BACKGROUND;
- vals[0] = colors.bar_fg;
-- statusline_ctx = xcb_generate_id(xcb_connection);
- xcb_free_gc(xcb_connection, statusline_ctx);
-+ statusline_ctx = xcb_generate_id(xcb_connection);
- xcb_void_cookie_t sl_ctx_cookie = xcb_create_gc_checked(xcb_connection,
- statusline_ctx,
- xcb_root,
---- src/commands.c
-+++ src/commands.c
-@@ -779,6 +779,12 @@ void cmd_resize(I3_CMD, char *way, char *direction, char *resize_px, char *resiz
-
- owindow *current;
- TAILQ_FOREACH(current, &owindows, owindows) {
-+ /* Don't handle dock windows (issue #1201) */
-+ if (current->con->window->dock) {
-+ DLOG("This is a dock window. Not resizing (con = %p)\n)", current->con);
-+ continue;
-+ }
-+
- Con *floating_con;
- if ((floating_con = con_inside_floating(current->con))) {
- cmd_resize_floating(current_match, cmd_output, way, direction, floating_con, px);
---- src/ipc.c
-+++ src/ipc.c
-@@ -833,14 +833,16 @@ handler_t handlers[8] = {
- static void ipc_receive_message(EV_P_ struct ev_io *w, int revents) {
- uint32_t message_type;
- uint32_t message_length;
-- uint8_t *message;
-+ uint8_t *message = NULL;
-
- int ret = ipc_recv_message(w->fd, &message_type, &message_length, &message);
- /* EOF or other error */
- if (ret < 0) {
- /* Was this a spurious read? See ev(3) */
-- if (ret == -1 && errno == EAGAIN)
-+ if (ret == -1 && errno == EAGAIN) {
-+ FREE(message);
- return;
-+ }
-
- /* If not, there was some kind of error. We don’t bother
- * and close the connection */
-@@ -863,6 +865,7 @@ static void ipc_receive_message(EV_P_ struct ev_io *w, int revents) {
-
- ev_io_stop(EV_A_ w);
- free(w);
-+ FREE(message);
-
- DLOG("IPC: client disconnected\n");
- return;
-@@ -874,6 +877,8 @@ static void ipc_receive_message(EV_P_ struct ev_io *w, int revents) {
- handler_t h = handlers[message_type];
- h(w->fd, message, 0, message_length, message_type);
- }
-+
-+ FREE(message);
- }
-
- /*
---- dev/null
-+++ testcases/t/222-regress-dock-resize.t
-@@ -0,0 +1,42 @@
-+#!perl
-+# vim:ts=4:sw=4:expandtab
-+#
-+# Please read the following documents before working on tests:
-+# • http://build.i3wm.org/docs/testsuite.html
-+# (or docs/testsuite)
-+#
-+# • http://build.i3wm.org/docs/lib-i3test.html
-+# (alternatively: perldoc ./testcases/lib/i3test.pm)
-+#
-+# • http://build.i3wm.org/docs/ipc.html
-+# (or docs/ipc)
-+#
-+# • http://onyxneon.com/books/modern_perl/modern_perl_a4.pdf
-+# (unless you are already familiar with Perl)
-+#
-+# Test that i3 does not crash when a command is issued that would resize a dock
-+# client.
-+# Ticket: #1201
-+# Bug still in: 4.7.2-107-g9b03be6
-+use i3test i3_autostart => 0;
-+
-+my $config = <<'EOT';
-+# i3 config file (v4)
-+font -misc-fixed-medium-r-normal--13-120-75-75-C-70-iso10646-1
-+EOT
-+
-+my $pid = launch_with_config($config);
-+
-+my $i3 = i3(get_socket_path());
-+$i3->connect()->recv;
-+
-+my $window = open_window(
-+ wm_class => 'special',
-+ window_type => $x->atom(name => '_NET_WM_WINDOW_TYPE_DOCK'),
-+);
-+
-+cmd('[class="special"] resize grow height 160 px or 16 ppt');
-+
-+does_i3_live;
-+
-+done_testing;
diff --git a/x11-wm/i3/pkg-plist b/x11-wm/i3/pkg-plist
index 605f17cd024e..7e21f00bfbb9 100644
--- a/x11-wm/i3/pkg-plist
+++ b/x11-wm/i3/pkg-plist
@@ -6,6 +6,7 @@ bin/i3-input
bin/i3-migrate-config-to-v4
bin/i3-msg
bin/i3-nagbar
+bin/i3-save-tree
bin/i3-sensible-editor
bin/i3-sensible-pager
bin/i3-sensible-terminal
@@ -21,6 +22,7 @@ man/man1/i3-input.1.gz
man/man1/i3-migrate-config-to-v4.1.gz
man/man1/i3-msg.1.gz
man/man1/i3-nagbar.1.gz
+man/man1/i3-save-tree.1.gz
man/man1/i3-sensible-editor.1.gz
man/man1/i3-sensible-pager.1.gz
man/man1/i3-sensible-terminal.1.gz