aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2009-12-21 10:36:53 +0000
committerRenato Botelho <garga@FreeBSD.org>2009-12-21 10:36:53 +0000
commit7abc2a5a784737d072b71c477bceb94e7e765dfd (patch)
tree6517122208d31e24009f4edc0a11a38ad30c0ad5 /x11-wm
parentdb84d6328f2d19805175432fa50393a6cd4b70b5 (diff)
downloadports-7abc2a5a784737d072b71c477bceb94e7e765dfd.tar.gz
ports-7abc2a5a784737d072b71c477bceb94e7e765dfd.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/awesome/Makefile1
-rw-r--r--x11-wm/awesome/files/patch-lib__awful__rules.lua.in23
-rw-r--r--x11-wm/awesome/files/patch-lib__awful__tag.lua.in10
3 files changed, 34 insertions, 0 deletions
diff --git a/x11-wm/awesome/Makefile b/x11-wm/awesome/Makefile
index 7d5a4c642366..399eb483fb07 100644
--- a/x11-wm/awesome/Makefile
+++ b/x11-wm/awesome/Makefile
@@ -7,6 +7,7 @@
PORTNAME= awesome
PORTVERSION= 3.4.2
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://awesome.naquadah.org/download/ \
http://redundancy.redundancy.org/mirror/
diff --git a/x11-wm/awesome/files/patch-lib__awful__rules.lua.in b/x11-wm/awesome/files/patch-lib__awful__rules.lua.in
new file mode 100644
index 000000000000..937f0ea47578
--- /dev/null
+++ b/x11-wm/awesome/files/patch-lib__awful__rules.lua.in
@@ -0,0 +1,23 @@
+--- lib/awful/rules.lua.in
++++ lib/awful/rules.lua.in
+@@ -89,7 +89,9 @@ end
+
+ --- Apply rules to a client.
+ -- @param c The client.
+-function apply(c)
++-- @param startup Executed at startup ? (optional, default is false)
++function apply(c, startup)
++ startup = startup or false
+ local props = {}
+ local callbacks = {}
+ for _, entry in ipairs(rules) do
+@@ -129,6 +131,9 @@ function apply(c)
+ callback(c)
+ end
+
++ -- Apply tags.
++ atag.withcurrent(c, startup)
++
+ -- Do this at last so we do not erase things done by the focus
+ -- signal.
+ if props.focus then
diff --git a/x11-wm/awesome/files/patch-lib__awful__tag.lua.in b/x11-wm/awesome/files/patch-lib__awful__tag.lua.in
new file mode 100644
index 000000000000..1b170f1097c9
--- /dev/null
+++ b/x11-wm/awesome/files/patch-lib__awful__tag.lua.in
@@ -0,0 +1,10 @@
+--- lib/awful/tag.lua.in
++++ lib/awful/tag.lua.in
+@@ -374,7 +374,6 @@ capi.client.add_signal("manage", function(c, startup)
+ c.screen = capi.mouse.screen
+ end
+ end
+- withcurrent(c, startup)
+ c:add_signal("property::screen", withcurrent)
+ end)
+