aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-20 21:03:26 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-20 21:03:26 +0000
commitb4d289c8411ca6f2742dda3c83c6d0b961f49c4e (patch)
tree2b40aa36fea6039f0da07b823263c156481646ff /x11-wm
parent23fb0bcf75bf5949e7348d9fa7c0e1da76022ef3 (diff)
downloadports-b4d289c8411ca6f2742dda3c83c6d0b961f49c4e.tar.gz
ports-b4d289c8411ca6f2742dda3c83c6d0b961f49c4e.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/treewm/Makefile43
-rw-r--r--x11-wm/treewm/files/patch-tile.cc10
-rw-r--r--x11-wm/treewm/pkg-descr31
3 files changed, 49 insertions, 35 deletions
diff --git a/x11-wm/treewm/Makefile b/x11-wm/treewm/Makefile
index 3dd5a0b83ddd..518963b231b7 100644
--- a/x11-wm/treewm/Makefile
+++ b/x11-wm/treewm/Makefile
@@ -12,37 +12,40 @@ COMMENT= Window manager that arranges windows in a tree
LICENSE= GPLv2
-USES= imake:env
+OPTIONS_DEFINE= DOCS EXAMPLES
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake imake:env
USE_XORG= x11 ice sm xext xmu xpm xt xxf86vm
PORTDOCS= AUTHORS ChangeLog INSTALL PROBLEMS README README.tiling TODO
PORTEXAMPLES= default.cfg sample.cfg
-OPTIONS_DEFINE= DOCS EXAMPLES
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e '/^PREFIX/s| =| ?=| ; /^CXXFLAGS/s| =| ?=| ; \
- s|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ '/^PREFIX/s| =| ?=| ; \
+ /^CXXFLAGS/s| =| ?=| ; \
+ s|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/treewm ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/xprop/xprop ${PREFIX}/bin/xprop-treewm
- ${INSTALL_PROGRAM} ${WRKSRC}/xkill/xkill ${PREFIX}/bin/xkill-treewm
- @${MKDIR} ${DATADIR}/pixmaps
- ${INSTALL_DATA} ${WRKSRC}/src/pixmaps/*.xpm ${DATADIR}/pixmaps
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
-.endif
+ (cd ${WRKSRC}/src && ${INSTALL_PROGRAM} treewm \
+ ${STAGEDIR}${PREFIX}/bin)
+ (cd ${WRKSRC}/xprop && ${INSTALL_PROGRAM} xprop \
+ ${STAGEDIR}${PREFIX}/bin/xprop-treewm)
+ (cd ${WRKSRC}/xkill && ${INSTALL_PROGRAM} xkill \
+ ${STAGEDIR}${PREFIX}/bin/xkill-treewm)
+ @${MKDIR} ${STAGEDIR}${DATADIR}/pixmaps
+ (cd ${WRKSRC}/src/pixmaps && ${INSTALL_DATA} *.xpm \
+ ${STAGEDIR}${DATADIR}/pixmaps)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for F in ${PORTDOCS}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${F} ${STAGEDIR}${DOCSDIR})
+.endfor
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+.for F in ${PORTEXAMPLES}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${F} ${STAGEDIR}${EXAMPLESDIR})
+.endfor
.include <bsd.port.mk>
diff --git a/x11-wm/treewm/files/patch-tile.cc b/x11-wm/treewm/files/patch-tile.cc
new file mode 100644
index 000000000000..ea179a42bb0a
--- /dev/null
+++ b/x11-wm/treewm/files/patch-tile.cc
@@ -0,0 +1,10 @@
+--- src/tile.cc.orig
++++ src/tile.cc
+@@ -5,6 +5,7 @@
+ #include <algorithm>
+ #include <stack>
+ //#include <stdio.h>
++#include <stdlib.h>
+
+ /*
+ * changed<05.02.2003> by Rudolf Polzer: including namespace std (C++)
diff --git a/x11-wm/treewm/pkg-descr b/x11-wm/treewm/pkg-descr
index 96bb37c3bf2e..5080dfa8f475 100644
--- a/x11-wm/treewm/pkg-descr
+++ b/x11-wm/treewm/pkg-descr
@@ -1,21 +1,22 @@
-treewm is a window manager that tries to implement a new concept. In addition
-to the client windows the user can create desktops which can themselves contain
-windows and desktops. By arranging the windows in such a tree the user is able
-to manage his tasks efficiently treewm is feature-rich, flexible and provides
-a powerful concept. However, treewm's look is is rather puristic, and its feel
-is not always intuitive, but with a bit of practise it should be very effective
-to use.
+treewm is a window manager that tries to implement a new concept. In
+addition to the client windows the user can create desktops which can
+themselves contain windows and desktops. By arranging the windows in
+such a tree the user is able to manage his tasks efficiently treewm is
+feature-rich, flexible and provides a powerful concept. However,
+treewm's look is is rather puristic, and its feel is not always
+intuitive, but with a bit of practise it should be very effective to
+use.
Short feature list (some of them are quite unique among window managers):
-
- - Allows to create desktops and to arbitrarily move windows between desktops
- - Many options (such as sticky, autoresize, always on top, or the focus or
- raise policy) can be set for any desktop or window
+ - Allows to create desktops and to arbitrarily move windows between
+ desktops
+ - Many options (such as sticky, autoresize, always on top, or the
+ focus or raise policy) can be set for any desktop or window
- Can be fully customized using the configuration file
- - Has a very powerful (somewhat vi-like) command mode, and can be controlled
- from shell scripts via a FIFO
+ - Has a very powerful (somewhat vi-like) command mode, and can be
+ controlled from shell scripts via a FIFO
- Icons can be placed on desktops that can execute arbitrary commands
- - Only uses very common libraries, in particular it doesn't require GTK, Qt,
- or anything like that
+ - Only uses very common libraries, in particular it doesn't require
+ GTK, Qt, or anything like that
WWW: http://treewm.sourceforge.net/