aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-09 19:58:14 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-09 19:58:14 +0000
commitc30df7f98176cf6486d52f4b9a4a707c0747dba3 (patch)
tree0a376a9d19df78d8fb0b892ec07683cb4006c6ad /x11-wm
parent468f16d221bb67db691008c26a06ec0e1e727a28 (diff)
downloadports-c30df7f98176cf6486d52f4b9a4a707c0747dba3.tar.gz
ports-c30df7f98176cf6486d52f4b9a4a707c0747dba3.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/libepplet/Makefile24
-rw-r--r--x11-wm/libepplet/distinfo2
-rw-r--r--x11-wm/libepplet/files/patch-Makefile.in11
-rw-r--r--x11-wm/libepplet/files/patch-api::epplet.h.in10
-rw-r--r--x11-wm/libepplet/files/patch-configure10
5 files changed, 44 insertions, 13 deletions
diff --git a/x11-wm/libepplet/Makefile b/x11-wm/libepplet/Makefile
index 79037fc72dae..0112b89224e1 100644
--- a/x11-wm/libepplet/Makefile
+++ b/x11-wm/libepplet/Makefile
@@ -6,27 +6,27 @@
#
PORTNAME= libepplet
-PORTVERSION= 0.5
+PORTVERSION= 0.7
CATEGORIES= x11-wm devel
-MASTER_SITES= ftp://kde.planetmirror.com/pub/enlightenment/epplets/ \
- ftp://ftp.dti.ad.jp/pub/X/enlightenment/epplets/
-DISTNAME= epplet-base-${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= enlightenment
+DISTNAME= epplets-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for building enlightenment dock applications
-WRKSRC= ${WRKDIR}/Epplets-${PORTVERSION}
-
-USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GNOME= imlib
+USE_GL= yes
+USE_GMAKE= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= EROOT=${X11BASE}/share/enlightenment \
- EBIN=${X11BASE}/bin
-CONFIGURE_ARGS= --enable-fsstd
+CONFIGURE_ENV= EROOT="${X11BASE}/share/enlightenment" \
+ EBIN="${X11BASE}/bin" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
-pre-patch:
- @${REINPLACE_CMD} -e 's|api epplets|api|g' ${WRKSRC}/Makefile.in
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lGL -lGLU ${PTHREAD_LIBS}
.include <bsd.port.mk>
diff --git a/x11-wm/libepplet/distinfo b/x11-wm/libepplet/distinfo
index 72e5def07b72..146d895b8a49 100644
--- a/x11-wm/libepplet/distinfo
+++ b/x11-wm/libepplet/distinfo
@@ -1 +1 @@
-MD5 (epplet-base-0.5.tar.gz) = 6be063dcff76dcdef0f2bfdba4cd111d
+MD5 (epplets-0.7.tar.gz) = b28331134d22ba5305c48dc0948f9e95
diff --git a/x11-wm/libepplet/files/patch-Makefile.in b/x11-wm/libepplet/files/patch-Makefile.in
new file mode 100644
index 000000000000..7b3384b60be1
--- /dev/null
+++ b/x11-wm/libepplet/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Nov 6 07:09:39 2003
++++ Makefile.in Mon Dec 8 02:20:28 2003
+@@ -107,7 +107,7 @@
+
+ AUTOMAKE_OPTIONS = foreign
+
+-SUBDIRS = api epplets debian
++SUBDIRS = api debian
+
+ EXTRA_DIST = autogen.sh epplets.spec
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/x11-wm/libepplet/files/patch-api::epplet.h.in b/x11-wm/libepplet/files/patch-api::epplet.h.in
new file mode 100644
index 000000000000..7b87c97c61ff
--- /dev/null
+++ b/x11-wm/libepplet/files/patch-api::epplet.h.in
@@ -0,0 +1,10 @@
+--- api/epplet.h.in.orig Fri Jun 30 08:54:24 2000
++++ api/epplet.h.in Mon Dec 8 23:43:09 2003
+@@ -28,7 +28,6 @@
+
+ /* preliminary OpenGL Checking */
+ #ifdef HAVE_LIBGL
+-#include <GL/glut.h>
+ #include <GL/glx.h>
+ #endif
+
diff --git a/x11-wm/libepplet/files/patch-configure b/x11-wm/libepplet/files/patch-configure
new file mode 100644
index 000000000000..8ed049a52175
--- /dev/null
+++ b/x11-wm/libepplet/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Tue Aug 26 12:12:44 2003
++++ configure Mon Dec 8 02:20:46 2003
+@@ -5414,6 +5414,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'