aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 20:22:28 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-10 20:22:28 +0000
commit598b3dd07433bda9451f4355a59039482b491ff3 (patch)
treea86cbc131e421cb3ff149b03d35867d3bf03f657 /x11-wm
parent79e762dc38e86bc464a2c7ac01fd8fba3b3cdeed (diff)
downloadports-598b3dd07433bda9451f4355a59039482b491ff3.tar.gz
ports-598b3dd07433bda9451f4355a59039482b491ff3.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/e17-module-screenshot/Makefile49
-rw-r--r--x11-wm/e17-module-screenshot/distinfo3
-rw-r--r--x11-wm/e17-module-screenshot/files/patch-configure11
-rw-r--r--x11-wm/e17-module-screenshot/pkg-descr6
-rw-r--r--x11-wm/e17-module-screenshot/pkg-plist17
5 files changed, 86 insertions, 0 deletions
diff --git a/x11-wm/e17-module-screenshot/Makefile b/x11-wm/e17-module-screenshot/Makefile
new file mode 100644
index 000000000000..06aaaf0fa41c
--- /dev/null
+++ b/x11-wm/e17-module-screenshot/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: e17-module-uptime
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= screenshot
+PORTVERSION= 20060707
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An e17 module which allows users to take screenshots
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+OPTIONS= IMAGIC "Use ImageMagick" on \
+ SCROT "Use Scrot" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_IMAGIC)
+RUN_DEPENDS+= import:${PORTSDIR}/graphics/ImageMagick
+.endif
+
+.if defined(WITH_SCROT)
+RUN_DEPENDS+= scrot:${PORTSDIR}/graphics/scrot
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-wm/e17-module-screenshot/distinfo b/x11-wm/e17-module-screenshot/distinfo
new file mode 100644
index 000000000000..0836f4795b07
--- /dev/null
+++ b/x11-wm/e17-module-screenshot/distinfo
@@ -0,0 +1,3 @@
+MD5 (screenshot-20060707.tar.bz2) = 9171aaf311bcf74762f42c6317045813
+SHA256 (screenshot-20060707.tar.bz2) = 3c1dbfb464e4f440b2d9dc43387563e22cf2a20f94ded7f56930470ddce13bd8
+SIZE (screenshot-20060707.tar.bz2) = 364926
diff --git a/x11-wm/e17-module-screenshot/files/patch-configure b/x11-wm/e17-module-screenshot/files/patch-configure
new file mode 100644
index 000000000000..bc913371e95e
--- /dev/null
+++ b/x11-wm/e17-module-screenshot/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Jun 23 16:14:40 2006
++++ configure Fri Jun 23 16:14:53 2006
+@@ -21497,7 +21497,7 @@
+
+
+
+-MODULE_ARCH="$host_os-$host_cpu"
++MODULE_ARCH=""
+
+
+ cat >>confdefs.h <<_ACEOF
diff --git a/x11-wm/e17-module-screenshot/pkg-descr b/x11-wm/e17-module-screenshot/pkg-descr
new file mode 100644
index 000000000000..bd1038d2288f
--- /dev/null
+++ b/x11-wm/e17-module-screenshot/pkg-descr
@@ -0,0 +1,6 @@
+This e17 module allows users to take screenshots. It provides customized
+delays, directory and file names, image dithering, thumbnails preparing
+and various effects via external programs.
+
+Author: Christopher Michael <devilhorns@comcast.net>
+WWW: http://www.enlightenment.org
diff --git a/x11-wm/e17-module-screenshot/pkg-plist b/x11-wm/e17-module-screenshot/pkg-plist
new file mode 100644
index 000000000000..ce36c62f6c43
--- /dev/null
+++ b/x11-wm/e17-module-screenshot/pkg-plist
@@ -0,0 +1,17 @@
+lib/enlightenment/modules/screenshot/screenshot.edj
+lib/enlightenment/modules/screenshot/e17_titlebar_glint1.png
+lib/enlightenment/modules/screenshot/e17_titlebar_glint2.png
+lib/enlightenment/modules/screenshot/e17_titlebar_glint3.png
+lib/enlightenment/modules/screenshot/module.a
+lib/enlightenment/modules/screenshot/module.eap
+lib/enlightenment/modules/screenshot/module.la
+lib/enlightenment/modules/screenshot/module.so
+lib/enlightenment/modules/screenshot/module_icon.png
+%%NLS%%share/locale/eo/LC_MESSAGES/screenshot.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/screenshot.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/screenshot.mo
+%%NLS%%share/locale/it/LC_MESSAGES/screenshot.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/screenshot.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/screenshot.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/screenshot.mo
+@dirrm lib/enlightenment/modules/screenshot