aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-11-21 13:44:28 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-11-21 13:44:28 +0000
commit03866fcca14bc4d0de84da4880bc37bfccab5ceb (patch)
tree6371f817d513bd9f4552f12285036de4e1ed777b /x11-wm
parentc691d6e0273ef0197235c06d4ee7d65e724aa94f (diff)
downloadports-03866fcca14bc4d0de84da4880bc37bfccab5ceb.tar.gz
ports-03866fcca14bc4d0de84da4880bc37bfccab5ceb.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/pager/Makefile5
-rw-r--r--x11-wm/pager/distinfo2
-rw-r--r--x11-wm/pager/files/patch-pager.c10
-rw-r--r--x11-wm/pager/files/patch-pager.jl14
4 files changed, 14 insertions, 17 deletions
diff --git a/x11-wm/pager/Makefile b/x11-wm/pager/Makefile
index 8e7c09a8a8a8..31c8d3e87ff6 100644
--- a/x11-wm/pager/Makefile
+++ b/x11-wm/pager/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pager
-PORTVERSION= 0.4a
+PORTVERSION= 0.5
CATEGORIES= x11-wm
MASTER_SITES= http://dapfy.bei.t-online.de/sawfish/pager/
EXTRACT_SUFX= .tgz
@@ -17,6 +17,7 @@ BUILD_DEPENDS= ${X11BASE}/bin/sawfish:${PORTSDIR}/x11-wm/sawfish
RUN_DEPENDS= ${X11BASE}/bin/sawfish:${PORTSDIR}/x11-wm/sawfish
USE_GMAKE= yes
+MAKEFILE= GNUmakefile
USE_GNOME= gtk12
USE_GNOMENG= yes
USE_REINPLACE= yes
@@ -28,7 +29,7 @@ SAWFISH_VERSION= `${X11BASE}/bin/sawfish --version 2>&1 | \
PLIST_SUB+= SAWFISH_VERSION="${SAWFISH_VERSION}"
post-patch:
- @${REINPLACE_CMD} -e 's/gtk-config/gtk12-config/g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's/gtk-config/gtk12-config/g' ${WRKSRC}/${MAKEFILE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/x11-wm/pager/distinfo b/x11-wm/pager/distinfo
index 43fd5f7c58ff..24d509394062 100644
--- a/x11-wm/pager/distinfo
+++ b/x11-wm/pager/distinfo
@@ -1 +1 @@
-MD5 (pager-0.4a.tgz) = c67f36063e98ab81940c52b66a2c4212
+MD5 (pager-0.5.tgz) = 02375110f5e03bc3f390ab389d4baca4
diff --git a/x11-wm/pager/files/patch-pager.c b/x11-wm/pager/files/patch-pager.c
new file mode 100644
index 000000000000..18a6adb098fd
--- /dev/null
+++ b/x11-wm/pager/files/patch-pager.c
@@ -0,0 +1,10 @@
+--- pager.c.orig Thu Nov 21 12:46:28 2002
++++ pager.c Thu Nov 21 12:46:48 2002
+@@ -24,6 +24,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
++#include <sys/time.h>
+ #include <sys/select.h>
+ #include <gtk/gtk.h>
+
diff --git a/x11-wm/pager/files/patch-pager.jl b/x11-wm/pager/files/patch-pager.jl
deleted file mode 100644
index 62a57f06c112..000000000000
--- a/x11-wm/pager/files/patch-pager.jl
+++ /dev/null
@@ -1,14 +0,0 @@
---- pager.jl.orig Tue Nov 19 21:06:10 2002
-+++ pager.jl Tue Nov 19 21:08:30 2002
-@@ -277,7 +277,10 @@
- ;; Tells the C program to change the colors
- (define (send-colors)
- (send ?c
-- (mapcar color-rgb
-+ (mapcar (lambda (color)
-+ (let ((clist (color-rgb color)))
-+ (setcdr (nthcdr 2 clist) nil)
-+ clist))
- (list pager-color-background
- pager-color-viewport
- pager-color-window