aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-07-16 07:36:28 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-07-16 07:36:28 +0000
commit7bbcd81e1e73279e08a53a5d8836c2f3dcc63414 (patch)
tree5057a4fbea0a0cdbcd46f8c86e1065c444cb72f1 /x11-wm
parent632c0f9bd700eae75f52d219022f1640139f9cee (diff)
downloadports-7bbcd81e1e73279e08a53a5d8836c2f3dcc63414.tar.gz
ports-7bbcd81e1e73279e08a53a5d8836c2f3dcc63414.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/awesome2/Makefile38
-rw-r--r--x11-wm/awesome2/pkg-plist5
2 files changed, 21 insertions, 22 deletions
diff --git a/x11-wm/awesome2/Makefile b/x11-wm/awesome2/Makefile
index 1def43c1c50d..8b2685f4054c 100644
--- a/x11-wm/awesome2/Makefile
+++ b/x11-wm/awesome2/Makefile
@@ -11,6 +11,8 @@ DISTNAME= awesome-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A tiling window manager initially based on a dwm code rewriting
+LICENSE= GPLv2
+
BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
xmlto:${PORTSDIR}/textproc/xmlto
LIB_DEPENDS= libconfuse.so:${PORTSDIR}/devel/libconfuse \
@@ -26,20 +28,16 @@ USE_PYTHON_BUILD= yes
USE_XORG= x11 xft xext xinerama xt xrandr xproto
LDFLAGS+= -lX11 -lXext ${ICONV_LIB}
-MAN1= awesome2.1 \
+MAN1S= awesome2.1 \
awesome2-client.1 \
awesome2-menu.1 \
awesome2-message.1
-MAN5= awesome2rc.5
+MAN5S= awesome2rc.5
PORTDOCS= AUTHORS LICENSE README STYLE UPGRADE
PORTEXAMPLES= awesomerc
OPTIONS_DEFINE= DOCS EXAMPLES
-NO_STAGE= yes
-
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's, "$$(DESTDIR)$$(docdir)";,;,g' \
-e 's,\([[:space:]]\)install-docDATA ,\1,g' \
@@ -50,12 +48,12 @@ post-patch:
${WRKSRC}/configure
@${REINPLACE_CMD} -e "s,awesomerc,awesome2rc,g" \
${WRKSRC}/common/configopts.c
-. for man in ${MAN1} ${MAN5}
+.for man in ${MAN1S} ${MAN5S}
@${MV} ${WRKSRC}/${man:S%awesome2%awesome%}.txt ${WRKSRC}/${man}.txt
@${REINPLACE_CMD} -e 's,awesome,awesome2,g' \
-e 's,\~/\.awesome2,~/.awesome,g' \
${WRKSRC}/${man}.txt
-. endfor
+.endfor
post-configure:
@${REINPLACE_CMD} -E '/^awesome2_(message_)?LDADD/s/$$/ ${ICONV_LIB}/g; \
@@ -63,19 +61,15 @@ post-configure:
${WRKSRC}/Makefile
post-install:
-. if ${PORT_OPTIONS:MDOCS}
- @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
- @${MKDIR} ${DOCSDIR}
-. for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
-. endfor
-. endif
-. if ${PORT_OPTIONS:MEXAMPLES}
- @${ECHO_MSG} "installing example config file to ${EXAMPLESDIR}"
- @${MKDIR} ${EXAMPLESDIR}
-. for example in ${PORTEXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${example} ${EXAMPLESDIR}
-. endfor
-. endif
+ @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
+.endfor
+ @${ECHO_MSG} "installing example config file to ${EXAMPLESDIR}"
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+.for example in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${example} ${STAGEDIR}${EXAMPLESDIR}
+.endfor
.include <bsd.port.mk>
diff --git a/x11-wm/awesome2/pkg-plist b/x11-wm/awesome2/pkg-plist
index e2814901d3d2..9b0609aeca29 100644
--- a/x11-wm/awesome2/pkg-plist
+++ b/x11-wm/awesome2/pkg-plist
@@ -2,6 +2,11 @@ bin/awesome2
bin/awesome2-client
bin/awesome2-menu
bin/awesome2-message
+man/man1/awesome2.1.gz
+man/man1/awesome2-client.1.gz
+man/man1/awesome2-menu.1.gz
+man/man1/awesome2-message.1.gz
+man/man5/awesome2rc.5.gz
%%DATADIR%%/icons/awesome16.png
%%DATADIR%%/icons/awesome32.png
%%DATADIR%%/icons/awesome48.png