aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-04-07 07:12:32 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-04-07 07:12:32 +0000
commite5eeaf2b4e6889e73854ce381ef2cb097eec40b5 (patch)
treeec8d216eab3b32da5a7816a148cae8e4b1a08663 /x11-wm
parent50300e3a9ef31a651b68733fbf1a3d7d1bec4ee2 (diff)
downloadports-e5eeaf2b4e6889e73854ce381ef2cb097eec40b5.tar.gz
ports-e5eeaf2b4e6889e73854ce381ef2cb097eec40b5.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xfce4-panel/Makefile5
-rw-r--r--x11-wm/xfce4-panel/files/patch-libxfce4panel__xfce-panel-convenience.c46
2 files changed, 49 insertions, 2 deletions
diff --git a/x11-wm/xfce4-panel/Makefile b/x11-wm/xfce4-panel/Makefile
index 4ed634b3c2a2..3dea4e9ee4d7 100644
--- a/x11-wm/xfce4-panel/Makefile
+++ b/x11-wm/xfce4-panel/Makefile
@@ -4,7 +4,7 @@
PORTNAME= xfce4-panel
PORTVERSION= 4.10.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11-wm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DIST_SUBDIR= xfce4
@@ -16,11 +16,12 @@ LIB_DEPENDS= wnck-1:${PORTSDIR}/x11-toolkits/libwnck \
cairo:${PORTSDIR}/graphics/cairo \
dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+USES= pathfix
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack glib20 gtk20 intltool intlhack desktopfileutils
+USE_GNOME= glib20 gtk20 intltool intlhack desktopfileutils
USE_LDCONFIG= yes
USE_PERL5= yes
USE_XFCE= configenv garcon libexo libmenu libutil xfconf
diff --git a/x11-wm/xfce4-panel/files/patch-libxfce4panel__xfce-panel-convenience.c b/x11-wm/xfce4-panel/files/patch-libxfce4panel__xfce-panel-convenience.c
new file mode 100644
index 000000000000..6aa56870324a
--- /dev/null
+++ b/x11-wm/xfce4-panel/files/patch-libxfce4panel__xfce-panel-convenience.c
@@ -0,0 +1,46 @@
+--- ./libxfce4panel/xfce-panel-convenience.c.orig 2012-04-28 20:31:35.000000000 +0000
++++ ./libxfce4panel/xfce-panel-convenience.c 2013-04-06 21:01:14.000000000 +0000
+@@ -158,7 +158,7 @@
+ gchar *name;
+ gchar *filename;
+ gint src_w, src_h;
+- gdouble wratio, hratio;
++ gdouble ratio;
+ GdkPixbuf *dest;
+ GError *error = NULL;
+ gint size = MIN (dest_width, dest_height);
+@@ -170,15 +170,13 @@
+
+ if (G_UNLIKELY (g_path_is_absolute (source)))
+ {
+- pixbuf = gdk_pixbuf_new_from_file_at_scale (source, dest_width, dest_height, TRUE, &error);
++ pixbuf = gdk_pixbuf_new_from_file (source, &error);
+ if (G_UNLIKELY (pixbuf == NULL))
+ {
+ g_message ("Failed to load image \"%s\": %s",
+ source, error->message);
+ g_error_free (error);
+ }
+-
+- return pixbuf;
+ }
+ else
+ {
+@@ -233,13 +231,11 @@
+ if (src_w > dest_width || src_h > dest_height)
+ {
+ /* calculate the new dimensions */
+- wratio = (gdouble) src_w / (gdouble) size;
+- hratio = (gdouble) src_h / (gdouble) size;
++ ratio = MIN ((gdouble) dest_width / (gdouble) src_w,
++ (gdouble) dest_height / (gdouble) src_h);
+
+- if (hratio > wratio)
+- dest_width = rint (src_w / hratio);
+- else
+- dest_height = rint (src_h / wratio);
++ dest_width = rint (src_w * ratio);
++ dest_height = rint (src_h * ratio);
+
+ dest = gdk_pixbuf_scale_simple (pixbuf,
+ MAX (dest_width, 1),