aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2007-02-06 20:39:07 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2007-02-06 20:39:07 +0000
commite75ff3b34bf309d48503e7b181f65759abe86a5e (patch)
tree38ef2ef1eeaeebda2939ca8cf6db512d3305eaf4 /x11-wm
parentd05b21fda0ad9907fc31ea2a47be280a139dce7f (diff)
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xfce4/bsd.xfce.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-wm/xfce4/bsd.xfce.mk b/x11-wm/xfce4/bsd.xfce.mk
index 820426b8256a..f3e1b45fa7b2 100644
--- a/x11-wm/xfce4/bsd.xfce.mk
+++ b/x11-wm/xfce4/bsd.xfce.mk
@@ -1,3 +1,20 @@
+#
+# $FreeBSD$
+#
+
+.if !defined(_POSTMKINCLUDED) && !defined(Xfce_Pre_Include)
+
+Xfce_Pre_Include= bsd.xfce.mk
+Xfce_Include_MAINTAINER= oliver@FreeBSD.org
+
+# This file contains some variable definitions that are supposed to
+# make your life easier when dealing with ports related to the Xfce
+# desktop environment. It's automatically included when USE_XFCE
+# is defined in the ports' makefile.
+
+_USE_XFCE_ALL= configenv libexo libgui libutil libmcs mcsmanager panel \
+ thunar wm xfdev
+
MASTER_SITE_SUBDIR?= xfce-4.4.0
configenv_CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
@@ -22,9 +39,23 @@ wm_RUN_DEPENDS= xfwm4:${PORTSDIR}/x11-wm/xfce4-wm
xfdev_RUN_DEPENDS= xfce4-dev-tools:${PORTSDIR}/devel/xfce4-dev-tools
+.endif
+
+.if defined(_POSTMKINCLUDED) && !defined(Xfce_Post_Include)
+
+Xfce_Post_Include= bsd.xfce.mk
+
.for component in ${USE_XFCE}
BUILD_DEPENDS+= ${${component}_BUILD_DEPENDS}
LIB_DEPENDS+= ${${component}_LIB_DEPENDS}
RUN_DEPENDS+= ${${component}_RUN_DEPENDS}
CONFIGURE_ENV+= ${${component}_CONFIGURE_ENV}
.endfor
+
+.for component in ${USE_XFCE}
+. if ${_USE_XFCE_ALL:M${component}}==""
+IGNORE= cannot install: Unknown component ${component}
+. endif
+.endfor
+
+.endif