aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-12-31 16:46:09 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-12-31 17:16:31 +0000
commitbb69675791c557b87a5f8deefbf3992187e8382a (patch)
tree3385d5607e0335adb6f5c542227f259f7f93de85 /x11-wm
parentf0fb771fba55c5914e7e116a0d0da4f88b742ce3 (diff)
downloadports-bb69675791c557b87a5f8deefbf3992187e8382a.tar.gz
ports-bb69675791c557b87a5f8deefbf3992187e8382a.zip
x11-wm/dwl: unbreak on GCC architectures
In file included from dwl.c:377: client.h: In function 'client_get_appid': client.h:63: error: 'struct wlr_xdg_surface' has no member named 'toplevel' client.h: In function 'client_get_title': client.h:88: error: 'struct wlr_xdg_surface' has no member named 'toplevel' dwl.c: In function 'createkeyboard': dwl.c:797: error: 'struct wlr_input_device' has no member named 'keyboard' dwl.c:800: error: 'struct wlr_input_device' has no member named 'keyboard' dwl.c:803: error: 'struct wlr_input_device' has no member named 'keyboard' dwl.c:804: error: 'struct wlr_input_device' has no member named 'keyboard' dwl.c: In function 'createnotify': dwl.c:901: error: 'struct wlr_xdg_surface' has no member named 'toplevel' dwl.c:902: error: 'struct wlr_xdg_surface' has no member named 'toplevel' dwl.c: In function 'keypress': dwl.c:1242: error: 'struct wlr_input_device' has no member named 'keyboard' dwl.c:1245: error: 'struct wlr_input_device' has no member named 'keyboard' dwl.c: In function 'keypressmod': dwl.c:1277: error: 'struct wlr_input_device' has no member named 'keyboard'
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/dwl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/x11-wm/dwl/Makefile b/x11-wm/dwl/Makefile
index e812062142a5..19c26bbc0569 100644
--- a/x11-wm/dwl/Makefile
+++ b/x11-wm/dwl/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libwayland-server.so:graphics/wayland \
libinput.so:x11/libinput \
libxkbcommon.so:x11/libxkbcommon
-USES= gmake pkgconfig
+USES= compiler:c11 gmake pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= djpohly
PLIST_FILES= bin/${PORTNAME} \