aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2018-09-27 15:49:43 +0000
committerGleb Popov <arrowd@FreeBSD.org>2018-09-27 15:49:43 +0000
commit0a4e147de52b553866d9429ccb8cd4b497d9d416 (patch)
treeba1ea7216a4183c7a3ad84711ea4172eb2c7f4f4 /x11-wm
parent721bc9fa4882ad41197425f692965bee36d2806d (diff)
downloadports-0a4e147de52b553866d9429ccb8cd4b497d9d416.tar.gz
ports-0a4e147de52b553866d9429ccb8cd4b497d9d416.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/hs-xmonad-contrib/Makefile3
-rw-r--r--x11-wm/hs-xmonad-contrib/distinfo6
-rw-r--r--x11-wm/hs-xmonad-contrib/files/patch-8.4.2-support95
3 files changed, 4 insertions, 100 deletions
diff --git a/x11-wm/hs-xmonad-contrib/Makefile b/x11-wm/hs-xmonad-contrib/Makefile
index ccdcfbbb5e7f..7b3afbeaacb2 100644
--- a/x11-wm/hs-xmonad-contrib/Makefile
+++ b/x11-wm/hs-xmonad-contrib/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xmonad-contrib
-PORTVERSION= 0.13
-PORTREVISION= 4
+PORTVERSION= 0.14
CATEGORIES= x11-wm haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/x11-wm/hs-xmonad-contrib/distinfo b/x11-wm/hs-xmonad-contrib/distinfo
index 6de387ff2b8e..e7683ded1203 100644
--- a/x11-wm/hs-xmonad-contrib/distinfo
+++ b/x11-wm/hs-xmonad-contrib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1486836834
-SHA256 (cabal/xmonad-contrib-0.13.tar.gz) = a760827fe5b1f99d783f52ccbb72b272d02d53daa26757363cde3ceba014476e
-SIZE (cabal/xmonad-contrib-0.13.tar.gz) = 485351
+TIMESTAMP = 1538003068
+SHA256 (cabal/xmonad-contrib-0.14.tar.gz) = deccbc44f19977fc860024d2eb2ff63b5856058e3b078d16c234bb05fbe0c098
+SIZE (cabal/xmonad-contrib-0.14.tar.gz) = 523437
diff --git a/x11-wm/hs-xmonad-contrib/files/patch-8.4.2-support b/x11-wm/hs-xmonad-contrib/files/patch-8.4.2-support
deleted file mode 100644
index f54d82cd682a..000000000000
--- a/x11-wm/hs-xmonad-contrib/files/patch-8.4.2-support
+++ /dev/null
@@ -1,95 +0,0 @@
-diff --git XMonad/Hooks/FadeWindows.hs XMonad/Hooks/FadeWindows.hs
-index 4b8e62b6..01d06792 100644
---- XMonad/Hooks/FadeWindows.hs
-+++ XMonad/Hooks/FadeWindows.hs
-@@ -61,7 +61,8 @@ import Control.Monad.Reader (ask
- ,asks)
- import Control.Monad.State (gets)
- import qualified Data.Map as M
--import Data.Monoid
-+import Data.Monoid hiding ((<>))
-+import Data.Semigroup
-
- import Graphics.X11.Xlib.Extras (Event(..))
-
-@@ -134,6 +135,9 @@ instance Monoid Opacity where
- r `mappend` OEmpty = r
- _ `mappend` r = r
-
-+instance Semigroup Opacity where
-+ (<>) = mappend
-+
- -- | A FadeHook is similar to a ManageHook, but records window opacity.
- type FadeHook = Query Opacity
-
-diff --git XMonad/Hooks/WallpaperSetter.hs XMonad/Hooks/WallpaperSetter.hs
-index 00a3b1c3..d4f5ccb2 100644
---- XMonad/Hooks/WallpaperSetter.hs
-+++ XMonad/Hooks/WallpaperSetter.hs
-@@ -41,7 +41,8 @@ import Data.Ord (comparing)
- import Control.Monad
- import Control.Applicative
- import Data.Maybe
--import Data.Monoid
-+import Data.Monoid hiding ((<>))
-+import Data.Semigroup
-
- -- $usage
- -- This module requires imagemagick and feh to be installed, as these are utilized
-@@ -86,6 +87,9 @@ instance Monoid WallpaperList where
- mappend (WallpaperList w1) (WallpaperList w2) =
- WallpaperList $ M.toList $ (M.fromList w2) `M.union` (M.fromList w1)
-
-+instance Semigroup WallpaperList where
-+ (<>) = mappend
-+
- -- | Complete wallpaper configuration passed to the hook
- data WallpaperConf = WallpaperConf {
- wallpaperBaseDir :: FilePath -- ^ Where the wallpapers reside (if empty, will look in \~\/.wallpapers/)
-diff --git XMonad/Layout/Mosaic.hs XMonad/Layout/Mosaic.hs
-index 05655d4c..da44fc50 100644
---- XMonad/Layout/Mosaic.hs
-+++ XMonad/Layout/Mosaic.hs
-@@ -38,7 +38,8 @@ import Control.Monad(mplus)
- import Data.Foldable(Foldable,foldMap, sum)
- import Data.Function(on)
- import Data.List(sortBy)
--import Data.Monoid(Monoid,mempty, mappend)
-+import Data.Monoid(Monoid,mempty, mappend, (<>))
-+import Data.Semigroup
-
-
- -- $usage
-@@ -202,6 +203,9 @@ instance Monoid (Tree a) where
- mappend x Empty = x
- mappend x y = Branch x y
-
-+instance Semigroup (Tree a) where
-+ (<>) = mappend
-+
- makeTree :: (Num a1, Ord a1) => (a -> a1) -> [a] -> Tree a
- makeTree _ [] = Empty
- makeTree _ [x] = Leaf x
-diff --git xmonad-contrib.cabal xmonad-contrib.cabal
-index dde3ccda..c401c6e6 100644
---- xmonad-contrib.cabal
-+++ xmonad-contrib.cabal
-@@ -36,7 +36,7 @@ cabal-version: >= 1.6
- build-type: Simple
- bug-reports: https://github.com/xmonad/xmonad-contrib/issues
-
--tested-with: GHC==7.6.3, GHC==7.8.4, GHC==7.10.3, GHC==8.0.1
-+tested-with: GHC==7.6.3, GHC==7.8.4, GHC==7.10.3, GHC==8.0.1, GHC==8.2.2, GHC==8.4.1
-
- source-repository head
- type: git
-@@ -66,7 +66,8 @@ library
- unix,
- X11>=1.6.1 && < 1.9,
- xmonad>=0.13 && < 0.14,
-- utf8-string
-+ utf8-string,
-+ semigroups
-
- if flag(use_xft)
- build-depends: X11-xft >= 0.2