aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-05-12 23:13:12 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2002-05-12 23:13:12 +0000
commit57ef1ea5aca7be6b6c523b0a609b2907682b89a9 (patch)
tree66276c076c0e02c2913361d4b624c15902005913 /x11-wm
parent6cde80ac71fb75806e863a5bd1d77a6d0079c49d (diff)
downloadports-57ef1ea5aca7be6b6c523b0a609b2907682b89a9.tar.gz
ports-57ef1ea5aca7be6b6c523b0a609b2907682b89a9.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/hackedbox/Makefile146
-rw-r--r--x11-wm/hackedbox/distinfo2
-rw-r--r--x11-wm/hackedbox/pkg-comment2
-rw-r--r--x11-wm/hackedbox/pkg-descr15
5 files changed, 97 insertions, 69 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 089336b671f1..193da8b7d586 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -38,6 +38,7 @@
SUBDIR += gnome2wmaker
SUBDIR += golem
SUBDIR += gwm
+ SUBDIR += hackedbox
SUBDIR += icemc
SUBDIR += icepref
SUBDIR += icewm
diff --git a/x11-wm/hackedbox/Makefile b/x11-wm/hackedbox/Makefile
index c073674445d0..5ffe58db72ba 100644
--- a/x11-wm/hackedbox/Makefile
+++ b/x11-wm/hackedbox/Makefile
@@ -1,102 +1,124 @@
-# New ports collection makefile for: openbox
-# Date created: 2002-04-28
-# Whom: trevor
-# based on the blackbox port
+# New ports collection makefile for: hackedbox
+# Date created: 2002-05-11
+# Whom: Dominic Marks <dominic_marks@btinternet.com>
+# based on the blackbox and openbox ports
#
# $FreeBSD$
#
-PORTNAME= openbox
-PORTVERSION= 1.1.0
+PORTNAME= hackedbox
+PORTVERSION= 0.7.0
CATEGORIES= x11-wm
-MASTER_SITES= ftp://sunsite.dk/projects/openbox/
+MASTER_SITES= ftp://scrudgeware.org/
-MAINTAINER= trevor@FreeBSD.org
+MAINTAINER= dominic_marks@btinternet.com
-MAN1= openbox.1 osetroot.1 osetbg.1
-
-RUN_DEPENDS= xsetbg:${PORTSDIR}/x11/xloadimage
-
-DOCS= AUTHORS BUGS CHANGELOG CHANGELOG.Blackbox CHANGELOG.bsetbg \
- CodingStyle INSTALL LICENSE README README.bbtools \
- README.bsetbg TODO
-I10L= C da_DK de_DE es_ES et_EE fr_FR it_IT ja_JP nl_NL pt_BR ru_RU \
- sl_SI sv_SE tr_TR zh_CN
-STYLES= artwiz bluebox cthulhain deep flux frobozz frobust nyz \
- nyzclone operation outcomes shade steelblue steelblue2 \
- the_orange trisb twice
+MAN1= hackedbox.1 hsetroot.1
+DOCS= AUTHORS ChangeLog ChangeLog-0.40.x ChangeLog-0.50.x \
+ ChangeLog-0.51.x ChangeLog-0.60.x ChangeLog-0.62.x \
+ ChangeLog-0.7.0 ChangeLog.bsetbg INSTALL LICENSE \
+ README README.bbtools README.bsetbg TODO hackbox.pws
+I10L= C da_DK de_DE es_ES et_EE fr_FR it_IT nl_NL pt_BR ru_RU sl_SI \
+ sv_SE tr_TR
+BACKGROUNDS= Abominations.jpg Adrift.jpg Minus_thirty-five.jpg blackngrey.jpg
+STYLES= Artwiz Cthulhain Flux Minimal Nyz Operation Outcomes Rampage \
+ Rancor Results Shade Spiff TDF Twice
PLIST= ${WRKDIR}/pkg-plist
-USE_GMAKE= yes
+#USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
do-patch:
${PERL} -pi -e \
- "s:bsetbg:osetbg:g; s:bsetroot:osetroot:g; s:Bsetroot:Osetroot:g" \
- ${WRKSRC}/data/styles/* ${WRKSRC}/doc/*.1
-
+ "s:/usr/local/share/hackedbox:${PREFIX}/share/hackedbox:g" \
+ ${WRKSRC}/data/menu.in
+ ${PERL} -pi -e \
+ "s:blackbox:hackedbox:g; s:Blackbox:Hackedbox:g; \
+ s:bsetroot:hsetroot:g; s:Bsetroot:Hsetroot:g" \
+ ${WRKSRC}/data/styles/* ${WRKSRC}/doc/*.1 \
+ ${WRKSRC}/doc/ja_JP/*.1 ${WRKSRC}/doc/nl_NL/*.1 \
+ ${WRKSRC}/doc/sl_SI/*.1
pre-install:
${RM} -f ${PLIST}
-.for ii in osetbg osetroot openbox
+.for ii in hsetroot hackedbox
${ECHO_CMD} bin/${ii} >> ${PLIST}
.endfor
- ${ECHO_CMD} share/openbox/menu >> ${PLIST}
+ ${ECHO_CMD} share/hackedbox/menu >> ${PLIST}
+.for ii in POSIX US_ASCII de en en_US es fr it nl
+ ${ECHO_CMD} share/hackedbox/nls/${ii} >> ${PLIST}
+.endfor
.for ii in ${I10L}
- ${ECHO_CMD} share/openbox/nls/${ii}/openbox.cat >> ${PLIST}
- ${ECHO_CMD} @dirrm share/openbox/nls/${ii} >> ${PLIST}
+ ${ECHO_CMD} share/hackedbox/nls/${ii}/hackedbox.cat >> ${PLIST}
+ ${ECHO_CMD} @dirrm share/hackedbox/nls/${ii} >> ${PLIST}
.endfor
-.for ii in POSIX US_ASCII de en en_US es fr it nl
- ${ECHO_CMD} share/openbox/nls/${ii} >> ${PLIST}
+.for ii in ${BACKGROUNDS}
+ ${ECHO_CMD} share/hackedbox/backgrounds/${ii} >> ${PLIST}
.endfor
.for ii in ${STYLES}
- ${ECHO_CMD} share/openbox/styles/${ii} >> ${PLIST}
+ ${ECHO_CMD} share/hackedbox/styles/${ii} >> ${PLIST}
.endfor
-.for ii in /styles /nls /
- ${ECHO_CMD} @dirrm share/openbox${ii} >> ${PLIST}
+.for ii in /backgrounds /styles /nls /
+ ${ECHO_CMD} @dirrm share/hackedbox${ii} >> ${PLIST}
.endfor
.if !defined(NOPORTDOCS)
-.for ii in ${DOCS}
- ${ECHO_CMD} share/doc/openbox/${ii} >> ${PLIST}
+.for ii in ${DOCS} Hackedbox.xml
+ ${ECHO_CMD} share/doc/hackedbox/${ii} >> ${PLIST}
+.endfor
+.for ii in nl_NL/hackedbox.1 nl_NL/hsetroot.1 sl_SI/hackedbox.1
+ ${ECHO_CMD} share/doc/hackedbox/${ii} >> ${PLIST}
+.endfor
+.for ii in /nl_NL /sl_SI /
+ ${ECHO_CMD} @dirrm share/doc/hackedbox${ii} >> ${PLIST}
.endfor
- ${ECHO_CMD} @dirrm share/doc/openbox >> ${PLIST}
.endif
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/util/bsetbg ${PREFIX}/bin/osetbg
- ${INSTALL_PROGRAM} ${WRKSRC}/util/bsetroot ${PREFIX}/bin/osetroot
- ${INSTALL_PROGRAM} ${WRKSRC}/src/openbox ${PREFIX}/bin/
- ${MKDIR} ${DATADIR}/styles
+ ${INSTALL_PROGRAM} ${WRKSRC}/util/bsetroot ${PREFIX}/bin/hsetroot
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/blackbox ${PREFIX}/bin/hackedbox
+ ${MKDIR} ${DATADIR}/styles ${DATADIR}/backgrounds
${INSTALL_DATA} ${WRKSRC}/data/menu ${DATADIR}
.for ii in ${I10L}
- ${MKDIR} ${PREFIX}/share/openbox/nls/${ii}/
- ${INSTALL_DATA} ${WRKSRC}/nls/${ii}/openbox.cat \
- ${PREFIX}/share/openbox/nls/${ii}/
+ ${MKDIR} ${PREFIX}/share/hackedbox/nls/${ii}/
+ ${INSTALL_DATA} ${WRKSRC}/nls/${ii}/blackbox.cat \
+ ${PREFIX}/share/hackedbox/nls/${ii}/hackedbox.cat
+.endfor
+ cd ${PREFIX}/share/hackedbox/nls/ && \
+ ${LN} -fs C POSIX && \
+ ${LN} -fs C US_ASCII && \
+ ${LN} -fs C en && \
+ ${LN} -fs C en_US && \
+ ${LN} -fs de_DE de && \
+ ${LN} -fs es_ES es && \
+ ${LN} -fs fr_FR fr && \
+ ${LN} -fs it_IT it && \
+ ${LN} -fs nl_NL nl
+.for ii in ${BACKGROUNDS}
+ ${INSTALL_DATA} ${WRKSRC}/data/backgrounds/${ii} \
+ ${PREFIX}/share/hackedbox/backgrounds/
.endfor
- cd ${PREFIX}/share/openbox/nls/ && \
- ${LN} -s C POSIX && \
- ${LN} -s C US_ASCII && \
- ${LN} -s C en && \
- ${LN} -s C en_US && \
- ${LN} -s de_DE de && \
- ${LN} -s es_ES es && \
- ${LN} -s fr_FR fr && \
- ${LN} -s it_IT it && \
- ${LN} -s nl_NL nl
.for ii in ${STYLES}
${INSTALL_DATA} ${WRKSRC}/data/styles/${ii} \
- ${PREFIX}/share/openbox/styles/
-.endfor
-.for ii in setroot setbg
- ${CP} -p ${WRKSRC}/doc/b${ii}.1 ${WRKSRC}/doc/o${ii}.1
-.endfor
-.for ii in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/doc/${ii} ${PREFIX}/man/man1/
+ ${PREFIX}/share/hackedbox/styles/
.endfor
+ ${CP} -p ${WRKSRC}/doc/bsetroot.1 ${WRKSRC}/doc/hsetroot.1
+ ${CP} -p ${WRKSRC}/doc/blackbox.1 ${WRKSRC}/doc/hackedbox.1
+ ${INSTALL_MAN} ${WRKSRC}/doc/blackbox.1 ${PREFIX}/man/man1/hackedbox.1
+ ${INSTALL_MAN} ${WRKSRC}/doc/hsetroot.1 ${PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/doc/ja_JP/blackbox.1 \
+ ${PREFIX}/man/ja/man1/hackedbox.1
+ ${INSTALL_MAN} ${WRKSRC}/doc/ja_JP/bsetroot.1 \
+ ${PREFIX}/man/ja/man1/hsetroot.1
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for ii in ${DOCS}
+ ${MKDIR} ${DOCSDIR}/nl_NL ${DOCSDIR}/sl_SI
+.for ii in ${DOCS} doc/Hackedbox.xml
${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
.endfor
+ ${INSTALL_DATA} ${WRKSRC}/doc/nl_NL/blackbox.1 \
+ ${DOCSDIR}/nl_NL/hackedbox.1
+ ${INSTALL_DATA} ${WRKSRC}/doc/nl_NL/bsetroot.1 \
+ ${DOCSDIR}/nl_NL/hsetroot.1
+ ${INSTALL_DATA} ${WRKSRC}/doc/sl_SI/blackbox.1 \
+ ${DOCSDIR}/sl_SI/hackedbox.1
.endif
.include <bsd.port.mk>
diff --git a/x11-wm/hackedbox/distinfo b/x11-wm/hackedbox/distinfo
index a5344aae046d..d724aab85ea0 100644
--- a/x11-wm/hackedbox/distinfo
+++ b/x11-wm/hackedbox/distinfo
@@ -1,2 +1,2 @@
$FreeBSD$
-MD5 (openbox-1.1.0.tar.gz) = 6cabadd94e1f863e62a1f48df7d62cdf
+MD5 (hackedbox-0.7.0.tar.gz) = cba95984f7cfc269f963a69e74bcef42
diff --git a/x11-wm/hackedbox/pkg-comment b/x11-wm/hackedbox/pkg-comment
index 82785e082e82..ec914acdb80d 100644
--- a/x11-wm/hackedbox/pkg-comment
+++ b/x11-wm/hackedbox/pkg-comment
@@ -1 +1 @@
-Derived from, and similar to, Blackbox
+Hackedbox is a small and fast window manager based on Blackbox
diff --git a/x11-wm/hackedbox/pkg-descr b/x11-wm/hackedbox/pkg-descr
index 3e1a5b2573f5..5509b59ba713 100644
--- a/x11-wm/hackedbox/pkg-descr
+++ b/x11-wm/hackedbox/pkg-descr
@@ -1,7 +1,12 @@
-Openbox is based on, and similar to, blackbox. In this port/package,
-bsetbg and bsetroot are renamed to osetbg and osetroot in order to
-avoid conflict with blackbox.
+Hackedbox is based upon the popular Blackbox window manager. It
+aims to be fast and free of bloat. Several Blackbox features,
+including the toolbar and Slit, have been removed in Hackedbox. No
+new features are planned, only optimizations and fixes.
-Internationalization/localization does not work in this port.
+In this port/package, blackbox, bsetbg and bsetroot are renamed to
+hackedbox, hsetbg and hsetroot in order to avoid conflict with the
+corresponding programs from the blackbox port/package.
-WWW: http://openbox.sunsite.dk/
+WWW: http://scrudgeware.org/hackedbox/
+
+- Dominic <dominic_marks@btinternet.com>