aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-04-20 05:42:42 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-04-20 05:42:42 +0000
commit7661f5c4e89774773bacab373e6dd7f9e635cc96 (patch)
treec8e7269c94ca404a5705967eaccda73488b70d4f /x11-wm
parent1a251b99c9a22d0b7bd04ec2dfe0e84dcead36cc (diff)
downloadports-7661f5c4e89774773bacab373e6dd7f9e635cc96.tar.gz
ports-7661f5c4e89774773bacab373e6dd7f9e635cc96.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/icewm/Makefile3
-rw-r--r--x11-wm/icewm/distinfo6
-rw-r--r--x11-wm/icewm/files/patch-src_ylocale.cc14
3 files changed, 13 insertions, 10 deletions
diff --git a/x11-wm/icewm/Makefile b/x11-wm/icewm/Makefile
index 7d77977d8383..eaca2354bc1b 100644
--- a/x11-wm/icewm/Makefile
+++ b/x11-wm/icewm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= icewm
-PORTVERSION= 1.2.25
+PORTVERSION= 1.2.26
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,7 +17,6 @@ COMMENT= Window Manager designed for speed, usability and consistency
USE_X_PREFIX= yes
WANT_GNOME= yes
USE_GNOME= gnometarget
-USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
diff --git a/x11-wm/icewm/distinfo b/x11-wm/icewm/distinfo
index 2c42bba72210..e716e656e623 100644
--- a/x11-wm/icewm/distinfo
+++ b/x11-wm/icewm/distinfo
@@ -1,3 +1,3 @@
-MD5 (icewm-1.2.25.tar.gz) = af69d095a6c6fba1f73f80e966bc4459
-SHA256 (icewm-1.2.25.tar.gz) = b0971c6f79a1642eda06cdb79e022a05168f8031e408cc96e367318c9c5f97fa
-SIZE (icewm-1.2.25.tar.gz) = 1042790
+MD5 (icewm-1.2.26.tar.gz) = 097b12d3f8e0f57a964e4821bc1825ed
+SHA256 (icewm-1.2.26.tar.gz) = 96ed51cbaead5bd8c33522be5bf0baac4c051db0a826f764eb8528b2ec0c5497
+SIZE (icewm-1.2.26.tar.gz) = 1042824
diff --git a/x11-wm/icewm/files/patch-src_ylocale.cc b/x11-wm/icewm/files/patch-src_ylocale.cc
index 0ca66acf6c4d..e1b29970890f 100644
--- a/x11-wm/icewm/files/patch-src_ylocale.cc
+++ b/x11-wm/icewm/files/patch-src_ylocale.cc
@@ -1,7 +1,7 @@
---- src/ylocale.cc.orig Wed Apr 21 05:06:34 2004
-+++ src/ylocale.cc Sun Apr 25 19:40:07 2004
-@@ -149,7 +149,8 @@
- return NULL;
+--- src/ylocale.cc.orig Mon Apr 17 01:12:31 2006
++++ src/ylocale.cc Mon Apr 17 16:19:46 2006
+@@ -149,10 +149,11 @@
+ return NULL;
YUChar * uStr(new YUChar[lLen + 1]);
- char * inbuf((char *) lStr), * outbuf((char *) uStr);
@@ -9,4 +9,8 @@
+ char * outbuf((char *) uStr);
size_t inlen(lLen), outlen(4 * lLen);
- if (0 > (int) iconv(instance->toUnicode, &inbuf, &inlen, &outbuf, &outlen))
+- if (0 > (int) iconv(instance->toUnicode, const_cast<char **>(&inbuf), &inlen, &outbuf, &outlen))
++ if (0 > (int) iconv(instance->toUnicode, &inbuf, &inlen, &outbuf, &outlen))
+ warn(_("Invalid multibyte string \"%s\": %s"), lStr, strerror(errno));
+
+ *((YUChar *) outbuf) = 0;