aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorDejan Lesjak <lesi@FreeBSD.org>2005-03-17 23:22:13 +0000
committerDejan Lesjak <lesi@FreeBSD.org>2005-03-17 23:22:13 +0000
commitac39221672c3c391a6c127d2fcc67a1fe3d4512e (patch)
treede7ec01912bcb217296d86bd4fad9fd5b211f0cf /x11-wm
parent7534bc4462725b61b62a62d09f6b0c18686624b9 (diff)
downloadports-ac39221672c3c391a6c127d2fcc67a1fe3d4512e.tar.gz
ports-ac39221672c3c391a6c127d2fcc67a1fe3d4512e.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/ctwm/Makefile10
-rw-r--r--x11-wm/ctwm/pkg-plist1
-rw-r--r--x11-wm/vtwm/Makefile10
-rw-r--r--x11-wm/vtwm/pkg-plist1
4 files changed, 20 insertions, 2 deletions
diff --git a/x11-wm/ctwm/Makefile b/x11-wm/ctwm/Makefile
index 57c1f2c64da1..a3b5ff171a47 100644
--- a/x11-wm/ctwm/Makefile
+++ b/x11-wm/ctwm/Makefile
@@ -25,4 +25,12 @@ MAN1= ctwm.1
post-extract:
@(cd ${WRKSRC} && ${LN} -s ../xpm xpm)
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xorg
+PLIST_SUB+= NEWMTREE=""
+.else
+PLIST_SUB+= NEWMTREE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-wm/ctwm/pkg-plist b/x11-wm/ctwm/pkg-plist
index 63f9f3f850b0..a4646df20bb6 100644
--- a/x11-wm/ctwm/pkg-plist
+++ b/x11-wm/ctwm/pkg-plist
@@ -90,3 +90,4 @@ lib/X11/twm/images/xrn.xpm
lib/X11/twm/images/xterm.xpm
lib/X11/twm/system.ctwmrc
@dirrm lib/X11/twm/images
+%%NEWMTREE%%@unexec rmdir %D/lib/X11/twm 2>/dev/null || true
diff --git a/x11-wm/vtwm/Makefile b/x11-wm/vtwm/Makefile
index 7dde582f2b3f..0874291863fa 100644
--- a/x11-wm/vtwm/Makefile
+++ b/x11-wm/vtwm/Makefile
@@ -19,4 +19,12 @@ USE_XPM= yes
MAN1= vtwm.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xorg
+PLIST_SUB+= NEWMTREE=""
+.else
+PLIST_SUB+= NEWMTREE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-wm/vtwm/pkg-plist b/x11-wm/vtwm/pkg-plist
index 2be80dd2f8b4..1dd612a354a3 100644
--- a/x11-wm/vtwm/pkg-plist
+++ b/x11-wm/vtwm/pkg-plist
@@ -1,2 +1,3 @@
bin/vtwm
lib/X11/twm/system.vtwmrc
+%%NEWMTREE%%@unexec rmdir %D/lib/X11/twm 2>/dev/null || true