aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-08-18 09:41:17 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-08-18 09:42:54 +0000
commitbf4b73d37d7b09739e7275f94f1fb66ddb925a53 (patch)
treee4945761007bb823fd8adbcc3d459effedbd422e /x11-wm
parent93054149a58a80e1fcc21f3bdf171cadd7f47254 (diff)
downloadports-bf4b73d37d7b09739e7275f94f1fb66ddb925a53.tar.gz
ports-bf4b73d37d7b09739e7275f94f1fb66ddb925a53.zip
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/gamescope/Makefile6
-rw-r--r--x11-wm/gamescope/distinfo2
-rw-r--r--x11-wm/gamescope/files/patch-private-libs26
3 files changed, 3 insertions, 31 deletions
diff --git a/x11-wm/gamescope/Makefile b/x11-wm/gamescope/Makefile
index 0afccff3a983..04f0eb0a6c8d 100644
--- a/x11-wm/gamescope/Makefile
+++ b/x11-wm/gamescope/Makefile
@@ -15,11 +15,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= glslangValidator:graphics/glslang \
evdev-proto>0:devel/evdev-proto \
+ libliftoff>=0.3.0<0.4.0:graphics/libliftoff \
vulkan-headers>0:graphics/vulkan-headers \
wayland-protocols>=1.17:graphics/wayland-protocols \
wlroots>=0.15.0<0.16.0:x11-toolkits/wlroots
LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
libdrm.so:graphics/libdrm \
+ libliftoff.so:graphics/libliftoff \
libvulkan.so:graphics/vulkan-loader \
libwayland-server.so:graphics/wayland \
libwlroots.so:x11-toolkits/wlroots \
@@ -27,14 +29,12 @@ LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
USES= compiler:c++11-lib meson pkgconfig sdl xorg
USE_GITHUB= yes
-USE_GITLAB= nodefault
USE_SDL= sdl2
USE_XORG= x11 xcomposite xdamage xext xfixes xrender xres xtst xxf86vm
GH_ACCOUNT= Plagman
GH_TUPLE= nothings:stb:af1a5bc:stb/subprojects/stb
-GL_TUPLE= https://gitlab.freedesktop.org:emersion:libliftoff:9c84f7945aab0d88365f4c878f9de8a68deca3ea:libliftoff/subprojects/libliftoff
PLIST_FILES= bin/${PORTNAME}
-MESON_ARGS= --force-fallback-for=libliftoff # allow system wlroots
+MESON_ARGS= --force-fallback-for= # allow system wlroots + libliftoff
OPTIONS_DEFINE= PIPEWIRE
OPTIONS_DEFAULT=PIPEWIRE
diff --git a/x11-wm/gamescope/distinfo b/x11-wm/gamescope/distinfo
index bbb438a18841..8d8b020be368 100644
--- a/x11-wm/gamescope/distinfo
+++ b/x11-wm/gamescope/distinfo
@@ -3,8 +3,6 @@ SHA256 (Plagman-gamescope-3.11.36_GH0.tar.gz) = 39ea32510c6b7d982a9431e71a66e02a
SIZE (Plagman-gamescope-3.11.36_GH0.tar.gz) = 192928
SHA256 (nothings-stb-af1a5bc_GH0.tar.gz) = 3facf6e6f8c3e1715e1a088f22bad9c9202973f9369fb3f088f46cced3f64058
SIZE (nothings-stb-af1a5bc_GH0.tar.gz) = 1387334
-SHA256 (emersion-libliftoff-9c84f7945aab0d88365f4c878f9de8a68deca3ea_GL0.tar.gz) = a189ea791b1557e71274e671897bc253bdd3c8dbf460042b659d656444a8420b
-SIZE (emersion-libliftoff-9c84f7945aab0d88365f4c878f9de8a68deca3ea_GL0.tar.gz) = 31697
SHA256 (2a84a44f6897.patch) = fd892d4477885926b0ef5793d5222764afa2ba334fd25c4cc671c89812e100b5
SIZE (2a84a44f6897.patch) = 2931
SHA256 (e0927f7bce95.patch) = 6bbab2f37d7e76a1eade6d81bc0b441cc09f0020143bafb53555b767bf056600
diff --git a/x11-wm/gamescope/files/patch-private-libs b/x11-wm/gamescope/files/patch-private-libs
deleted file mode 100644
index a50ea41a00bf..000000000000
--- a/x11-wm/gamescope/files/patch-private-libs
+++ /dev/null
@@ -1,26 +0,0 @@
-libliftoff package is too old. Keep it private to gamescope package for now.
-
---- subprojects/libliftoff/meson.build.orig 2020-05-26 19:30:31 UTC
-+++ subprojects/libliftoff/meson.build
-@@ -38,7 +38,7 @@ liftoff_lib = library(
- include_directories: liftoff_inc,
- version: meson.project_version(),
- dependencies: liftoff_deps,
-- install: true,
-+ install: not meson.is_subproject(),
- )
-
- liftoff = declare_dependency(
-@@ -47,6 +47,7 @@ liftoff = declare_dependency(
- dependencies: liftoff_deps,
- )
-
-+if not meson.is_subproject()
- install_headers('include/libliftoff.h')
-
- pkgconfig = import('pkgconfig')
-@@ -60,3 +61,4 @@ pkgconfig.generate(
-
- subdir('example')
- subdir('test')
-+endif