aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-10-26 11:08:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-10-26 11:08:05 +0000
commit3acfca324de4a610de0eb5924a624c3bd6e94527 (patch)
tree917fc4d1c1855c8d92e0ac07d370fd4920381b91 /x11-wm
parent30b44b625201216c1e502d124998d11c42a07722 (diff)
downloadports-3acfca324de4a610de0eb5924a624c3bd6e94527.tar.gz
ports-3acfca324de4a610de0eb5924a624c3bd6e94527.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/e16utils/Makefile40
-rw-r--r--x11-wm/e16utils/distinfo4
-rw-r--r--x11-wm/e16utils/files/patch-e16keyedit-0.247
-rw-r--r--x11-wm/e16utils/files/patch-e16menuedit-0.1103
-rw-r--r--x11-wm/e16utils/pkg-descr1
-rw-r--r--x11-wm/e16utils/pkg-plist2
7 files changed, 198 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 504ae3eeb38a..3156039b6d5e 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -29,6 +29,7 @@
SUBDIR += devilspie
SUBDIR += dwm
SUBDIR += e16
+ SUBDIR += e16utils
SUBDIR += e17-module-alarm
SUBDIR += e17-module-calendar
SUBDIR += e17-module-comp-scale
diff --git a/x11-wm/e16utils/Makefile b/x11-wm/e16utils/Makefile
new file mode 100644
index 000000000000..23550826de32
--- /dev/null
+++ b/x11-wm/e16utils/Makefile
@@ -0,0 +1,40 @@
+# Created by: Jeremy Norris <ishmael27@home.com>
+# $FreeBSD$
+
+PORTNAME= e16utils
+PORTVERSION= 0.16
+PORTREVISION= 11
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= SF/enlightenment/e16menuedit/e16menuedit:src1 \
+ SF/enlightenment/e16keyedit/0.2:src2
+
+DISTFILES= e16menuedit-0.1.tar.gz:src1 \
+ e16keyedit-0.2.tar.gz:src2
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Standalone menu and keybinding editors for enlightenment 0.16
+
+LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm
+
+USE_GNOME= imlib
+
+SUB_STUBS= e16menuedit-0.1 e16keyedit-0.2
+
+do-patch:
+.for i in ${SUB_STUBS}
+ @cd ${WRKDIR}/${i} ; ${PATCH} -s < ${PATCHDIR}/patch-${i}
+.endfor
+
+do-build:
+.for i in ${SUB_STUBS}
+ @cd ${WRKDIR}/${i} ; ${SETENV} ${MAKE_ENV} ${MAKE} all
+.endfor
+
+do-install:
+.for i in ${SUB_STUBS}
+ @cd ${WRKDIR}/${i} ; \
+ ${INSTALL_PROGRAM} `${ECHO_CMD} '${i}' | ${SED} -e 's,-\(.*\),,'` \
+ ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e16utils/distinfo b/x11-wm/e16utils/distinfo
new file mode 100644
index 000000000000..dcec2042a16b
--- /dev/null
+++ b/x11-wm/e16utils/distinfo
@@ -0,0 +1,4 @@
+SHA256 (e16menuedit-0.1.tar.gz) = 2a5ed9b02af9788c1028cf052e78a4932ad52e42de037c6f0c5cf3b7e3c02a8b
+SIZE (e16menuedit-0.1.tar.gz) = 8450
+SHA256 (e16keyedit-0.2.tar.gz) = f95f05981c54372f2205694c4e2e27a060573c0608e187e1ba2d07bb4d8f5178
+SIZE (e16keyedit-0.2.tar.gz) = 13749
diff --git a/x11-wm/e16utils/files/patch-e16keyedit-0.2 b/x11-wm/e16utils/files/patch-e16keyedit-0.2
new file mode 100644
index 000000000000..2b6ab682c812
--- /dev/null
+++ b/x11-wm/e16utils/files/patch-e16keyedit-0.2
@@ -0,0 +1,47 @@
+
+$FreeBSD$
+
+--- Makefile.orig Fri Mar 24 04:04:16 2000
++++ Makefile Sat Aug 3 02:32:20 2002
+@@ -10,23 +10,23 @@
+ BUILD = \
+
+ LIB_DIRS = \
+- -L/usr/local/lib -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/dt/lib
++ -L${LOCALBASE}/lib
+ LIBS = \
+- `gtk-config --libs` -lgdbm -lgdk_imlib
+-CFLAGS = \
+- -O -g -D_GNU_SOURCE $(DEVFLAGS)
++ `${IMLIB_CONFIG} --libs-gdk` -lgdbm
++CFLAGS += \
++ -D_GNU_SOURCE $(DEVFLAGS)
+ #CFLAGS = \
+ # -O -g -W -Wall -Wno-unused -pedantic -pedantic-errors -ansi -D_GNU_SOURCE
+-OPTFLAGS = \
+- -O6 -mpentium -mcpu=pentium -march=pentium -ffast-math -D_GNU_SOURCE
++#OPTFLAGS = \
++# -O6 -mpentium -mcpu=pentium -march=pentium -ffast-math -D_GNU_SOURCE
+ INCLUDES = \
+- `gtk-config --cflags` -I..
++ `${IMLIB_CONFIG} --cflags-gdk` -I..
+
+ BIN = e16keyedit
+
+ # configurable stuff
+-BINARY_DESTINATION = /usr/local/enlightenment/bin
+-DATA_DESTINATION = /usr/local/enlightenment/share
++BINARY_DESTINATION = ${PREFIX}/bin
++DATA_DESTINATION = ${PREFIX}/share
+
+ # commands to do things
+ INSTALL = install
+@@ -39,7 +39,7 @@
+ MAKE = make
+ STRIP = strip
+ SED = sed
+-MAKEDEP = gcc -MM $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDES) $(EXTRA_INCLUDES)
++MAKEDEP = ${CC} -MM $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDES) $(EXTRA_INCLUDES)
+ #MAKEDEP = makedepend -f- -s'\# CUT' -- -Y $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDES) $(EXTRA_INCLUDES) --
+
+ # piece together variables
diff --git a/x11-wm/e16utils/files/patch-e16menuedit-0.1 b/x11-wm/e16utils/files/patch-e16menuedit-0.1
new file mode 100644
index 000000000000..91244e3eb2fa
--- /dev/null
+++ b/x11-wm/e16utils/files/patch-e16menuedit-0.1
@@ -0,0 +1,103 @@
+
+$FreeBSD$
+
+--- Makefile.orig Mon Apr 17 05:40:03 2000
++++ Makefile Sat Aug 3 02:33:28 2002
+@@ -10,23 +10,23 @@
+ BUILD = \
+
+ LIB_DIRS = \
+- -L/usr/local/lib -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/dt/lib
++ -L${LOCALBASE}/lib
+ LIBS = \
+- `gtk-config --libs` -lgdbm -lgdk_imlib
+-CFLAGS = \
+- -O -g -D_GNU_SOURCE $(DEVFLAGS)
++ `${IMLIB_CONFIG} --libs-gdk` -lgdbm
++CFLAGS += \
++ -D_GNU_SOURCE $(DEVFLAGS)
+ #CFLAGS = \
+ # -O -g -W -Wall -Wno-unused -pedantic -pedantic-errors -ansi -D_GNU_SOURCE
+-OPTFLAGS = \
+- -O6 -mpentium -mcpu=pentium -march=pentium -ffast-math -D_GNU_SOURCE
++#OPTFLAGS = \
++# -O6 -mpentium -mcpu=pentium -march=pentium -ffast-math -D_GNU_SOURCE
+ INCLUDES = \
+- `gtk-config --cflags` -I..
++ `${IMLIB_CONFIG} --cflags-gdk` -I..
+
+ BIN = e16menuedit
+
+ # configurable stuff
+-BINARY_DESTINATION = /usr/local/enlightenment/bin
+-DATA_DESTINATION = /usr/local/enlightenment/share
++BINARY_DESTINATION = ${PREFIX}/bin
++DATA_DESTINATION = ${PREFIX}/share
+
+ # commands to do things
+ INSTALL = install
+@@ -39,7 +39,7 @@
+ MAKE = make
+ STRIP = strip
+ SED = sed
+-MAKEDEP = gcc -MM $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDES) $(EXTRA_INCLUDES)
++MAKEDEP = ${CC} -MM $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDES) $(EXTRA_INCLUDES)
+ #MAKEDEP = makedepend -f- -s'\# CUT' -- -Y $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDES) $(EXTRA_INCLUDES) --
+
+ # piece together variables
+--- viewer.c.orig 2000-04-16 22:40:03.000000000 +0200
++++ viewer.c 2008-01-11 18:08:53.000000000 +0100
+@@ -34,7 +34,7 @@
+ if (!file_to_load)
+ return;
+ if (file_to_load[0] != '/')
+- sprintf (buf, "%s/.enlightenment/%s", homedir (getuid ()), file_to_load);
++ sprintf (buf, "%s/.e16/menus/%s", homedir (getuid ()), file_to_load);
+ else
+ sprintf (buf, "%s", file_to_load);
+
+@@ -108,7 +108,7 @@
+ GtkCTreeNode *parent = NULL;
+
+ /* currently hardcoded, but not a big issue to change later */
+- sprintf (buf, "%s/.enlightenment/file.menu", homedir (getuid ()));
++ sprintf (buf, "%s/.e16/menus/file.menu", homedir (getuid ()));
+ menufile = fopen (buf, "r");
+ if (!menufile)
+ {
+@@ -564,7 +564,7 @@
+ gint retval = 0;
+
+ buf =
+- g_strjoin ("/", homedir (getuid ()), ".enlightenment", "file.menu", NULL);
++ g_strjoin ("/", homedir (getuid ()), ".e16/menus", "file.menu", NULL);
+
+ node =
+ gtk_ctree_export_to_gnode (GTK_CTREE (ctree), NULL, NULL,
+@@ -683,7 +683,7 @@
+ {
+ /* Tarnation! A relative path */
+ realfile =
+- g_strjoin ("/", homedir (getuid ()), ".enlightenment", file, NULL);
++ g_strjoin ("/", homedir (getuid ()), ".e16/menus", file, NULL);
+ }
+ else
+ realfile = g_strdup (file);
+@@ -717,7 +717,7 @@
+ if (G_NODE_IS_LEAF (node))
+ {
+ /* It's an entry */
+- fprintf (fp, "\"%s\"\t%s\texec\t\"%s\"\n",
++ fprintf (fp, "\"%s\"\t\"%s\"\texec\t\"%s\"\n",
+ dat->desc[0] == '\0' ? "NULL" : dat->desc,
+ dat->icon[0] == '\0' ? "NULL" : dat->icon,
+ dat->params[0] == '\0' ? "" : dat->params);
+@@ -725,7 +725,7 @@
+ else
+ {
+ /* It's a submenu */
+- fprintf (fp, "\"%s\"\t%s\tmenu\t\"%s\"\n",
++ fprintf (fp, "\"%s\"\t\"%s\"\tmenu\t\"%s\"\n",
+ dat->desc[0] == '\0' ? "NULL" : dat->desc,
+ dat->icon[0] == '\0' ? "NULL" : dat->icon,
+ dat->params[0] == '\0' ? "" : dat->params);
diff --git a/x11-wm/e16utils/pkg-descr b/x11-wm/e16utils/pkg-descr
new file mode 100644
index 000000000000..5918d33b2bef
--- /dev/null
+++ b/x11-wm/e16utils/pkg-descr
@@ -0,0 +1 @@
+Standalone menu and keybinding editors for enlightment 0.16.
diff --git a/x11-wm/e16utils/pkg-plist b/x11-wm/e16utils/pkg-plist
new file mode 100644
index 000000000000..585bfd696d87
--- /dev/null
+++ b/x11-wm/e16utils/pkg-plist
@@ -0,0 +1,2 @@
+bin/e16menuedit
+bin/e16keyedit