aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-01-27 19:40:17 +0000
committerRene Ladan <rene@FreeBSD.org>2020-01-27 19:40:17 +0000
commitb0eec09651960d8c9d8a0981beab512bfb3c21f7 (patch)
tree94e26138c8267621b1b647591febb9f4c2bee2eb /x11-wm
parent56b735e2588de9f5ab64b0122de9f731ea768c0c (diff)
downloadports-b0eec09651960d8c9d8a0981beab512bfb3c21f7.tar.gz
ports-b0eec09651960d8c9d8a0981beab512bfb3c21f7.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/muffin/Makefile4
-rw-r--r--x11-wm/muffin/files/patch-configure.ac12
-rw-r--r--x11-wm/muffin/files/patch-src_core_main.c6
3 files changed, 17 insertions, 5 deletions
diff --git a/x11-wm/muffin/Makefile b/x11-wm/muffin/Makefile
index 16bbe164e48f..083a43ec1e4d 100644
--- a/x11-wm/muffin/Makefile
+++ b/x11-wm/muffin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= muffin
PORTVERSION= 2.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm gnome
DIST_SUBDIR= gnome3
@@ -23,7 +23,7 @@ USES= autoreconf:build gettext gmake gnome libtool pathfix pkgconfig \
python:2.7 xorg
USE_GITHUB= yes
GH_ACCOUNT= linuxmint
-USE_GNOME= gconf2 gnomedocutils gnomeprefix gtk30 \
+USE_GNOME= gconf2 gnomeprefix gtk30 \
intlhack introspection:build
USE_XORG= x11 xext xrandr xcomposite xcursor xinerama ice sm
USE_LDCONFIG= yes
diff --git a/x11-wm/muffin/files/patch-configure.ac b/x11-wm/muffin/files/patch-configure.ac
new file mode 100644
index 000000000000..034a2609221a
--- /dev/null
+++ b/x11-wm/muffin/files/patch-configure.ac
@@ -0,0 +1,12 @@
+--- configure.ac.orig 2015-02-02 16:02:44 UTC
++++ configure.ac
+@@ -412,9 +412,6 @@ fi
+ # For fix-meta-rectangle.py
+ AM_PATH_PYTHON([2.5])
+
+-# Use gnome-doc-utils:
+-GNOME_DOC_INIT([0.8.0])
+-
+ #### Warnings (last since -Werror can disturb other tests)
+
+ # Stay command-line compatible with the gnome-common configure option. Here
diff --git a/x11-wm/muffin/files/patch-src_core_main.c b/x11-wm/muffin/files/patch-src_core_main.c
index a248e943ac3b..c2ee5f5e8625 100644
--- a/x11-wm/muffin/files/patch-src_core_main.c
+++ b/x11-wm/muffin/files/patch-src_core_main.c
@@ -1,6 +1,6 @@
---- src/core/main.c.orig 2010-02-12 12:17:38.000000000 -0500
-+++ src/core/main.c 2010-02-19 01:22:45.000000000 -0500
-@@ -59,7 +59,11 @@
+--- src/core/main.c.orig 2015-02-02 16:02:44 UTC
++++ src/core/main.c
+@@ -61,7 +61,11 @@
#include <stdlib.h>
#include <sys/types.h>