aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-25 03:42:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-25 03:42:32 +0000
commit04f9a046edbbfa6597d3d18ec514580e0499aa2e (patch)
treecc77c932b7d61f2d19524d8aca8d4956ef35c92f /x11-wm
parent1e13102249e50fe7d3b8fbcb6f6488e50493f27b (diff)
Winlist NG module for Enlightenment 17.
It is a replacement for the standard winlist. This module should not only look different as the e17 winlist, it also will get a lot of functionality i was missing, for example: decide while selecting if you want to jump to the desk of the selected app or bring the selected app to the current desk, close the selected app directly, show the selected app on the current desk(if it's on another desk), etc. WWW: http://www.enlightenment.org/ PR: ports/154402 zubmitted by: Grzegorz Blach <magik at roorback.net>
Notes
Notes: svn path=/head/; revision=276264
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/e17-module-winlist-ng/Makefile36
-rw-r--r--x11-wm/e17-module-winlist-ng/distinfo2
-rw-r--r--x11-wm/e17-module-winlist-ng/pkg-descr11
-rw-r--r--x11-wm/e17-module-winlist-ng/pkg-plist10
5 files changed, 60 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 09c1cc830f55..14b4e5c837e1 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -75,6 +75,7 @@
SUBDIR += e17-module-tiling
SUBDIR += e17-module-uptime
SUBDIR += e17-module-weather
+ SUBDIR += e17-module-winlist-ng
SUBDIR += e17-module-winselector
SUBDIR += e17-module-wlan
SUBDIR += e17-modules
diff --git a/x11-wm/e17-module-winlist-ng/Makefile b/x11-wm/e17-module-winlist-ng/Makefile
new file mode 100644
index 000000000000..bb9c7ccf3ab8
--- /dev/null
+++ b/x11-wm/e17-module-winlist-ng/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-winlist-ng
+# Date created: 29 January 2011
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= winlist-ng
+PORTVERSION= 20110129
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2011-01-29/modules/
+PKGNAMEPREFIX= e17-module-
+
+MAINTAINER= magik@roorback.net
+COMMENT= A Winlist NG module for Enlightenment 17
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= e17
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= edje libtool_hack modarch_hack
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e17-module-winlist-ng/distinfo b/x11-wm/e17-module-winlist-ng/distinfo
new file mode 100644
index 000000000000..f86d7b0acea7
--- /dev/null
+++ b/x11-wm/e17-module-winlist-ng/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/winlist-ng-20110129.tar.bz2) = 63823925f3dc484329fac5360f5c036215b68b572c2934a09d876eaf40ed689d
+SIZE (e17/winlist-ng-20110129.tar.bz2) = 561698
diff --git a/x11-wm/e17-module-winlist-ng/pkg-descr b/x11-wm/e17-module-winlist-ng/pkg-descr
new file mode 100644
index 000000000000..7a444737c62a
--- /dev/null
+++ b/x11-wm/e17-module-winlist-ng/pkg-descr
@@ -0,0 +1,11 @@
+A Winlist NG module for Enlightenment 17.
+It is a replacement for the standard winlist.
+
+This module should not only look different as the e17 winlist, it
+also will get a lot of functionality i was missing, for example:
+decide while selecting if you want to jump to the desk of the
+selected app or bring the selected app to the current desk, close
+the selected app directly, show the selected app on the current
+desk(if it's on another desk), etc.
+
+WWW: http://www.enlightenment.org/
diff --git a/x11-wm/e17-module-winlist-ng/pkg-plist b/x11-wm/e17-module-winlist-ng/pkg-plist
new file mode 100644
index 000000000000..39b3bbb61283
--- /dev/null
+++ b/x11-wm/e17-module-winlist-ng/pkg-plist
@@ -0,0 +1,10 @@
+lib/enlightenment/modules/winlist-ng/module_icon.png
+lib/enlightenment/modules/winlist-ng/ng.edc
+lib/enlightenment/modules/winlist-ng/module.desktop
+lib/enlightenment/modules/winlist-ng/ng.edj
+lib/enlightenment/modules/winlist-ng/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/winlist-ng/e-module-ng.edj
+@dirrm lib/enlightenment/modules/winlist-ng/%%E17_ARCH%%
+@dirrm lib/enlightenment/modules/winlist-ng/
+@dirrmtry lib/enlightenment/modules
+@dirrmtry lib/enlightenment