aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2010-04-24 00:12:44 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2010-04-24 00:12:44 +0000
commitc12ad461607125aa5a06154b9f19ef64d8919948 (patch)
treecc3ceb9be16bd04e138523ae6a9ac97f5ecd1707 /x11-wm
parentc6935d779aea55a56a4adc560d88969141d5edda (diff)
downloadports-c12ad461607125aa5a06154b9f19ef64d8919948.tar.gz
ports-c12ad461607125aa5a06154b9f19ef64d8919948.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/jwm/Makefile33
1 files changed, 31 insertions, 2 deletions
diff --git a/x11-wm/jwm/Makefile b/x11-wm/jwm/Makefile
index fe8169e4b141..790d92a80102 100644
--- a/x11-wm/jwm/Makefile
+++ b/x11-wm/jwm/Makefile
@@ -7,12 +7,11 @@
PORTNAME= jwm
PORTVERSION= 2.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-wm
MASTER_SITES= SF \
http://joewing.net/programs/
-
MAINTAINER= admin@mjbrune.org
COMMENT= Joe's Window Manager
@@ -27,11 +26,41 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= jwm.1
+OPTIONS= FRIBIDI "Fribidi support" on \
+ XFT "Xft support " on \
+ XINERAMA "XINERAMA support" on \
+ JPEG "JPEG support" on \
+ DEBUG "Enable Debugging" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_FRIBIDI)
+BUILD_DEPENDS+= fribidi:${PORTSDIR}/converters/fribidi
+.endif
+
+.if defined(WITH_XFT)
+LIB_DEPENDS+= Xft:${PORTSDIR}/x11-fonts/libXft
+.endif
+
+.if defined(WITH_XINERAMA)
+LIB_DEPENDS+= Xinerama:${PORTSDIR}/x11/libXinerama
+
+.endif
+
+.if defined(WITH_JPEG)
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/example.jwmrc
+ @${REINPLACE_CMD} -e 's|fribidi_char_sets_utf8.h|fribidi-char-sets.h|' ${WRKSRC}/src/jwm.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/jwm ${PREFIX}/bin