aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-08-22 21:58:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-08-22 21:58:25 +0000
commitd1701f00f88e78a2c3033deece2eded7b3c67d51 (patch)
tree871d0eb2fd148cd9194fcab8e91d9e4d5bd83f95 /x11-wm
parent905b29b6e07a8c26f2f6ad86656b25f05e868c79 (diff)
downloadports-d1701f00f88e78a2c3033deece2eded7b3c67d51.tar.gz
ports-d1701f00f88e78a2c3033deece2eded7b3c67d51.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/i3/Makefile9
-rw-r--r--x11-wm/i3/distinfo4
-rw-r--r--x11-wm/i3/files/patch-src__log.c68
-rw-r--r--x11-wm/i3/pkg-descr2
4 files changed, 6 insertions, 77 deletions
diff --git a/x11-wm/i3/Makefile b/x11-wm/i3/Makefile
index d836707f1a90..3d55ecaf3a1a 100644
--- a/x11-wm/i3/Makefile
+++ b/x11-wm/i3/Makefile
@@ -2,15 +2,12 @@
# $FreeBSD$
PORTNAME= i3
-DISTVERSION= 4.5.1
-PORTREVISION= 1
+DISTVERSION= 4.6
CATEGORIES= x11-wm
-MASTER_SITES= http://i3wm.org/downloads/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= dhn
+MASTER_SITES= http://i3wm.org/downloads/
MAINTAINER= bapt@FreeBSD.org
-COMMENT= An improved dynamic tiling window manager
+COMMENT= Improved dynamic tiling window manager
LICENSE= BSD
diff --git a/x11-wm/i3/distinfo b/x11-wm/i3/distinfo
index cb831759852c..57b8fb2b5cf9 100644
--- a/x11-wm/i3/distinfo
+++ b/x11-wm/i3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (i3-4.5.1.tar.bz2) = bae55f1c7c4a21d71aae182e4fab6038ba65ba4be5d1ceff9e269f4f74b823f2
-SIZE (i3-4.5.1.tar.bz2) = 878954
+SHA256 (i3-4.6.tar.bz2) = f5d2118441cec8b623d18610f3793c55df9da6af15b4df8523e86309096956e1
+SIZE (i3-4.6.tar.bz2) = 891862
diff --git a/x11-wm/i3/files/patch-src__log.c b/x11-wm/i3/files/patch-src__log.c
deleted file mode 100644
index 5c50252eeb57..000000000000
--- a/x11-wm/i3/files/patch-src__log.c
+++ /dev/null
@@ -1,68 +0,0 @@
---- ./src/log.c.orig 2013-03-20 15:28:14.746383400 +0100
-+++ ./src/log.c 2013-03-20 18:27:56.885378021 +0100
-@@ -81,11 +81,11 @@
- void init_logging(void) {
- if (!errorfilename) {
- if (!(errorfilename = get_process_filename("errorlog")))
-- ELOG("Could not initialize errorlog\n");
-+ fprintf(stderr, "Could not initialize errorlog\n");
- else {
- errorfile = fopen(errorfilename, "w");
- if (fcntl(fileno(errorfile), F_SETFD, FD_CLOEXEC)) {
-- ELOG("Could not set close-on-exec flag\n");
-+ fprintf(stderr, "Could not set close-on-exec flag\n");
- }
- }
- }
-@@ -107,25 +107,28 @@
- sysconf(_SC_PAGESIZE);
- #endif
- logbuffer_size = min(physical_mem_bytes * 0.01, shmlog_size);
-- sasprintf(&shmlogname, "/i3-log-%d", getpid());
-+#if defined(__FreeBSD__)
-+ asprintf(&shmlogname, "/tmp/i3-log-%d", getpid());
-+#else
-+ asprintf(&shmlogname, "/i3-log-%d", getpid());
-+#endif
- logbuffer_shm = shm_open(shmlogname, O_RDWR | O_CREAT, S_IREAD | S_IWRITE);
- if (logbuffer_shm == -1) {
-- ELOG("Could not shm_open SHM segment for the i3 log: %s\n", strerror(errno));
-+ fprintf(stderr, "Could not shm_open SHM segment for the i3 log: %s\n", strerror(errno));
- return;
- }
--
- if (ftruncate(logbuffer_shm, logbuffer_size) == -1) {
- close(logbuffer_shm);
-- shm_unlink("/i3-log-");
-- ELOG("Could not ftruncate SHM segment for the i3 log: %s\n", strerror(errno));
-+ shm_unlink(shmlogname);
-+ fprintf(stderr, "Could not ftruncate SHM segment for the i3 log: %s\n", strerror(errno));
- return;
- }
-
- logbuffer = mmap(NULL, logbuffer_size, PROT_READ | PROT_WRITE, MAP_SHARED, logbuffer_shm, 0);
- if (logbuffer == MAP_FAILED) {
- close(logbuffer_shm);
-- shm_unlink("/i3-log-");
-- ELOG("Could not mmap SHM segment for the i3 log: %s\n", strerror(errno));
-+ shm_unlink(shmlogname);
-+ fprintf(stderr, "Could not mmap SHM segment for the i3 log: %s\n", strerror(errno));
- logbuffer = NULL;
- return;
- }
-@@ -138,13 +141,14 @@
- pthread_condattr_t cond_attr;
- pthread_condattr_init(&cond_attr);
- if (pthread_condattr_setpshared(&cond_attr, PTHREAD_PROCESS_SHARED) != 0)
-- ELOG("pthread_condattr_setpshared() failed, i3-dump-log -f will not work!\n");
-+ fprintf(stderr, "pthread_condattr_setpshared() failed, i3-dump-log -f will not work!\n");
- pthread_cond_init(&(header->condvar), &cond_attr);
-
- logwalk = logbuffer + sizeof(i3_shmlog_header);
- loglastwrap = logbuffer + logbuffer_size;
- store_log_markers();
- }
-+
- atexit(purge_zerobyte_logfile);
- }
-
diff --git a/x11-wm/i3/pkg-descr b/x11-wm/i3/pkg-descr
index 0a1777594035..d6b23b305cfc 100644
--- a/x11-wm/i3/pkg-descr
+++ b/x11-wm/i3/pkg-descr
@@ -1,4 +1,4 @@
i3 is an improved dynamic, tiling window manager.
Inspired by wmii that supported Xinerama.
-WWW: http://i3wm.org
+WWW: http://i3wm.org