aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-04-01 17:43:39 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-04-01 17:43:39 +0000
commitdb3d10336a900aac3e56c788e9d7b8a58695d12a (patch)
treeedd2b26ac477b0ef3dde42f28f05db92cf20c4b6 /x11-wm
parent881c6d5546c92484681f6ba2a2422ef2d5eba3c3 (diff)
downloadports-db3d10336a900aac3e56c788e9d7b8a58695d12a.tar.gz
ports-db3d10336a900aac3e56c788e9d7b8a58695d12a.zip
Notes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/awesome/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/x11-wm/awesome/Makefile b/x11-wm/awesome/Makefile
index 8a2a0b9d777a..6c26b2aed4e7 100644
--- a/x11-wm/awesome/Makefile
+++ b/x11-wm/awesome/Makefile
@@ -22,7 +22,6 @@ BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
xcb-util>=0.3.3:${PORTSDIR}/x11/xcb-util \
xproto>=7.0.11:${PORTSDIR}/x11/xproto
LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
- dbus-1.3:${PORTSDIR}/devel/dbus \
ev.3:${PORTSDIR}/devel/libev \
freetype.9:${PORTSDIR}/print/freetype2 \
xcb.2:${PORTSDIR}/x11/libxcb \
@@ -44,6 +43,8 @@ MAN5= awesomerc.5
MANCOMPRESSED= yes
PORTDOCS= AUTHORS BUGS LICENSE README
+OPTIONS+= DBUS "Enable D-BUS support" On
+
.include <bsd.port.pre.mk>
.if (exists(${LOCALBASE}/libdata/pkgconfig/cairo.pc) && \
@@ -51,12 +52,19 @@ PORTDOCS= AUTHORS BUGS LICENSE README
IGNORE= cannot find dependency: The cairo exists but not with XCB support. Please reinstall graphics/cairo with XCB support
.endif
+.ifdef(WITH_DBUS)
+LIB_DEPENDS += dbus-1.3:${PORTSDIR}/devel/dbus
+CMAKE_ARGS += -DWITH_DBUS=YES
+.else
+CMAKE_ARGS += -DWITH_DBUS=NO
+.endif
+
pre-configure:
@${REINPLACE_CMD} \
-e 's/"generate luadoc" ON/\"generate luadoc" OFF/g' \
${WRKSRC}/awesomeConfig.cmake
@${REINPLACE_CMD} \
- -e 's,tr ,env LC_ALL="C" tr ,g' \
+ -e 's,tr ,env LC_ALL="C" ${TR} ,g' \
-e 's,gperf,${LOCALBASE}/bin/gperf,g' \
${WRKSRC}/build-utils/gperf.sh
.if defined(NOPORTDOCS)