aboutsummaryrefslogtreecommitdiff
path: root/x11/3ddesktop
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-30 08:37:15 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-30 08:37:15 +0000
commit230189d87d4a51473dd794dd3080e90f9fd784ae (patch)
treebf753bb141e512aa6b0f58ea32d33c82c498cb7f /x11/3ddesktop
parentc9d420ce55a351c82db475506876bf45c93d552d (diff)
downloadports-230189d87d4a51473dd794dd3080e90f9fd784ae.tar.gz
ports-230189d87d4a51473dd794dd3080e90f9fd784ae.zip
Update to version 0.2.7
PR: ports/71126 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=117643
Diffstat (limited to 'x11/3ddesktop')
-rw-r--r--x11/3ddesktop/Makefile34
-rw-r--r--x11/3ddesktop/distinfo4
-rw-r--r--x11/3ddesktop/files/patch-3ddesk.cpp10
-rw-r--r--x11/3ddesktop/files/patch-util.h11
-rw-r--r--x11/3ddesktop/pkg-plist8
5 files changed, 47 insertions, 20 deletions
diff --git a/x11/3ddesktop/Makefile b/x11/3ddesktop/Makefile
index c4a68f18df83..fc9d8216beb1 100644
--- a/x11/3ddesktop/Makefile
+++ b/x11/3ddesktop/Makefile
@@ -5,21 +5,35 @@
# $FreeBSD$
#
-PORTNAME= 3ddesktop
-PORTVERSION= 0.2.5
-PORTREVISION= 1
-CATEGORIES= x11
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+PORTNAME= 3ddesktop
+PORTVERSION= 0.2.7
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= desk3d
-MAINTAINER= ports@FreeBSD.org
-COMMENT= 3D Virtual Desktop Switcher
+MAINTAINER= ports@FreeBSD.org
+COMMENT= 3D Virtual Desktop Switcher
-LIB_DEPENDS= Imlib2.2:${PORTSDIR}/graphics/imlib2
+LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut \
+ Imlib2.2:${PORTSDIR}/graphics/imlib2
-USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_GL= yes
USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+PORTDOCS= README README.windowmanagers
+PLIST_FILES= bin/3ddesk bin/3ddeskd etc/3ddesktop.conf \
+ %%DATADIR%%/digits.bmp
+PLIST_DIRS= %%DATADIR%%
+
+CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/Makefile.in
post-install:
.if !defined(NOPORTDOCS)
diff --git a/x11/3ddesktop/distinfo b/x11/3ddesktop/distinfo
index edb2219c0e85..720bd116a051 100644
--- a/x11/3ddesktop/distinfo
+++ b/x11/3ddesktop/distinfo
@@ -1,2 +1,2 @@
-MD5 (3ddesktop-0.2.5.tar.gz) = afecac14b6d432e757e37085d4bc8549
-SIZE (3ddesktop-0.2.5.tar.gz) = 162089
+MD5 (3ddesktop-0.2.7.tar.gz) = 2b9204195101d17eaca02f0c5286ed15
+SIZE (3ddesktop-0.2.7.tar.gz) = 167984
diff --git a/x11/3ddesktop/files/patch-3ddesk.cpp b/x11/3ddesktop/files/patch-3ddesk.cpp
new file mode 100644
index 000000000000..69b8f288f6f4
--- /dev/null
+++ b/x11/3ddesktop/files/patch-3ddesk.cpp
@@ -0,0 +1,10 @@
+--- 3ddesk.cpp.orig Mon May 10 01:44:54 2004
++++ 3ddesk.cpp Thu Aug 26 22:59:52 2004
+@@ -22,6 +22,7 @@
+ #include <stdlib.h>
+ #include <errno.h>
+ #include <sys/types.h>
++#include <sys/time.h>
+ #include <sys/ipc.h>
+ #include <sys/msg.h>
+ #include <string.h>
diff --git a/x11/3ddesktop/files/patch-util.h b/x11/3ddesktop/files/patch-util.h
new file mode 100644
index 000000000000..6a585edb22ca
--- /dev/null
+++ b/x11/3ddesktop/files/patch-util.h
@@ -0,0 +1,11 @@
+--- util.h.orig Mon May 10 00:57:26 2004
++++ util.h Thu Aug 26 23:00:45 2004
+@@ -21,7 +21,7 @@
+ #ifndef _UTIL_H
+ #define _UTIL_H
+ #include <math.h> // for cos
+-#include <endian.h>
++#include <sys/endian.h>
+ #include "3ddesk.h"
+
+ #define MAX_FACES 30 // this is a lot
diff --git a/x11/3ddesktop/pkg-plist b/x11/3ddesktop/pkg-plist
deleted file mode 100644
index 137eae63b9d7..000000000000
--- a/x11/3ddesktop/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-bin/3ddesk
-bin/3ddeskd
-etc/3ddesktop.conf
-share/3ddesktop/digits.bmp
-%%PORTDOCS%%share/doc/3ddesktop/README
-%%PORTDOCS%%share/doc/3ddesktop/README.windowmanagers
-%%PORTDOCS%%@dirrm share/doc/3ddesktop
-@dirrm share/3ddesktop